summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-09-03 21:34:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-09-03 21:34:20 +0000
commit7f3f571c38fbe7584ef63c536d366698cfeb119d (patch)
tree967576948d02b4602d76ff33a0e397df35d7af53 /dev-ml/ocamlnet
parentSecurity bump wrt bug 354345 (diff)
downloadgentoo-2-7f3f571c38fbe7584ef63c536d366698cfeb119d.tar.gz
gentoo-2-7f3f571c38fbe7584ef63c536d366698cfeb119d.tar.bz2
gentoo-2-7f3f571c38fbe7584ef63c536d366698cfeb119d.zip
version bump
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ChangeLog7
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 321a8fb4cf04..09c4547169c7 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.77 2013/08/19 13:13:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.78 2013/09/03 21:34:20 aballier Exp $
+
+*ocamlnet-3.7.3 (03 Sep 2013)
+
+ 03 Sep 2013; Alexis Ballier <aballier@gentoo.org> +ocamlnet-3.7.3.ebuild:
+ version bump
19 Aug 2013; Alexis Ballier <aballier@gentoo.org> ocamlnet-3.6.6.ebuild,
+files/ocamlnet-3.6.6-ocaml-4.01.patch:
diff --git a/dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild b/dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild
new file mode 100644
index 000000000000..4dcdbf85c2a3
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild,v 1.1 2013/09/03 21:34:20 aballier Exp $
+
+EAPI="5"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="ZLIB GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND=">=dev-ml/findlib-1.0
+ pcre? ( >=dev-ml/pcre-ocaml-5:= )
+ >=dev-lang/ocaml-3.10.2:=[tk?,ocamlopt?]
+ cryptokit? ( dev-ml/cryptokit:= )
+ gtk? ( >=dev-ml/lablgtk-2:= )
+ ssl? ( >=dev-ml/ocaml-ssl-0.4:= )
+ zip? ( dev-ml/camlzip:= )
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable cryptokit crypto) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}