summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-23 20:30:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-23 20:30:06 +0000
commit7953ed830fae75044b0fb3267581660dd7ef0449 (patch)
tree007f6106fd2e4b54c685fe8031a475aa051fa45f /dev-ml/ocamlnet
parentremove old (diff)
downloadgentoo-2-7953ed830fae75044b0fb3267581660dd7ef0449.tar.gz
gentoo-2-7953ed830fae75044b0fb3267581660dd7ef0449.tar.bz2
gentoo-2-7953ed830fae75044b0fb3267581660dd7ef0449.zip
version bump
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ChangeLog9
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.5.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index ccc104e4e768..a14011a1a59c 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlnet
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.54 2011/11/02 15:05:41 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.55 2012/02/23 20:30:06 aballier Exp $
+
+*ocamlnet-3.5 (23 Feb 2012)
+
+ 23 Feb 2012; Alexis Ballier <aballier@gentoo.org> +ocamlnet-3.5.ebuild:
+ version bump
*ocamlnet-3.4.1 (02 Nov 2011)
diff --git a/dev-ml/ocamlnet/ocamlnet-3.5.ebuild b/dev-ml/ocamlnet/ocamlnet-3.5.ebuild
new file mode 100644
index 000000000000..0034a66a1a12
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-3.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.5.ebuild,v 1.1 2012/02/23 20:30:06 aballier Exp $
+
+EAPI="2"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND=">=dev-ml/findlib-1.0
+ pcre? ( >=dev-ml/pcre-ocaml-5 )
+ >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
+ cryptokit? ( dev-ml/cryptokit )
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( >=dev-ml/ocaml-ssl-0.4 )
+ zip? ( dev-ml/camlzip )
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable cryptokit crypto) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make failed"
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}