summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-30 11:42:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-30 11:42:23 +0000
commit2f5200fb80ec01b19355a13081636e6c180a6085 (patch)
treeeae597ede0f76242c77dffc96587aff602a2082c /dev-ml/ocaml-sha
parentKeyword ~mips, requested by scarabeus (diff)
downloadgentoo-2-2f5200fb80ec01b19355a13081636e6c180a6085.tar.gz
gentoo-2-2f5200fb80ec01b19355a13081636e6c180a6085.tar.bz2
gentoo-2-2f5200fb80ec01b19355a13081636e6c180a6085.zip
version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocaml-sha')
-rw-r--r--dev-ml/ocaml-sha/ChangeLog7
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ml/ocaml-sha/ChangeLog b/dev-ml/ocaml-sha/ChangeLog
index 2ec1922a34f1..35a607d9d52b 100644
--- a/dev-ml/ocaml-sha/ChangeLog
+++ b/dev-ml/ocaml-sha/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-sha
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sha/ChangeLog,v 1.1 2012/08/02 13:42:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sha/ChangeLog,v 1.2 2012/10/30 11:42:23 aballier Exp $
+
+*ocaml-sha-1.8 (30 Oct 2012)
+
+ 30 Oct 2012; Alexis Ballier <aballier@gentoo.org> +ocaml-sha-1.8.ebuild:
+ version bump
*ocaml-sha-1.7 (02 Aug 2012)
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
new file mode 100644
index 000000000000..637cbba1406c
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild,v 1.1 2012/10/30 11:42:23 aballier Exp $
+
+EAPI=4
+
+inherit findlib vcs-snapshot
+
+DESCRIPTION="A binding for SHA interface code in OCaml"
+HOMEPAGE="http://github.com/vincenthz/ocaml-sha"
+SRC_URI="http://nodeload.github.com/vincenthz/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.12[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README
+}