summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-19 13:39:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-19 13:39:23 +0000
commite522d884eb9db1ff48ef0384d8266da141a176da (patch)
tree02c285d05c1165e78f8982b58d64620a90b1e87d /dev-ml/ocaml-mysql
parentStable for ppc, wrt bug #480562 (diff)
downloadgentoo-2-e522d884eb9db1ff48ef0384d8266da141a176da.tar.gz
gentoo-2-e522d884eb9db1ff48ef0384d8266da141a176da.tar.bz2
gentoo-2-e522d884eb9db1ff48ef0384d8266da141a176da.zip
EAPI5, define suslot and add := dep on ocaml
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocaml-mysql')
-rw-r--r--dev-ml/ocaml-mysql/ChangeLog7
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild16
2 files changed, 13 insertions, 10 deletions
diff --git a/dev-ml/ocaml-mysql/ChangeLog b/dev-ml/ocaml-mysql/ChangeLog
index 680d638b42b6..ef8975ccd75d 100644
--- a/dev-ml/ocaml-mysql/ChangeLog
+++ b/dev-ml/ocaml-mysql/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ocaml-mysql
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ChangeLog,v 1.11 2012/05/23 23:36:02 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ChangeLog,v 1.12 2013/08/19 13:39:23 aballier Exp $
+
+ 19 Aug 2013; Alexis Ballier <aballier@gentoo.org> ocaml-mysql-1.1.1.ebuild:
+ EAPI5, define suslot and add := dep on ocaml
*ocaml-mysql-1.1.1 (23 May 2012)
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild
index c1031ffc88b9..b8de0ea9b547 100644
--- a/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild,v 1.1 2012/05/23 23:36:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild,v 1.2 2013/08/19 13:39:23 aballier Exp $
-EAPI="2"
+EAPI=5
inherit findlib eutils
@@ -12,28 +12,28 @@ DESCRIPTION="A package for ocaml that provides access to mysql databases."
SRC_URI="http://forge.ocamlcore.org/frs/download.php/870/${P}.tar.gz"
HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
-DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
sys-libs/zlib
>=virtual/mysql-4.0"
RDEPEND="$DEPEND"
-SLOT="0"
+SLOT="0/${PV}"
LICENSE="LGPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
src_compile()
{
- emake all || die "make failed"
+ emake all
if use ocamlopt; then
- emake opt || die "make opt failed"
+ emake opt
fi
}
src_install()
{
findlib_src_preinst
- emake install || die "make install failed"
+ emake install
dodoc CHANGES README VERSION || die
}