summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-17 07:14:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-17 07:14:08 +0000
commitaea870f49c30f43a833b18d21e940ab146356586 (patch)
tree66a8bc6b63422b3d665f117b8823faac1151e1d1 /dev-ml/lwt
parentversion bump (diff)
downloadgentoo-2-aea870f49c30f43a833b18d21e940ab146356586.tar.gz
gentoo-2-aea870f49c30f43a833b18d21e940ab146356586.tar.bz2
gentoo-2-aea870f49c30f43a833b18d21e940ab146356586.zip
eapi2ify, by Olivier Huber <oli.huber@gmail.com>, bug #268933
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/lwt')
-rw-r--r--dev-ml/lwt/ChangeLog7
-rw-r--r--dev-ml/lwt/lwt-1.1.0.ebuild21
2 files changed, 11 insertions, 17 deletions
diff --git a/dev-ml/lwt/ChangeLog b/dev-ml/lwt/ChangeLog
index 19a9d6ab4333..29f5f70ce55c 100644
--- a/dev-ml/lwt/ChangeLog
+++ b/dev-ml/lwt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/lwt
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/ChangeLog,v 1.2 2008/09/25 12:21:10 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/ChangeLog,v 1.3 2009/06/17 07:14:08 aballier Exp $
+
+ 17 Jun 2009; Alexis Ballier <aballier@gentoo.org> lwt-1.1.0.ebuild:
+ eapi2ify, by Olivier Huber <oli.huber@gmail.com>, bug #268933
25 Sep 2008; Alexis Ballier <aballier@gentoo.org> lwt-1.1.0.ebuild:
keyword ~x86-fbsd
diff --git a/dev-ml/lwt/lwt-1.1.0.ebuild b/dev-ml/lwt/lwt-1.1.0.ebuild
index 0295a4b27d26..025ab6f24836 100644
--- a/dev-ml/lwt/lwt-1.1.0.ebuild
+++ b/dev-ml/lwt/lwt-1.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/lwt-1.1.0.ebuild,v 1.2 2008/09/25 12:21:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/lwt-1.1.0.ebuild,v 1.3 2009/06/17 07:14:08 aballier Exp $
-EAPI=1
+EAPI=2
inherit findlib eutils
@@ -10,27 +10,18 @@ DESCRIPTION="Cooperative light-weight thread library for OCaml"
SRC_URI="http://ocsigen.org/download/${P}.tar.gz"
HOMEPAGE="http://ocsigen.org/lwt"
-DEPEND=">=dev-lang/ocaml-3.10
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
>=dev-ml/ocaml-ssl-0.4.0"
RDEPEND="${DEPEND}
!<www-servers/ocsigen-1.1"
-IUSE="doc +ocamlopt"
-
SLOT="0"
LICENSE="LGPL-2.1 LGPL-2.1-linking-exception"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
src_compile() {
# ocamlbuild is stupid and fails parallel make if it does not exist...
mkdir _build