summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-06-29 04:39:55 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-06-29 04:39:55 +0000
commiteda9a1c2c31e47026770a782c66468ad5930031f (patch)
treeb204eeb781eba094ecf415922e11089b3288cbbd /dev-ml/lablgl
parentversion bump (diff)
downloadgentoo-2-eda9a1c2c31e47026770a782c66468ad5930031f.tar.gz
gentoo-2-eda9a1c2c31e47026770a782c66468ad5930031f.tar.bz2
gentoo-2-eda9a1c2c31e47026770a782c66468ad5930031f.zip
added new category dev-ml, which is supposed to keep ocaml and other
statically compiled ml language related packages. added first ocaml related package - lablgl.
Diffstat (limited to 'dev-ml/lablgl')
-rw-r--r--dev-ml/lablgl/ChangeLog14
-rw-r--r--dev-ml/lablgl/files/LablGL-0.97-Makefile-destdir.patch34
-rw-r--r--dev-ml/lablgl/files/LablGL-0.97-Makefile.config59
-rw-r--r--dev-ml/lablgl/files/digest-lablgl-0.971
-rw-r--r--dev-ml/lablgl/lablgl-0.97.ebuild43
5 files changed, 151 insertions, 0 deletions
diff --git a/dev-ml/lablgl/ChangeLog b/dev-ml/lablgl/ChangeLog
new file mode 100644
index 000000000000..b3904ef558f8
--- /dev/null
+++ b/dev-ml/lablgl/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for dev-ml/lablgl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.1 2002/06/29 04:39:55 george Exp $
+
+*lablgl-0.97.ebuild (28 Jun 2002)
+
+ 28 Jun 2002; G Shapovalov <george@gentoo.org> all :
+
+ initial release
+ form the README:
+ LablGL is an OpenGL interface for Objective Caml. Since it includes
+ support for the Togl widget, you can comfortably use it with LablTk.
+
+ ebuild submitted by Bardur Arantsson <bardur-gta@odense.kollegienet.dk>
diff --git a/dev-ml/lablgl/files/LablGL-0.97-Makefile-destdir.patch b/dev-ml/lablgl/files/LablGL-0.97-Makefile-destdir.patch
new file mode 100644
index 000000000000..46204fa57534
--- /dev/null
+++ b/dev-ml/lablgl/files/LablGL-0.97-Makefile-destdir.patch
@@ -0,0 +1,34 @@
+--- Makefile.orig 2002-05-29 20:04:00.000000000 +0200
++++ Makefile 2002-05-29 20:28:16.000000000 +0200
+@@ -103,22 +103,21 @@
+ @$(MAKE) real-install LIBDIR=$(LIBDIR)
+
+ real-install:
+- if test -d $(INSTALLDIR); then : ; else mkdir -p $(INSTALLDIR); fi
+- if test `grep -s -c '^$(INSTALLDIR)$$' $(LIBDIR)/ld.conf || :` = 0; \
+- then echo $(INSTALLDIR) >> $(LIBDIR)/ld.conf; fi
+- cp $(MLOBJS:.cmo=.cmi) $(INSTALLDIR)
+- cp $(MLOBJS:.cmo=.mli) $(INSTALLDIR)
+- cp liblablgl.a lablgl.cma libtogl.a togl.cma $(INSTALLDIR)
+- cp lablgltop $(INSTALLDIR)
+- cp lablgl $(BINDIR)
++ mkdir -p $(DESTDIR)$(INSTALLDIR)
++ mkdir -p $(DESTDIR)$(BINDIR)
++ cp $(MLOBJS:.cmo=.cmi) $(DESTDIR)$(INSTALLDIR)
++ cp $(MLOBJS:.cmo=.mli) $(DESTDIR)$(INSTALLDIR)
++ cp liblablgl.a lablgl.cma libtogl.a togl.cma $(DESTDIR)$(INSTALLDIR)
++ cp lablgltop $(DESTDIR)$(INSTALLDIR)
++ cp lablgl $(DESTDIR)$(BINDIR)
+ @if test -f dlllablgl.so; then $(MAKE) installdll; fi
+ @if test -f lablgl.cmxa; then $(MAKE) installopt LIBDIR=$(LIBDIR); fi
+
+ installdll:
+- cp dlllablgl.so dlltogl.so $(INSTALLDIR)
++ cp dlllablgl.so dlltogl.so $(DESTDIR)$(INSTALLDIR)
+
+ installopt:
+- cp lablgl.cmxa lablgl.a togl.cmxa togl.a $(MLOBJS:.cmo=.cmx) $(INSTALLDIR)
++ cp lablgl.cmxa lablgl.a togl.cmxa togl.a $(MLOBJS:.cmo=.cmx) $(DESTDIR)$(INSTALLDIR)
+
+ clean:
+ rm -f *.cm* *.a *.o *.opt *_tags.c *_tags.h *~ \
diff --git a/dev-ml/lablgl/files/LablGL-0.97-Makefile.config b/dev-ml/lablgl/files/LablGL-0.97-Makefile.config
new file mode 100644
index 000000000000..b1373bd6d774
--- /dev/null
+++ b/dev-ml/lablgl/files/LablGL-0.97-Makefile.config
@@ -0,0 +1,59 @@
+# LablGL and Togl configuration file
+#
+# Please have a look at the config/Makefile in the Objective Caml distribution,
+# or at the labltklink script to get the information needed here
+#
+
+##### Adjust these always
+
+# Where to put the lablgl script
+BINDIR = /usr/bin
+
+# Where to find X headers
+XINCLUDES = -I/usr/X11R6/include
+# X libs (for broken RTLD_GLOBAL: e.g. FreeBSD 4.0)
+XLIBS = -L/usr/X11R6/lib -lXext -lXmu -lX11
+
+# Where to find Tcl/Tk headers
+# This must the same version as for LablTk
+#TKINCLUDES = -I/usr/local/include
+# Tcl/Tk libs (for broken RTLD_GLOBAL: e.g. FreeBSD 4.0)
+#TKLIBS = -L/usr/local/lib -ltk83 -ltcl83
+
+# Where to find OpenGL/Mesa headers and libraries
+GLINCLUDES =
+GLLIBS = -lGL -lGLU
+# The following libraries may be required (try to add them one at a time)
+# GLLIBS = -lGL -lGLU -lXmu -lXext -lpthread
+
+# How to index a library
+RANLIB = ranlib
+#RANLIB = :
+
+##### Adjust these if non standard
+
+# The Objective Caml library directory
+LIBDIR = `ocamlc -where`
+
+# Where is LablTk (standard)
+LABLTKDIR = $(LIBDIR)/labltk
+
+# Where to put LablGL (standard)
+INSTALLDIR = $(LIBDIR)/lablGL
+
+# Where is Togl (default)
+TOGLDIR = Togl
+
+# C Compiler options
+COPTS = -c -O
+
+###### No need to change these
+
+# Where to find tcl.h, tk.h, OpenGL/Mesa headers, etc:
+INCLUDES = $(TKINCLUDES) $(GLINCLUDES) $(XINCLUDES)
+
+# Libraries to link with:
+LIBS = $(TKLIBS) $(GLLIBS) $(XLIBS)
+
+# Leave this empty
+LIBDIRS =
diff --git a/dev-ml/lablgl/files/digest-lablgl-0.97 b/dev-ml/lablgl/files/digest-lablgl-0.97
new file mode 100644
index 000000000000..d63def5015cf
--- /dev/null
+++ b/dev-ml/lablgl/files/digest-lablgl-0.97
@@ -0,0 +1 @@
+MD5 e084a62ff47492cade8887f3f6b60c5b lablgl-0.97.tar.gz 242693
diff --git a/dev-ml/lablgl/lablgl-0.97.ebuild b/dev-ml/lablgl/lablgl-0.97.ebuild
new file mode 100644
index 000000000000..16c768de7abd
--- /dev/null
+++ b/dev-ml/lablgl/lablgl-0.97.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-0.97.ebuild,v 1.1 2002/06/29 04:39:55 george Exp $
+
+DESCRIPTION="Objective CAML interface for OpenGL"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html"
+LICENSE="as-is"
+
+DEPEND=">=dev-lang/ocaml-3.04
+ opengl? ( virtual/opengl )"
+RDEPEND="${DEPEND}"
+
+SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz"
+S=${WORKDIR}/lablGL-${PV}
+SLOT="0"
+
+#need to do some mangling to keep ebuild name lowercase
+#(anyway package uses mixture of upper and lower case letters)
+Name="LablGL"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # patch the makefile to include DESTDIR support
+ cd ${S} || die
+ patch -p0 < ${FILESDIR}/${Name}-${PV}-Makefile-destdir.patch || die
+}
+
+src_compile() {
+
+ # make configuration file
+ cp ${FILESDIR}/${Name}-${PV}-Makefile.config ${S}/Makefile.config || die
+
+ # build
+ make all opt || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc README CHANGES COPYRIGHT
+}