summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-02 18:00:28 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-02 18:00:28 +0000
commit41afc0f55badd3c988c9251c1a8f7730f9eae026 (patch)
treeb976e0f7d403ef155fdbd63b29498988ec36d51c /dev-ml/lablgl
parentUse pkg-config to get libncurses libraries, like libtinfo wrt #454322 by "Gri... (diff)
downloadgentoo-2-41afc0f55badd3c988c9251c1a8f7730f9eae026.tar.gz
gentoo-2-41afc0f55badd3c988c9251c1a8f7730f9eae026.tar.bz2
gentoo-2-41afc0f55badd3c988c9251c1a8f7730f9eae026.zip
Drop togl as it does not build with recent tk versions; eapi5 and use slot deps
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/lablgl')
-rw-r--r--dev-ml/lablgl/ChangeLog10
-rw-r--r--dev-ml/lablgl/lablgl-1.04-r1.ebuild93
2 files changed, 101 insertions, 2 deletions
diff --git a/dev-ml/lablgl/ChangeLog b/dev-ml/lablgl/ChangeLog
index aea9d3b20f09..4a989888d517 100644
--- a/dev-ml/lablgl/ChangeLog
+++ b/dev-ml/lablgl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/lablgl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.61 2012/10/06 20:46:11 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.62 2013/03/02 18:00:28 aballier Exp $
+
+*lablgl-1.04-r1 (02 Mar 2013)
+
+ 02 Mar 2013; Alexis Ballier <aballier@gentoo.org> +lablgl-1.04-r1.ebuild:
+ Drop togl as it does not build with recent tk versions; eapi5 and use slot
+ deps
06 Oct 2012; Alexis Ballier <aballier@gentoo.org> lablgl-1.04.ebuild:
add missing virutal/glu dep, bug #434456
diff --git a/dev-ml/lablgl/lablgl-1.04-r1.ebuild b/dev-ml/lablgl/lablgl-1.04-r1.ebuild
new file mode 100644
index 000000000000..cc7977a39b26
--- /dev/null
+++ b/dev-ml/lablgl/lablgl-1.04-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.04-r1.ebuild,v 1.1 2013/03/02 18:00:28 aballier Exp $
+
+EAPI="5"
+
+inherit multilib eutils toolchain-funcs
+
+IUSE="doc glut +ocamlopt"
+#tk"
+
+DESCRIPTION="Objective CAML interface for OpenGL"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html"
+LICENSE="BSD"
+
+# >=dev-lang/ocaml-3.10.2:=[tk?,ocamlopt?]
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libX11
+ virtual/opengl
+ virtual/glu
+ glut? ( media-libs/freeglut )
+ "
+# tk? ( >=dev-lang/tcl-8.3 >=dev-lang/tk-8.3 )
+
+DEPEND="${RDEPEND}"
+
+SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+S=${WORKDIR}/lablGL-${PV}
+
+src_configure() {
+ # make configuration file
+ echo "BINDIR=/usr/bin" > Makefile.config
+ echo "GLLIBS = -lGL -lGLU" >> Makefile.config
+ if use glut; then
+ echo "GLUTLIBS = -lglut" >> Makefile.config
+ else
+ echo "GLUTLIBS = " >> Makefile.config
+ fi
+ echo "XLIBS = -lXext -lXmu -lX11" >> Makefile.config
+ echo "RANLIB = $(tc-getRANLIB)" >> Makefile.config
+ echo 'COPTS = -c -O $(CFLAGS)' >> Makefile.config
+ echo 'INCLUDES = $(TKINCLUDES) $(GLINCLUDES) $(XINCLUDES)' >> Makefile.config
+}
+
+src_compile() {
+ #if use tk; then
+ # emake -j1 togl || die "failed to build togl"
+ # if use ocamlopt; then
+ # emake -j1 toglopt || die "failed to build native code togl"
+ # fi
+ #fi
+
+ emake -j1 lib || die "failed to build the library"
+ if use ocamlopt; then
+ emake -j1 libopt || die "failed to build native code library"
+ fi
+
+ if use glut; then
+ emake -j1 glut || die "failed to build glut"
+ if use ocamlopt; then
+ emake -j1 glutopt || die "failed to build native code glutopt"
+ fi
+ fi
+}
+
+src_install () {
+ # Makefile do not use mkdir so the library is not installed
+ # but copied as a 'stublibs' file.
+ dodir /usr/$(get_libdir)/ocaml/stublibs
+
+ # Same for lablglut's toplevel
+ dodir /usr/bin
+
+ BINDIR=${ED}/usr/bin
+ BASE=${ED}/usr/$(get_libdir)/ocaml
+ emake BINDIR="${BINDIR}" INSTALLDIR="${BASE}/lablGL" DLLDIR="${BASE}/stublibs" install || die "make install failed"
+
+ dodoc README CHANGES
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ mv Togl/examples{,.togl}
+ doins -r Togl/examples.togl
+
+ mv LablGlut/examples{,.glut}
+ doins -r LablGlut/examples.glut
+ fi
+}