summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-13 06:00:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-13 06:00:23 +0000
commit3e990897c9560b6af8b54d28f1856f777a50606f (patch)
tree2cb6a3005fcffd15f6f4925305f0337089528381 /dev-ml/lablgl
parentEAPI=2 (diff)
downloadgentoo-2-3e990897c9560b6af8b54d28f1856f777a50606f.tar.gz
gentoo-2-3e990897c9560b6af8b54d28f1856f777a50606f.tar.bz2
gentoo-2-3e990897c9560b6af8b54d28f1856f777a50606f.zip
remove old
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/lablgl')
-rw-r--r--dev-ml/lablgl/ChangeLog6
-rw-r--r--dev-ml/lablgl/files/lablgl-1.03-tk8.5.patch12
-rw-r--r--dev-ml/lablgl/lablgl-1.03-r1.ebuild109
3 files changed, 5 insertions, 122 deletions
diff --git a/dev-ml/lablgl/ChangeLog b/dev-ml/lablgl/ChangeLog
index a9c3131b95ba..6c2abab98736 100644
--- a/dev-ml/lablgl/ChangeLog
+++ b/dev-ml/lablgl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/lablgl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.58 2009/10/12 23:14:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.59 2009/10/13 06:00:23 aballier Exp $
+
+ 13 Oct 2009; Alexis Ballier <aballier@gentoo.org> -lablgl-1.03-r1.ebuild,
+ -files/lablgl-1.03-tk8.5.patch:
+ remove old
12 Oct 2009; Jeroen Roovers <jer@gentoo.org> lablgl-1.04.ebuild:
Stable for HPPA (bug #285693).
diff --git a/dev-ml/lablgl/files/lablgl-1.03-tk8.5.patch b/dev-ml/lablgl/files/lablgl-1.03-tk8.5.patch
deleted file mode 100644
index c5421a170fcf..000000000000
--- a/dev-ml/lablgl/files/lablgl-1.03-tk8.5.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur --exclude '*~' lablgl-1.02/Togl/src/Togl/togl.c lablgl-1.02.tk8.5/Togl/src/Togl/togl.c
---- lablgl-1.02/Togl/src/Togl/togl.c 2004-11-02 08:03:34.000000000 +0100
-+++ lablgl-1.02.tk8.5/Togl/src/Togl/togl.c 2007-09-01 18:37:15.000000000 +0200
-@@ -148,6 +148,8 @@
- # include "tkInt8.3.h"
- #elif TK_MAJOR_VERSION==8 && TK_MINOR_VERSION==4
- # include "tkInt8.4.h"
-+#elif TK_MAJOR_VERSION==8 && TK_MINOR_VERSION==5
-+# include "tkInt8.4.h"
- #else
- Sorry, you will have to edit togl.c to include the right tkInt.h file
- #endif
diff --git a/dev-ml/lablgl/lablgl-1.03-r1.ebuild b/dev-ml/lablgl/lablgl-1.03-r1.ebuild
deleted file mode 100644
index 6e059d5ab6dd..000000000000
--- a/dev-ml/lablgl/lablgl-1.03-r1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.03-r1.ebuild,v 1.8 2009/06/21 13:29:11 aballier Exp $
-
-EAPI="1"
-
-inherit multilib eutils toolchain-funcs
-
-IUSE="doc glut +ocamlopt tk"
-
-DESCRIPTION="Objective CAML interface for OpenGL"
-HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html"
-LICENSE="BSD"
-
-RDEPEND=">=dev-lang/ocaml-3.05
- virtual/opengl
- x11-libs/libXext
- x11-libs/libXmu
- x11-libs/libX11
- glut? ( virtual/glut )
- tk? ( >=dev-lang/tcl-8.3
- >=dev-lang/tk-8.3 )"
-DEPEND="${RDEPEND}"
-
-SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86 ~x86-fbsd"
-
-pkg_setup() {
- if use tk && ! built_with_use dev-lang/ocaml tk ; then
- eerror "You don't have ocaml compiled with tk support"
- eerror ""
- eerror "lablgl requires ocaml be built with tk support."
- eerror ""
- eerror "Please recompile ocaml with tk useflag enabled."
- die "Ocaml is missing tk support"
- fi
-
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-tk8.5.patch"
-}
-
-src_compile() {
- # make configuration file
- echo "BINDIR=/usr/bin" > Makefile.config
- echo "GLLIBS = -lGL -lGLU" >> Makefile.config
- if use glut; then
- echo "GLUTLIBS = -lglut" >> Makefile.config
- else
- echo "GLUTLIBS = " >> Makefile.config
- fi
- echo "XLIBS = -lXext -lXmu -lX11" >> Makefile.config
- echo "RANLIB = $(tc-getRANLIB)" >> Makefile.config
- echo 'COPTS = -c -O $(CFLAGS)' >> Makefile.config
- echo 'INCLUDES = $(TKINCLUDES) $(GLINCLUDES) $(XINCLUDES)' >> Makefile.config
-
- if use tk; then
- emake -j1 togl || die "failed to build togl"
- if use ocamlopt; then
- emake -j1 toglopt || die "failed to build native code togl"
- fi
- fi
-
- emake -j1 lib || die "failed to build the library"
- if use ocamlopt; then
- emake -j1 libopt || die "failed to build native code library"
- fi
-
- if use glut; then
- emake -j1 glut || die "failed to build glut"
- if use ocamlopt; then
- emake -j1 glutopt || die "failed to build native code glutopt"
- fi
- fi
-}
-
-src_install () {
- # Makefile do not use mkdir so the library is not installed
- # but copied as a 'stublibs' file.
- dodir /usr/$(get_libdir)/ocaml/stublibs
-
- # Same for lablglut's toplevel
- dodir /usr/bin
-
- BINDIR=${D}/usr/bin
- BASE=${D}/usr/$(get_libdir)/ocaml
- emake BINDIR="${BINDIR}" INSTALLDIR="${BASE}/lablGL" DLLDIR="${BASE}/stublibs" install || die "make install failed"
-
- dodoc README CHANGES
-
- if use doc ; then
- insinto /usr/share/doc/${PF}
- mv Togl/examples{,.togl}
- doins -r Togl/examples.togl
-
- mv LablGlut/examples{,.glut}
- doins -r LablGlut/examples.glut
- fi
-}