summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-12-11 19:19:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-12-11 19:19:07 +0000
commit3e1a3ae221b9e87cfc1c65390f778cb7ceeb8bfc (patch)
tree3ec13c4dc064256ade0b8a4d2f45a4d19188b34d /dev-ml/js_of_ocaml
parentbump to 2.0.19 (diff)
downloadgentoo-2-3e1a3ae221b9e87cfc1c65390f778cb7ceeb8bfc.tar.gz
gentoo-2-3e1a3ae221b9e87cfc1c65390f778cb7ceeb8bfc.tar.bz2
gentoo-2-3e1a3ae221b9e87cfc1c65390f778cb7ceeb8bfc.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/js_of_ocaml')
-rw-r--r--dev-ml/js_of_ocaml/ChangeLog7
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-1.4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ml/js_of_ocaml/ChangeLog b/dev-ml/js_of_ocaml/ChangeLog
index 9edefbc33be0..69f3e30476be 100644
--- a/dev-ml/js_of_ocaml/ChangeLog
+++ b/dev-ml/js_of_ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/js_of_ocaml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/ChangeLog,v 1.4 2013/07/23 17:42:30 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/ChangeLog,v 1.5 2013/12/11 19:19:07 aballier Exp $
+
+*js_of_ocaml-1.4 (11 Dec 2013)
+
+ 11 Dec 2013; Alexis Ballier <aballier@gentoo.org> +js_of_ocaml-1.4.ebuild:
+ version bump
23 Jul 2013; Alexis Ballier <aballier@gentoo.org> js_of_ocaml-1.3.2.ebuild:
eapi5, define subslot and add slot deps
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-1.4.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-1.4.ebuild
new file mode 100644
index 000000000000..b94f6fe84497
--- /dev/null
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/js_of_ocaml-1.4.ebuild,v 1.1 2013/12/11 19:19:07 aballier Exp $
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A compiler from OCaml bytecode to javascript"
+HOMEPAGE="http://ocsigen.org/js_of_ocaml/"
+SRC_URI="http://www.ocsigen.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt doc +deriving-ocsigen"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ >=dev-ml/lwt-2.3.0:=
+ deriving-ocsigen? ( >=dev-ml/deriving-ocsigen-0.3:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ use ocamlopt || echo "BEST := byte" >> Makefile.conf
+ use deriving-ocsigen || echo "DERIVING :=" >> Makefile.conf
+}
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_install() {
+ findlib_src_preinst
+ emake BINDIR="${ED}/usr/bin/" install
+ dodoc CHANGES README
+ use doc && dohtml -r doc/api-html
+}