summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-10 13:04:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-10 13:04:33 +0000
commita18b6e0a8f9da25741939ca7adb292b091a53b0f (patch)
treef965e73397df1c48160e2d228589364e894f5c11 /dev-ml/facile
parentAdd spanish (es) description (diff)
downloadgentoo-2-a18b6e0a8f9da25741939ca7adb292b091a53b0f.tar.gz
gentoo-2-a18b6e0a8f9da25741939ca7adb292b091a53b0f.tar.bz2
gentoo-2-a18b6e0a8f9da25741939ca7adb292b091a53b0f.zip
fix build with ocaml4
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/facile')
-rw-r--r--dev-ml/facile/ChangeLog8
-rw-r--r--dev-ml/facile/facile-1.1.ebuild5
-rw-r--r--dev-ml/facile/files/facile-1.1-ocaml4.patch29
3 files changed, 38 insertions, 4 deletions
diff --git a/dev-ml/facile/ChangeLog b/dev-ml/facile/ChangeLog
index ce0995a080ac..c5ca862acb0c 100644
--- a/dev-ml/facile/ChangeLog
+++ b/dev-ml/facile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/facile
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/ChangeLog,v 1.18 2011/01/03 21:12:19 dilfridge Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/ChangeLog,v 1.19 2012/10/10 13:04:33 aballier Exp $
+
+ 10 Oct 2012; Alexis Ballier <aballier@gentoo.org> facile-1.1.ebuild,
+ +files/facile-1.1-ocaml4.patch:
+ fix build with ocaml4
03 Jan 2011; Andreas K. Huettel <dilfridge@gentoo.org> facile-1.1.ebuild:
Removed RESTRICT=mirror since there is no reason for it
diff --git a/dev-ml/facile/facile-1.1.ebuild b/dev-ml/facile/facile-1.1.ebuild
index 389b1f490307..7114a5c64f88 100644
--- a/dev-ml/facile/facile-1.1.ebuild
+++ b/dev-ml/facile/facile-1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.18 2011/01/03 21:12:19 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.19 2012/10/10 13:04:33 aballier Exp $
EAPI="2"
@@ -23,6 +23,7 @@ DEPEND="${RDEPEND}
src_prepare() {
# Fix building on FreeBSD
epatch "${FILESDIR}/${P}"-make.patch
+ has_version '>=dev-lang/ocaml-4' && epatch "${FILESDIR}/${P}-ocaml4.patch"
# Disable building native code objects if we dont have/want ocamlopt
if ! use ocamlopt; then
sed -i -e 's/\.opt//' src/Makefile || die "failed to change native code compiler to bytecode ones"
diff --git a/dev-ml/facile/files/facile-1.1-ocaml4.patch b/dev-ml/facile/files/facile-1.1-ocaml4.patch
new file mode 100644
index 000000000000..3c7556312364
--- /dev/null
+++ b/dev-ml/facile/files/facile-1.1-ocaml4.patch
@@ -0,0 +1,29 @@
+Index: facile-1.1/src/facile.mli
+===================================================================
+--- facile-1.1.orig/src/facile.mli
++++ facile-1.1/src/facile.mli
+@@ -127,7 +127,7 @@ module Data :
+ module Hashtbl :
+ sig
+ type ('a, 'b) t
+- val create : int -> ('a, 'b) t
++ val create : ?random:bool -> int -> ('a, 'b) t
+ val get : ('a, 'b) t -> ('a, 'b) Hashtbl.t
+ val add : ('a, 'b) t -> 'a -> 'b -> unit
+ val find : ('a, 'b) t -> 'a -> 'b
+Index: facile-1.1/src/fcl_data.cmi
+===================================================================
+Binary files facile-1.1.orig/src/fcl_data.cmi and facile-1.1/src/fcl_data.cmi differ
+Index: facile-1.1/src/fcl_data.mli
+===================================================================
+--- facile-1.1.orig/src/fcl_data.mli
++++ facile-1.1/src/fcl_data.mli
+@@ -23,7 +23,7 @@ end
+
+ module Hashtbl : sig
+ type ('a, 'b) t
+- val create : int -> ('a, 'b) t
++ val create : ?random:bool -> int -> ('a, 'b) t
+ val get : ('a, 'b) t -> ('a, 'b) Hashtbl.t
+ val add : ('a, 'b) t -> 'a -> 'b -> unit
+ val find : ('a, 'b) t -> 'a -> 'b