summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:31:52 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:31:52 +0000
commitfb7c76b83760ea80816e875962c91d97ef33d186 (patch)
treed4476ee63a0664283daddf4ef88b45e1e747d02d /dev-ml/facile/facile-1.1.ebuild
parentMigrate to EAPI 2 in order to nuke built_with_use. (diff)
downloadgentoo-2-fb7c76b83760ea80816e875962c91d97ef33d186.tar.gz
gentoo-2-fb7c76b83760ea80816e875962c91d97ef33d186.tar.bz2
gentoo-2-fb7c76b83760ea80816e875962c91d97ef33d186.zip
Migrate to EAPI 2 in order to nuke built_with_use.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'dev-ml/facile/facile-1.1.ebuild')
-rw-r--r--dev-ml/facile/facile-1.1.ebuild25
1 files changed, 6 insertions, 19 deletions
diff --git a/dev-ml/facile/facile-1.1.ebuild b/dev-ml/facile/facile-1.1.ebuild
index 84da343a60d1..53121d5b6a87 100644
--- a/dev-ml/facile/facile-1.1.ebuild
+++ b/dev-ml/facile/facile-1.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.15 2009/01/21 23:27:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.16 2009/09/28 16:31:52 betelgeuse Exp $
-inherit eutils
+EAPI="2"
-EAPI="1"
+inherit eutils
DESCRIPTION="FaCiLe is a constraint programming library on integer and integer set finite domains written in OCaml."
HOMEPAGE="http://www.recherche.enac.fr/log/facile/"
@@ -17,23 +17,11 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="+ocamlopt"
-RDEPEND=">=dev-lang/ocaml-3.09.3-r1"
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
DEPEND="${RDEPEND}
sys-apps/sed"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Fix building on FreeBSD
epatch "${FILESDIR}/${P}"-make.patch
# Disable building native code objects if we dont have/want ocamlopt
@@ -48,10 +36,9 @@ src_unpack() {
fi
}
-src_compile(){
+src_configure(){
# This is a custom configure script and it does not support standard options
./configure --faciledir "${D}"$(ocamlc -where)/facile/
- emake || die "Compilation failed"
}
src_test() {