summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:33:56 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:33:56 +0000
commitf39287ff0e86448eaf0fe321b85ca841d419dc10 (patch)
treed2daffce178246de16584fc3e3243090510d5e1c /dev-ml/extlib
parentMigrate to EAPI 2 in order to nuke built_with_use. (diff)
downloadgentoo-2-f39287ff0e86448eaf0fe321b85ca841d419dc10.tar.gz
gentoo-2-f39287ff0e86448eaf0fe321b85ca841d419dc10.tar.bz2
gentoo-2-f39287ff0e86448eaf0fe321b85ca841d419dc10.zip
Migrate to EAPI 2 in order to nuke built_with_use.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'dev-ml/extlib')
-rw-r--r--dev-ml/extlib/ChangeLog9
-rw-r--r--dev-ml/extlib/extlib-1.5.1.ebuild23
2 files changed, 13 insertions, 19 deletions
diff --git a/dev-ml/extlib/ChangeLog b/dev-ml/extlib/ChangeLog
index 19da3bcea87a..2e67d0b3e875 100644
--- a/dev-ml/extlib/ChangeLog
+++ b/dev-ml/extlib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/extlib
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.9 2008/04/20 14:20:27 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.10 2009/09/28 16:33:56 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> extlib-1.5.1.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
20 Apr 2008; Alexis Ballier <aballier@gentoo.org>
-files/extlib-1.5-ExtList.remove.patch, -extlib-1.4.ebuild,
@@ -28,7 +31,7 @@
21 Sep 2005; Matthieu Sozeau <mattam@gentoo.org> :
Version bump (fixes #87864).
-*extlib-1.3 (06 Feb 2005)
+*extlib-1.4 (06 Feb 2005)
06 Feb 2005; Matthieu Sozeau <mattam@gentoo.org> -extlib-1.2.ebuild,
+extlib-1.4.ebuild:
diff --git a/dev-ml/extlib/extlib-1.5.1.ebuild b/dev-ml/extlib/extlib-1.5.1.ebuild
index 74632c3926de..38a14ab430c5 100644
--- a/dev-ml/extlib/extlib-1.5.1.ebuild
+++ b/dev-ml/extlib/extlib-1.5.1.ebuild
@@ -1,29 +1,20 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/extlib-1.5.1.ebuild,v 1.4 2008/04/20 14:09:02 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/extlib-1.5.1.ebuild,v 1.5 2009/09/28 16:33:56 betelgeuse Exp $
-inherit findlib eutils
+EAPI="2"
-EAPI="1"
+inherit findlib eutils
DESCRIPTION="Standard library extensions for O'Caml"
HOMEPAGE="http://code.google.com/p/ocaml-extlib/"
SRC_URI="http://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-2.1"
-DEPEND=">=dev-lang/ocaml-3.07"
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="doc +ocamlopt"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
src_compile() {
emake all || die "failed to build"
if use ocamlopt; then
@@ -39,9 +30,9 @@ src_install () {
findlib_src_install
# install documentation
- dodoc README.txt
+ dodoc README.txt || die
if use doc; then
- dohtml doc/*
+ dohtml doc/* || die
fi
}