summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-10 10:44:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-10 10:44:17 +0000
commit8abcb4c5621d6746b7f2a5f860f10ae42ffa66d9 (patch)
treec62cd338c50502b2547a559b75050733adcd91cf /dev-ml/extlib
parentRemove old. (diff)
downloadgentoo-2-8abcb4c5621d6746b7f2a5f860f10ae42ffa66d9.tar.gz
gentoo-2-8abcb4c5621d6746b7f2a5f860f10ae42ffa66d9.tar.bz2
gentoo-2-8abcb4c5621d6746b7f2a5f860f10ae42ffa66d9.zip
eapi5: define subslot, slot dep on ocaml, remove useless || die
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/extlib')
-rw-r--r--dev-ml/extlib/ChangeLog5
-rw-r--r--dev-ml/extlib/extlib-1.5.3.ebuild20
2 files changed, 14 insertions, 11 deletions
diff --git a/dev-ml/extlib/ChangeLog b/dev-ml/extlib/ChangeLog
index e4c8896c9664..02f690dd67ee 100644
--- a/dev-ml/extlib/ChangeLog
+++ b/dev-ml/extlib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/extlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.22 2013/03/10 10:40:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.23 2013/03/10 10:44:17 aballier Exp $
+
+ 10 Mar 2013; Alexis Ballier <aballier@gentoo.org> extlib-1.5.3.ebuild:
+ eapi5: define subslot, slot dep on ocaml, remove useless || die
10 Mar 2013; Alexis Ballier <aballier@gentoo.org> -extlib-1.5.2.ebuild,
-files/extlib-1.5.2-ocaml4.patch:
diff --git a/dev-ml/extlib/extlib-1.5.3.ebuild b/dev-ml/extlib/extlib-1.5.3.ebuild
index 46ecb00b7aea..0fc29e8ffcbe 100644
--- a/dev-ml/extlib/extlib-1.5.3.ebuild
+++ b/dev-ml/extlib/extlib-1.5.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/extlib-1.5.3.ebuild,v 1.4 2012/11/20 20:50:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/extlib-1.5.3.ebuild,v 1.5 2013/03/10 10:44:17 aballier Exp $
-EAPI="2"
+EAPI=5
inherit findlib eutils
@@ -10,20 +10,20 @@ DESCRIPTION="Standard library extensions for O'Caml"
HOMEPAGE="http://code.google.com/p/ocaml-extlib/"
SRC_URI="http://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-2.1"
-DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
RDEPEND="${DEPEND}"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc +ocamlopt"
src_compile() {
- emake all || die "failed to build"
+ emake all
if use ocamlopt; then
- emake opt || die "failed to build"
+ emake opt
fi
if use doc; then
- emake doc || die "failed to create documentation"
+ emake doc
fi
}
@@ -31,9 +31,9 @@ src_install () {
findlib_src_install
# install documentation
- dodoc README.txt || die
+ dodoc README.txt
if use doc; then
- dohtml doc/* || die
+ dohtml doc/*
fi
}