summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-27 12:36:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-27 12:36:35 +0000
commita84558579f06e79cfe41adebcf1fbde00f2a2bf6 (patch)
treed922992780ded018d941a4db6103bf3b8db51cfd /dev-ml/core
parentFix the mess caused by previous commit. SCTP _is_ in tree. (diff)
downloadgentoo-2-a84558579f06e79cfe41adebcf1fbde00f2a2bf6.tar.gz
gentoo-2-a84558579f06e79cfe41adebcf1fbde00f2a2bf6.tar.bz2
gentoo-2-a84558579f06e79cfe41adebcf1fbde00f2a2bf6.zip
initial import, ebuild by me
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/core')
-rw-r--r--dev-ml/core/ChangeLog10
-rw-r--r--dev-ml/core/core-0.6.0.ebuild47
-rw-r--r--dev-ml/core/metadata.xml14
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
new file mode 100644
index 000000000000..563147e11016
--- /dev/null
+++ b/dev-ml/core/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/core
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.1 2009/10/27 12:36:35 aballier Exp $
+
+*core-0.6.0 (27 Oct 2009)
+
+ 27 Oct 2009; Alexis Ballier <aballier@gentoo.org> +core-0.6.0.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/dev-ml/core/core-0.6.0.ebuild b/dev-ml/core/core-0.6.0.ebuild
new file mode 100644
index 000000000000..7dede9f282df
--- /dev/null
+++ b/dev-ml/core/core-0.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-0.6.0.ebuild,v 1.1 2009/10/27 12:36:35 aballier Exp $
+
+EAPI="2"
+inherit findlib
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tgz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt]
+ dev-ml/res
+ dev-ml/sexplib
+ dev-ml/bin-prot
+ dev-ml/fieldslib
+ dev-ml/pcre-ocaml"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ml/ounit
+ dev-ml/type-conv
+ )"
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ cd "${S}/extended_test"
+ ocamlfind ocamlc -package bigarray,oUnit,type-conv,sexplib,bin_prot,res,fieldslib,pcre,threads -thread -dtypes -I ../extended -I ../lib yes.ml -o yes.exe || die
+ for i in lib extended ; do
+ cd "${S}/${i}_test"
+ emake || die
+ ./test_runner.exe || die
+ done
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die "make install failed"
+ dodoc README
+}
diff --git a/dev-ml/core/metadata.xml b/dev-ml/core/metadata.xml
new file mode 100644
index 000000000000..3a9dfe0e889c
--- /dev/null
+++ b/dev-ml/core/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <longdescription lang="en">
+ Core is Jane Street Capital's Ocaml standard library overlay. It
+ provides tail recursive versions of non tail recursive functions in
+ the standard library, changes the signature of many of the standard
+ modules, and adds new functionality.
+
+ Core_extended adds new functionality, but is only code reviewed on an
+ ad-hoc basis.
+ </longdescription>
+</pkgmetadata>