summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-01-10 13:27:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-01-10 13:27:01 +0000
commitaaae1e5fe24a647aab7ec856cf08a8860f69386c (patch)
tree6c20c64e46d8678fdcb68d61d9cec0896b13fdad /dev-ml/camomile
parentversion bump (diff)
downloadgentoo-2-aaae1e5fe24a647aab7ec856cf08a8860f69386c.tar.gz
gentoo-2-aaae1e5fe24a647aab7ec856cf08a8860f69386c.tar.bz2
gentoo-2-aaae1e5fe24a647aab7ec856cf08a8860f69386c.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/camomile')
-rw-r--r--dev-ml/camomile/ChangeLog9
-rw-r--r--dev-ml/camomile/camomile-0.8.4.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-ml/camomile/ChangeLog b/dev-ml/camomile/ChangeLog
index a648cbd60e61..76d99189eb98 100644
--- a/dev-ml/camomile/ChangeLog
+++ b/dev-ml/camomile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camomile
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.29 2011/07/23 11:18:02 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.30 2012/01/10 13:27:01 aballier Exp $
+
+*camomile-0.8.4 (10 Jan 2012)
+
+ 10 Jan 2012; Alexis Ballier <aballier@gentoo.org> +camomile-0.8.4.ebuild:
+ version bump
23 Jul 2011; Markus Meier <maekke@gentoo.org> camomile-0.8.3.ebuild:
x86 stable, bug #374965
diff --git a/dev-ml/camomile/camomile-0.8.4.ebuild b/dev-ml/camomile/camomile-0.8.4.ebuild
new file mode 100644
index 000000000000..eb9ac2ee4519
--- /dev/null
+++ b/dev-ml/camomile/camomile-0.8.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.8.4.ebuild,v 1.1 2012/01/10 13:27:01 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml."
+HOMEPAGE="http://github.com/yoriyuki/Camomile/wiki"
+SRC_URI="http://github.com/downloads/yoriyuki/Camomile/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 byte unidata unimaps charmap_data locale_data || die "failed to build"
+ if use ocamlopt; then
+ emake -j1 opt || die "failed to build native code"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
+}