summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-26 12:36:52 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-26 12:36:52 +0000
commit9188d562384aac9bf877140719101aacccbfbb4e (patch)
tree262c6343e5e8236dbb75c52488286a0c82f8a272 /dev-ml/camlzip
parentstable on ppc64 (Manifest recommit) (diff)
downloadgentoo-2-9188d562384aac9bf877140719101aacccbfbb4e.tar.gz
gentoo-2-9188d562384aac9bf877140719101aacccbfbb4e.tar.bz2
gentoo-2-9188d562384aac9bf877140719101aacccbfbb4e.zip
Stable move.
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/ChangeLog6
-rw-r--r--dev-ml/camlzip/camlzip-1.01-r1.ebuild8
-rw-r--r--dev-ml/camlzip/camlzip-1.01.ebuild69
-rw-r--r--dev-ml/camlzip/files/digest-camlzip-1.011
4 files changed, 9 insertions, 75 deletions
diff --git a/dev-ml/camlzip/ChangeLog b/dev-ml/camlzip/ChangeLog
index a86e946bf8b6..e2c3c475f841 100644
--- a/dev-ml/camlzip/ChangeLog
+++ b/dev-ml/camlzip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/camlzip
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.2 2004/08/25 12:44:43 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.3 2004/08/26 12:36:52 mattam Exp $
+
+ 26 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> camlzip-1.01-r1.ebuild,
+ -camlzip-1.01.ebuild:
+ Move to stable (not depended on), remove old version.
*camlzip-1.01-r1 (25 Aug 2004)
diff --git a/dev-ml/camlzip/camlzip-1.01-r1.ebuild b/dev-ml/camlzip/camlzip-1.01-r1.ebuild
index 9b8930ff974a..0a311658ad03 100644
--- a/dev-ml/camlzip/camlzip-1.01-r1.ebuild
+++ b/dev-ml/camlzip/camlzip-1.01-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.01-r1.ebuild,v 1.1 2004/08/25 12:44:43 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.01-r1.ebuild,v 1.2 2004/08/26 12:36:52 mattam Exp $
inherit findlib eutils
@@ -12,7 +12,7 @@ SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
SLOT="1"
LICENSE="LGPL-2.1"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ppc"
DEPEND=">=dev-lang/ocaml-3.04 \
>=sys-libs/zlib-1.1.3"
@@ -25,8 +25,8 @@ src_unpack() {
}
src_compile() {
- make all || die "Failed at compilation step !!!"
- make allopt || die "Failed at ML compilation step !!!"
+ emake all || die "Failed at compilation step !!!"
+ emake allopt || die "Failed at ML compilation step !!!"
}
src_install() {
diff --git a/dev-ml/camlzip/camlzip-1.01.ebuild b/dev-ml/camlzip/camlzip-1.01.ebuild
deleted file mode 100644
index 1cfc59749513..000000000000
--- a/dev-ml/camlzip/camlzip-1.01.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.01.ebuild,v 1.1 2004/08/18 12:01:52 mattam Exp $
-
-IUSE=""
-
-DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
-HOMEPAGE="http://cristal.inria.fr/~xleroy/software.html#camlzip"
-SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${PN}-${PV}.tar.gz"
-
-SLOT="1"
-LICENSE="LGPL-2.1"
-KEYWORDS="~x86"
-
-DEPEND=">=dev-lang/ocaml-3.04 \
- >=sys-libs/zlib-1.1.3 \
- sys-apps/sed \
- >=dev-ml/findlib-0.8"
-RDEPEND=">=dev-ml/findlib-0.8"
-
-src_unpack() {
- local CAT=$(which cat)
- local CP=$(which cp)
- local MV=$(which mv)
- local SED=$(which sed)
-
- unpack ${A}
- $CP /usr/lib/ocaml/ld.conf ${WORKDIR}
- # The ML linker configuration file is copied
- # into the ${WORKDIR} so as to compile properly
- # the ML related code.
- #
- # NB: Note that this file should NOT be copied
- # to the ${D}usr/lib/ocaml/ directory otherwise
- # it would be deleted at camlzip's unmerge,
- # which would break OCAML environment.
- # Julien TIERNY <julien.tierny@wanadoo.fr>
- $CAT ${S}/Makefile | \
- $SED "s/\`\$(OCAMLC) -where\`/\${D}\`ocamlfind\ printconf\ path\`/" | \
- $SED "s/ldconf=\${D}usr\/lib\/ocaml\/ld.conf;/ldconf=\${WORKDIR}\/ld.conf/" > \
- ${S}/Makefile.tmp
- $MV ${S}/Makefile.tmp ${S}/Makefile
-}
-
-src_compile() {
- emake all || die "Failed at compilation step !!!"
- emake allopt || die "Failed at ML compilation step !!!"
-}
-
-src_install() {
- einstall || die "Failed at installation step !!!"
- emake installopt || die "Failed at ML related installation step !!!"
- dodoc README
- insopts -m 644
- insinto `ocamlfind printconf path`/zip
- doins ${FILESDIR}/META
-}
-
-pkg_postinst() {
- local ECHO=$(which echo)
- local CAT=$(which cat)
- local GREP=$(which grep)
-
- if [ -z `$CAT /usr/lib/ocaml/ld.conf | $GREP zip` ]
- then
- einfo "Patching OCAML linker configuration file..."
- $ECHO "`ocamlfind printconf path`zip" >> /usr/lib/ocaml/ld.conf
- fi
-}
diff --git a/dev-ml/camlzip/files/digest-camlzip-1.01 b/dev-ml/camlzip/files/digest-camlzip-1.01
deleted file mode 100644
index 0d0e36c33ebe..000000000000
--- a/dev-ml/camlzip/files/digest-camlzip-1.01
+++ /dev/null
@@ -1 +0,0 @@
-MD5 728940dc0958493274314d576c16ef68 camlzip-1.01.tar.gz 15113