summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-06-07 20:32:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-06-07 20:32:41 +0000
commit1bb4fc8a096e3ae5fd944185fc6dedcea3ccdf36 (patch)
tree940e82705ea2284bc4dd5b8329d13866048faf4e /dev-ml/camlimages
parentStable for HPPA (bug #221063). (diff)
downloadgentoo-2-1bb4fc8a096e3ae5fd944185fc6dedcea3ccdf36.tar.gz
gentoo-2-1bb4fc8a096e3ae5fd944185fc6dedcea3ccdf36.tar.bz2
gentoo-2-1bb4fc8a096e3ae5fd944185fc6dedcea3ccdf36.zip
Add a better META file based on debian's one. This will allow to build active-dvi.
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-ml/camlimages')
-rw-r--r--dev-ml/camlimages/ChangeLog9
-rw-r--r--dev-ml/camlimages/camlimages-2.20-r1.ebuild82
-rw-r--r--dev-ml/camlimages/files/META.camlimages.in36
3 files changed, 126 insertions, 1 deletions
diff --git a/dev-ml/camlimages/ChangeLog b/dev-ml/camlimages/ChangeLog
index 9da9b0608973..1c980b9a1859 100644
--- a/dev-ml/camlimages/ChangeLog
+++ b/dev-ml/camlimages/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ml/camlimages
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/ChangeLog,v 1.11 2008/01/27 14:22:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/ChangeLog,v 1.12 2008/06/07 20:32:41 aballier Exp $
+
+*camlimages-2.20-r1 (07 Jun 2008)
+
+ 07 Jun 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/META.camlimages.in, +camlimages-2.20-r1.ebuild:
+ Add a better META file based on debian's one. This will allow to build
+ active-dvi.
27 Jan 2008; Alexis Ballier <aballier@gentoo.org> camlimages-2.20.ebuild:
fix automagics...
diff --git a/dev-ml/camlimages/camlimages-2.20-r1.ebuild b/dev-ml/camlimages/camlimages-2.20-r1.ebuild
new file mode 100644
index 000000000000..ec31b48a171d
--- /dev/null
+++ b/dev-ml/camlimages/camlimages-2.20-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/camlimages-2.20-r1.ebuild,v 1.1 2008/06/07 20:32:41 aballier Exp $
+
+inherit findlib eutils
+
+IUSE="gtk opengl"
+
+DESCRIPTION="An image manipulation library for ocaml"
+HOMEPAGE="http://pauillac.inria.fr/camlimages/"
+SRC_URI="ftp://ftp.inria.fr/INRIA/caml-light/bazar-ocaml/${P/20/2}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.09
+ gtk? ( dev-ml/lablgtk )
+ opengl? ( dev-ml/lablgl )
+ media-libs/giflib
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ x11-libs/libXpm
+ >=media-libs/freetype-2
+ virtual/ghostscript"
+
+S="${WORKDIR}/${P/20/2}"
+
+pkg_setup() {
+ if ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "${PN} needs to be built with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-ocaml-3.09.diff"
+}
+
+src_compile() {
+ local myconf
+
+ if !(use gtk);
+ then
+ myconf="--with-lablgtk=/dev/null --with-lablgtk2=/dev/null"
+ fi
+
+ if !(use opengl);
+ then
+ myconf="$myconf --with-lablgl=/dev/null"
+ fi
+
+ econf ${myconf} || die
+ emake -j1 || die
+ emake -j1 opt || die
+}
+
+src_test() {
+ cd "${S}/test"
+ emake || die "building test failed"
+ ./test
+ ./test.byt
+}
+
+src_install() {
+ # Use findlib to install properly, especially to avoid
+ # the shared library mess
+ findlib_src_preinst
+ mkdir "${T}/tmp"
+ emake CAMLDIR="${T}/tmp" \
+ LIBDIR="${T}/tmp" \
+ DESTDIR="${T}/tmp" \
+ install || die
+ sed -e "s/@VERSION@/${PV}/" "${FILESDIR}/META.camlimages.in" > "${T}/tmp/META"
+
+ ocamlfind install camlimages "${T}"/tmp/*
+}
diff --git a/dev-ml/camlimages/files/META.camlimages.in b/dev-ml/camlimages/files/META.camlimages.in
new file mode 100644
index 000000000000..94cc60b51059
--- /dev/null
+++ b/dev-ml/camlimages/files/META.camlimages.in
@@ -0,0 +1,36 @@
+version="@VERSION@"
+description = "Image manipulation library"
+
+requires="graphics"
+
+archive(byte) ="ci_core.cma"
+archive(byte) +="ci_freetype.cma"
+archive(byte) +="ci_gif.cma"
+archive(byte) +="ci_jpeg.cma"
+archive(byte) +="ci_tiff.cma"
+archive(byte) +="ci_bmp.cma"
+archive(byte) +="ci_ppm.cma"
+archive(byte) +="ci_png.cma"
+archive(byte) +="ci_xvthumb.cma"
+archive(byte) +="ci_xpm.cma"
+archive(byte) +="ci_ps.cma"
+archive(byte) +="ci_graphics.cma"
+
+archive(native) ="ci_core.cmxa"
+archive(native)+="ci_freetype.cmxa"
+archive(native)+="ci_gif.cmxa"
+archive(native)+="ci_jpeg.cmxa"
+archive(native)+="ci_tiff.cmxa"
+archive(native)+="ci_bmp.cmxa"
+archive(native)+="ci_ppm.cmxa"
+archive(native)+="ci_png.cmxa"
+archive(native)+="ci_xvthumb.cmxa"
+archive(native)+="ci_xpm.cmxa"
+archive(native)+="ci_ps.cmxa"
+archive(native)+="ci_graphics.cmxa"
+
+package "lablgtk2" (
+ requires="camlimages lablgtk2"
+ archive(byte)="ci_lablgtk2.cma"
+ archive(native)="ci_lablgtk2.cmxa"
+)