summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-19 12:49:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-19 12:49:26 +0000
commit09fac4a14428cc28bb44476ab110ab487c5cf606 (patch)
treeeb13d946ecf552fbfa7b45c7c83974ac1dccbe24 /dev-ml/bin-prot
parentamd64/x86 stable, bug #285403 (diff)
downloadgentoo-2-09fac4a14428cc28bb44476ab110ab487c5cf606.tar.gz
gentoo-2-09fac4a14428cc28bb44476ab110ab487c5cf606.tar.bz2
gentoo-2-09fac4a14428cc28bb44476ab110ab487c5cf606.zip
Initial import, ebuild by Guillaume Horel <guillaume.horel@gmail.com>, bug #281276
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/bin-prot')
-rw-r--r--dev-ml/bin-prot/ChangeLog11
-rw-r--r--dev-ml/bin-prot/bin-prot-1.2.18.ebuild44
-rw-r--r--dev-ml/bin-prot/metadata.xml5
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/bin-prot/ChangeLog b/dev-ml/bin-prot/ChangeLog
new file mode 100644
index 000000000000..a65bb35f6a24
--- /dev/null
+++ b/dev-ml/bin-prot/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/bin-prot
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.1 2009/09/19 12:49:26 aballier Exp $
+
+*bin-prot-1.2.18 (19 Sep 2009)
+
+ 19 Sep 2009; Alexis Ballier <aballier@gentoo.org> +bin-prot-1.2.18.ebuild,
+ +metadata.xml:
+ Initial import, ebuild by Guillaume Horel <guillaume.horel@gmail.com>, bug
+ #281276
+
diff --git a/dev-ml/bin-prot/bin-prot-1.2.18.ebuild b/dev-ml/bin-prot/bin-prot-1.2.18.ebuild
new file mode 100644
index 000000000000..16c49a909112
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-1.2.18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-1.2.18.ebuild,v 1.1 2009/09/19 12:49:26 aballier Exp $
+
+EAPI="2"
+
+inherit findlib
+
+DESCRIPTION="Automated code generation for converting OCaml values to/from a type-safe binary protocol"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+S=${WORKDIR}/${P}/lib
+
+RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt]
+ dev-ml/type-conv"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )
+ doc? ( virtual/latex-base )"
+
+src_compile() {
+ emake -j1 CFLAGS="${CFLAGS}" || die
+}
+
+src_test() {
+ cd "${S}/../lib_test"
+ emake -j1 || die
+ ./test_runner || die
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die "make install failed"
+ dodoc ../README.txt ../Changelog
+ if use doc; then
+ cd ../doc
+ pdflatex README.tex
+ dodoc README.pdf
+ fi
+}
diff --git a/dev-ml/bin-prot/metadata.xml b/dev-ml/bin-prot/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/bin-prot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>