summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2014-12-21 00:05:45 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2014-12-21 00:05:45 +0000
commit18796f315e363cab9a7cf3edeb6384eb331fda30 (patch)
tree92523942eb6f25b5eee9af200cb3bc4dbe97507d /dev-lua
parentThanks to Chris Kerr for reporting, add quickcheck-unicode to test dependenci... (diff)
downloadgentoo-2-18796f315e363cab9a7cf3edeb6384eb331fda30.tar.gz
gentoo-2-18796f315e363cab9a7cf3edeb6384eb331fda30.tar.bz2
gentoo-2-18796f315e363cab9a7cf3edeb6384eb331fda30.zip
version bump. bug #500702
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luarocks/ChangeLog10
-rw-r--r--dev-lua/luarocks/luarocks-2.2.0.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-lua/luarocks/ChangeLog b/dev-lua/luarocks/ChangeLog
index e157e515bab0..e19bc7f3913c 100644
--- a/dev-lua/luarocks/ChangeLog
+++ b/dev-lua/luarocks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lua/luarocks
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/ChangeLog,v 1.6 2013/05/19 22:08:41 mabi Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/ChangeLog,v 1.7 2014/12/21 00:05:45 rafaelmartins Exp $
+
+*luarocks-2.2.0 (21 Dec 2014)
+
+ 21 Dec 2014; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +luarocks-2.2.0.ebuild:
+ version bump. bug #500702
*luarocks-2.0.12 (19 May 2013)
diff --git a/dev-lua/luarocks/luarocks-2.2.0.ebuild b/dev-lua/luarocks/luarocks-2.2.0.ebuild
new file mode 100644
index 000000000000..6bff1fc6a87b
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-2.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/luarocks-2.2.0.ebuild,v 1.1 2014/12/21 00:05:45 rafaelmartins Exp $
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="curl openssl"
+
+DEPEND="dev-lang/lua
+ curl? ( net-misc/curl )
+ openssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_configure() {
+ USE_MD5="md5sum"
+ USE_FETCH="wget"
+ use openssl && USE_MD5="openssl"
+ use curl && USE_FETCH="curl"
+
+ # econf doesn't work b/c it passes variables the custom configure can't
+ # handle
+ ./configure \
+ --prefix=/usr \
+ --with-lua-lib=/usr/$(get_libdir) \
+ --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
+ --with-downloader=$USE_FETCH \
+ --with-md5-checker=$USE_MD5 \
+ || die "configure failed"
+}
+
+src_compile() {
+ # -j1 b/c make tries to delete files it has yet to create (bug #402005)
+ emake DESTDIR="${D}" -j1 || die "make failed"
+}
+
+src_install() {
+ # -j1 b/c otherwise it fails to find src/bin/luarocks
+ emake DESTDIR="${D}" -j1 install || die "einstall"
+}
+
+pkg_preinst() {
+ find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
+}