summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2012-01-24 20:56:04 +0000
committerMatti Bickel <mabi@gentoo.org>2012-01-24 20:56:04 +0000
commit65aa44333fc70e482589ae75862fe8029b1e3903 (patch)
tree7b80762032cedbd32d9c6cfcb78c81c3f6888ff4 /dev-lua/luarocks
parentVersion bump. Bug #400633. Thanks to PhobosK phobosk@fastmail.fm (diff)
downloadgentoo-2-65aa44333fc70e482589ae75862fe8029b1e3903.tar.gz
gentoo-2-65aa44333fc70e482589ae75862fe8029b1e3903.tar.bz2
gentoo-2-65aa44333fc70e482589ae75862fe8029b1e3903.zip
bump and remove old/nonworking (bug #313677)
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-lua/luarocks')
-rw-r--r--dev-lua/luarocks/ChangeLog10
-rw-r--r--dev-lua/luarocks/luarocks-2.0.7.1.ebuild (renamed from dev-lua/luarocks/luarocks-1.0.ebuild)20
2 files changed, 20 insertions, 10 deletions
diff --git a/dev-lua/luarocks/ChangeLog b/dev-lua/luarocks/ChangeLog
index 9c5e3b096052..feaedf7ff987 100644
--- a/dev-lua/luarocks/ChangeLog
+++ b/dev-lua/luarocks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lua/luarocks
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/ChangeLog,v 1.1 2010/11/05 22:13:24 rafaelmartins Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/ChangeLog,v 1.2 2012/01/24 20:56:04 mabi Exp $
+
+*luarocks-2.0.7.1 (24 Jan 2012)
+
+ 24 Jan 2012; Matti Bickel <mabi@gentoo.org> +luarocks-2.0.7.1.ebuild,
+ -luarocks-1.0.ebuild:
+ bump and remove old/nonworking (bug #313677)
05 Nov 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+luarocks-1.0.ebuild, +metadata.xml:
diff --git a/dev-lua/luarocks/luarocks-1.0.ebuild b/dev-lua/luarocks/luarocks-2.0.7.1.ebuild
index 921d396f39cb..d0ce24db4ec8 100644
--- a/dev-lua/luarocks/luarocks-1.0.ebuild
+++ b/dev-lua/luarocks/luarocks-2.0.7.1.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/luarocks-1.0.ebuild,v 1.1 2010/11/05 22:13:24 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/luarocks-2.0.7.1.ebuild,v 1.1 2012/01/24 20:56:04 mabi Exp $
+
+EAPI=4
inherit eutils
DESCRIPTION="A deployment and management system for Lua modules"
HOMEPAGE="http://www.luarocks.org"
-SRC_URI="http://luaforge.net/frs/download.php/3727/${P}.tar.gz"
+SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -19,7 +21,7 @@ DEPEND="dev-lang/lua
RDEPEND="${DEPEND}
app-arch/unzip"
-src_compile() {
+src_configure() {
USE_MD5="md5sum"
USE_FETCH="wget"
use openssl && USE_MD5="openssl"
@@ -29,18 +31,20 @@ src_compile() {
# handle
./configure \
--prefix=/usr \
- --scripts-dir=/usr/bin \
- --with-lua=/usr \
--with-lua-lib=/usr/$(get_libdir) \
- --rocks-tree=/usr/lib/lua/luarocks \
+ --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
--with-downloader=$USE_FETCH \
--with-md5-checker=$USE_MD5 \
--force-config || die "configure failed"
+}
+
+src_compile() {
emake DESTDIR="${D}" || die "make failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "einstall"
+ # -j1 b/c otherwise it fails with to find src/bin/luarocks
+ emake DESTDIR="${D}" -j1 install || die "einstall"
}
pkg_preinst() {