summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-08-13 14:34:52 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-08-13 14:34:52 +0000
commit3d757e763262f9cc45a5e2ddde6150cacb1823af (patch)
tree650fecbf3459df365cca4ea0579aa5442ef75828 /dev-lua/luaevent
parentStable for x86, wrt bug #430638 (diff)
downloadgentoo-2-3d757e763262f9cc45a5e2ddde6150cacb1823af.tar.gz
gentoo-2-3d757e763262f9cc45a5e2ddde6150cacb1823af.tar.bz2
gentoo-2-3d757e763262f9cc45a5e2ddde6150cacb1823af.zip
Version bump, bug #431168
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-lua/luaevent')
-rw-r--r--dev-lua/luaevent/ChangeLog7
-rw-r--r--dev-lua/luaevent/luaevent-0.4.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-lua/luaevent/ChangeLog b/dev-lua/luaevent/ChangeLog
index 4c2bbf54caf1..e2d5cae8a63a 100644
--- a/dev-lua/luaevent/ChangeLog
+++ b/dev-lua/luaevent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lua/luaevent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaevent/ChangeLog,v 1.7 2012/05/04 04:01:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaevent/ChangeLog,v 1.8 2012/08/13 14:34:52 blueness Exp $
+
+*luaevent-0.4.1 (13 Aug 2012)
+
+ 13 Aug 2012; Anthony G. Basile <blueness@gentoo.org> +luaevent-0.4.1.ebuild:
+ Version bump, bug #431168
04 May 2012; Jeff Horelick <jdhore@gentoo.org> luaevent-0.3.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/dev-lua/luaevent/luaevent-0.4.1.ebuild b/dev-lua/luaevent/luaevent-0.4.1.ebuild
new file mode 100644
index 000000000000..9b6e56bb0b9e
--- /dev/null
+++ b/dev-lua/luaevent/luaevent-0.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaevent/luaevent-0.4.1.ebuild,v 1.1 2012/08/13 14:34:52 blueness Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="libevent bindings for Lua"
+HOMEPAGE="http://luaforge.net/projects/luaevent http://repo.or.cz/w/luaevent.git"
+SRC_URI="http://dev.gentoo.org/~blueness/luaevent/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1
+ >=dev-libs/libevent-1.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i "s:^CFLAGS =:CFLAGS +=:" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^LDFLAGS =:LDFLAGS +=:" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "/^LDFLAGS/a CC = $(tc-getCC)" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^LUA_INC_DIR ?=.*:LUA_INC_DIR ?= $(pkg-config --variable INSTALL_INC lua):" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^INSTALL_DIR_LUA ?=.*:INSTALL_DIR_LUA ?= $(pkg-config --variable INSTALL_LMOD lua):" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^INSTALL_DIR_BIN ?=.*:INSTALL_DIR_BIN ?= $(pkg-config --variable INSTALL_CMOD lua):" "${S}/Makefile" \
+ || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}