summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2014-01-04 21:38:24 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2014-01-04 21:38:24 +0000
commit820a6b32f554834861b893b465d11a9dabf8352c (patch)
tree29a7b70ad9457fe3e14ae165c07dd917ca40ea73 /dev-lua/lgi
parentBuild fix per bug #488898. (diff)
downloadgentoo-2-820a6b32f554834861b893b465d11a9dabf8352c.tar.gz
gentoo-2-820a6b32f554834861b893b465d11a9dabf8352c.tar.bz2
gentoo-2-820a6b32f554834861b893b465d11a9dabf8352c.zip
Bump per bug #483830.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lua/lgi')
-rw-r--r--dev-lua/lgi/ChangeLog9
-rw-r--r--dev-lua/lgi/lgi-0.7.2.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-lua/lgi/ChangeLog b/dev-lua/lgi/ChangeLog
index 28eb51fd4325..4affcc205ddc 100644
--- a/dev-lua/lgi/ChangeLog
+++ b/dev-lua/lgi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lua/lgi
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/ChangeLog,v 1.2 2013/02/08 15:48:18 maksbotan Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/ChangeLog,v 1.3 2014/01/04 21:38:24 robbat2 Exp $
+
+*lgi-0.7.2 (04 Jan 2014)
+
+ 04 Jan 2014; Robin H. Johnson <robbat2@gentoo.org> +lgi-0.7.2.ebuild:
+ Bump per bug #483830.
*lgi-0.6.2-r1 (08 Feb 2013)
diff --git a/dev-lua/lgi/lgi-0.7.2.ebuild b/dev-lua/lgi/lgi-0.7.2.ebuild
new file mode 100644
index 000000000000..939e81f8075c
--- /dev/null
+++ b/dev-lua/lgi/lgi-0.7.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/lgi-0.7.2.ebuild,v 1.1 2014/01/04 21:38:24 robbat2 Exp $
+
+EAPI=4
+
+VIRTUALX_REQUIRED="manual"
+
+inherit eutils toolchain-funcs flag-o-matic virtualx
+
+DESCRIPTION="Lua bindings using gobject-introspection"
+HOMEPAGE="http://github.com/pavouk/lgi"
+SRC_URI="https://github.com/pavouk/lgi/archive/0.7.2.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/lua-5.1
+ dev-libs/gobject-introspection
+ dev-libs/glib
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ x11-libs/cairo[glib]
+ x11-libs/gtk+[introspection]
+ ${VIRTUALX_DEPEND}
+ )"
+
+src_prepare() {
+ sed -i \
+ -e "s:^LUA_LIBDIR.*$:LUA_LIBDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua):" \
+ -e "s:^LUA_SHAREDIR.*$:LUA_SHAREDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua):" \
+ "${S}"/lgi/Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}"
+}
+
+src_test() {
+ Xemake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}" check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dohtml -r docs/*
+ dodoc README.md
+ if use examples; then
+ dodoc -r samples
+ fi
+}