summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPanagiotis Christopoulos <pchrist@gentoo.org>2008-07-13 18:51:40 +0000
committerPanagiotis Christopoulos <pchrist@gentoo.org>2008-07-13 18:51:40 +0000
commite90b0b58afa839923619ef05bec9ecbe5b34f09d (patch)
tree8cb24da36ff3ec966c256acd780fbf66367bd788 /dev-lisp
parentMarked ppc stable for bug #208902. (diff)
downloadgentoo-2-e90b0b58afa839923619ef05bec9ecbe5b34f09d.tar.gz
gentoo-2-e90b0b58afa839923619ef05bec9ecbe5b34f09d.tar.bz2
gentoo-2-e90b0b58afa839923619ef05bec9ecbe5b34f09d.zip
fix ancient ecls ebuilds, bug 156182
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 i686)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog6
-rw-r--r--dev-lisp/ecls/ecls-0.9i.ebuild67
2 files changed, 31 insertions, 42 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index 1eca91b83f59..b3264ab0f418 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/ecls
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.26 2008/01/11 14:50:18 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.27 2008/07/13 18:51:40 pchrist Exp $
+
+ 13 Jul 2008; Panagiotis Christopoulos <pchrist@gentoo.org>
+ ecls-0.9i.ebuild:
+ fix ancient ecls ebuilds, bug 156182
*ecls-0.9j_p1 (11 Jan 2008)
diff --git a/dev-lisp/ecls/ecls-0.9i.ebuild b/dev-lisp/ecls/ecls-0.9i.ebuild
index 2b3f791cd6b4..621ecd958be4 100644
--- a/dev-lisp/ecls/ecls-0.9i.ebuild
+++ b/dev-lisp/ecls/ecls-0.9i.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9i.ebuild,v 1.1 2006/07/09 16:33:30 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9i.ebuild,v 1.2 2008/07/13 18:51:40 pchrist Exp $
inherit eutils
@@ -10,57 +10,42 @@ HOMEPAGE="http://ecls.sourceforge.net/"
SLOT="0"
LICENSE="BSD LGPL-2"
KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
-
DEPEND="=dev-libs/gmp-4*
app-text/texi2html"
-
-# ECL fails to build with a system-installed Boehm GC (which apparently is a
-# rare configuration since most distributions neglect to install the useful
-# private headers). Until this is properly isolated, we use the Boehm GC
-# included with ECL.
-
-# dev-libs/boehm-gc
-
-IUSE="X c++"
-
+IUSE="X"
PROVIDE="virtual/commonlisp"
-
S=${WORKDIR}/ecl-${PV:0:4}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-headers-gentoo.patch || die
- # waiting on upstream to fix this http://sourceforge.net/tracker/?func=detail&aid=1519256&group_id=30035&atid=398053
-# epatch ${FILESDIR}/${PV}-sockets-c++-gentoo.patch || die
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-headers-gentoo.patch"
}
src_compile() {
- local myconf="--with-system-gmp
- --enable-boehm=included
- --with-tcp
- --with-ffi
- --with-clos-streams
- --with-cmuformat
- --with-asdf
- `use_with c++ cxx`
- `use_with X x`
- `use_with X clx`"
- einfo "Configuring with: $myconf"
- econf ${myconf} || die
- make || die
+ econf --with-system-gmp \
+ --enable-boehm=included \
+ --with-tcp \
+ --with-ffi \
+ --with-clos-streams \
+ --with-cmuformat \
+ --with-asdf \
+ $(use_with X x) \
+ $(use_with X clx) \
+ || die "econf failed"
+ emake -j1 || die "emake died"
}
src_install () {
- make bindir=${D}/usr/bin \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- libdir=${D}/usr/lib/ecl \
- includedir=${D}/usr/include \
- docdir=${D}/usr/share/doc/${PF} install || true
- dohtml doc/*.html
- dodoc ANNOUNCEMENT Copyright LGPL
+ local libso="libecl.so"
+
+ emake DESTDIR="${D}" install \
+ || die "emake install failed."
- insinto /usr/share/doc/${PF}/
- doins ${FILESDIR}/README.Gentoo
+ rm -v "${D}/usr/lib/ecl/${libso}"
+ rm -v "${D}/usr/share/doc/ecl"
+ dolib.so "build/${libso}"
+
+ dohtml doc/*.html
+ dodoc ANNOUNCEMENT Copyright LGPL "${FILESDIR}/README.Gentoo"
}