summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPanagiotis Christopoulos <pchrist@gentoo.org>2010-03-26 01:54:24 +0000
committerPanagiotis Christopoulos <pchrist@gentoo.org>2010-03-26 01:54:24 +0000
commitde92ec43f4f03599dc15ed175af6a7d5a886ef93 (patch)
tree9736dae61605e8237c210a3e7c8ffeddbe6965fd /dev-lisp
parentforce again EAPI 3, fallback was from wrong decision (diff)
downloadgentoo-2-de92ec43f4f03599dc15ed175af6a7d5a886ef93.tar.gz
gentoo-2-de92ec43f4f03599dc15ed175af6a7d5a886ef93.tar.bz2
gentoo-2-de92ec43f4f03599dc15ed175af6a7d5a886ef93.zip
Fix graphviz's built_with_use png wrong test case, thanks to Kacper Kowalik (Xarthisius), reference bug #308869
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/ChangeLog8
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.19.ebuild8
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild6
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild6
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.28.ebuild6
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.31.ebuild6
6 files changed, 21 insertions, 19 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index 47636fe1590b..68d29f243d92 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.166 2010/03/26 01:40:04 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.167 2010/03/26 01:54:24 pchrist Exp $
+
+ 26 Mar 2010; Panagiotis Christopoulos <pchrist@gentoo.org>
+ sbcl-1.0.19.ebuild, sbcl-1.0.26-r10.ebuild, sbcl-1.0.27-r10.ebuild,
+ sbcl-1.0.28.ebuild, sbcl-1.0.31.ebuild:
+ Fix graphviz's built_with_use png wrong test case, thanks to Kacper
+ Kowalik (Xarthisius), reference bug #308869
26 Mar 2010; Panagiotis Christopoulos <pchrist@gentoo.org>
sbcl-1.0.36-r1.ebuild:
diff --git a/dev-lisp/sbcl/sbcl-1.0.19.ebuild b/dev-lisp/sbcl/sbcl-1.0.19.ebuild
index 3c09c2683f05..0c88ab402002 100644
--- a/dev-lisp/sbcl/sbcl-1.0.19.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.19.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.19.ebuild,v 1.8 2009/10/04 14:54:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.19.ebuild,v 1.9 2010/03/26 01:54:24 pchrist Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -59,10 +59,6 @@ pkg_setup() {
eerror "refer to Bug #119016 for more information."
die
fi
- if use doc && ! built_with_use media-gfx/graphviz png; then
- eerror "media-gfx/graphviz has to be built with png support."
- die "Missing png USE-flag for media-gfx/graphviz"
- fi
}
CONFIG="${S}/customize-target-features.lisp"
diff --git a/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild b/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild
index 25243afafd89..68423063210f 100644
--- a/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild,v 1.5 2009/10/04 14:54:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild,v 1.6 2010/03/26 01:54:24 pchrist Exp $
EAPI=2
@@ -34,7 +34,7 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~ppc ~sparc ~x86"
IUSE="ldb source +threads +unicode doc cobalt"
-DEPEND="doc? ( sys-apps/texinfo || ( >=media-gfx/graphviz-2.20[png] >=media-gfx/graphviz-2.24.0 ) )"
+DEPEND="doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="elibc_glibc? ( >=sys-libs/glibc-2.3 || ( <sys-libs/glibc-2.6[nptl] >=sys-libs/glibc-2.6 ) )"
PDEPEND="dev-lisp/gentoo-init"
diff --git a/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild b/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild
index 9ce2360b1908..dad50f0b621e 100644
--- a/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild,v 1.5 2009/10/04 14:54:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild,v 1.6 2010/03/26 01:54:24 pchrist Exp $
EAPI=2
@@ -34,7 +34,7 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~ppc ~sparc ~x86"
IUSE="ldb source +threads +unicode doc cobalt"
-DEPEND="doc? ( sys-apps/texinfo || ( >=media-gfx/graphviz-2.20[png] >=media-gfx/graphviz-2.24.0 ) )"
+DEPEND="doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="elibc_glibc? ( >=sys-libs/glibc-2.3 || ( <sys-libs/glibc-2.6[nptl] >=sys-libs/glibc-2.6 ) )"
PDEPEND="dev-lisp/gentoo-init"
diff --git a/dev-lisp/sbcl/sbcl-1.0.28.ebuild b/dev-lisp/sbcl/sbcl-1.0.28.ebuild
index 31b2c38c6bbc..257c1320de72 100644
--- a/dev-lisp/sbcl/sbcl-1.0.28.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.28.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.28.ebuild,v 1.3 2009/10/04 14:54:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.28.ebuild,v 1.4 2010/03/26 01:54:24 pchrist Exp $
EAPI=2
@@ -34,7 +34,7 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~ppc ~sparc ~x86"
IUSE="ldb source +threads +unicode doc cobalt"
-DEPEND="doc? ( sys-apps/texinfo || ( >=media-gfx/graphviz-2.20[png] >=media-gfx/graphviz-2.24.0 ) )"
+DEPEND="doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="elibc_glibc? ( >=sys-libs/glibc-2.3 || ( <sys-libs/glibc-2.6[nptl] >=sys-libs/glibc-2.6 ) )"
PDEPEND="dev-lisp/gentoo-init"
diff --git a/dev-lisp/sbcl/sbcl-1.0.31.ebuild b/dev-lisp/sbcl/sbcl-1.0.31.ebuild
index a7bb17817b89..026b552af7e7 100644
--- a/dev-lisp/sbcl/sbcl-1.0.31.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.31.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.31.ebuild,v 1.3 2009/10/04 14:54:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.31.ebuild,v 1.4 2010/03/26 01:54:24 pchrist Exp $
EAPI=2
@@ -34,7 +34,7 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~ppc ~sparc ~x86"
IUSE="ldb source +threads +unicode doc cobalt"
-DEPEND="doc? ( sys-apps/texinfo || ( >=media-gfx/graphviz-2.20[png] >=media-gfx/graphviz-2.24.0 ) )"
+DEPEND="doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="elibc_glibc? ( >=sys-libs/glibc-2.3 || ( <sys-libs/glibc-2.6[nptl] >=sys-libs/glibc-2.6 ) )"
PDEPEND="dev-lisp/gentoo-init"