summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2011-01-17 15:53:31 +0000
committerAndrey Grozin <grozin@gentoo.org>2011-01-17 15:53:31 +0000
commitc69c360427071452889229c3102455074c7e1cf6 (patch)
tree4e6283cf4d91990ca90b43b98910e70de95fd427 /dev-lisp
parentVersion bump (diff)
downloadgentoo-2-c69c360427071452889229c3102455074c7e1cf6.tar.gz
gentoo-2-c69c360427071452889229c3102455074c7e1cf6.tar.bz2
gentoo-2-c69c360427071452889229c3102455074c7e1cf6.zip
Version bump
(Portage version: 2.2.0_alpha15/cvs/Linux i686)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog10
-rw-r--r--dev-lisp/ecls/ecls-11.1.1.ebuild68
-rw-r--r--dev-lisp/ecls/files/11.1.1-headers-gentoo.patch17
3 files changed, 93 insertions, 2 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index 374e305cf06a..c9fbc16f1be9 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/ecls
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.37 2010/12/17 20:18:31 ulm Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.38 2011/01/17 15:53:31 grozin Exp $
+
+*ecls-11.1.1 (17 Jan 2011)
+
+ 17 Jan 2011; Andrey Grozin <grozin@gentoo.org>
+ +files/11.1.1-headers-gentoo.patch, +ecls-11.1.1.ebuild:
+ Version bump
17 Dec 2010; Ulrich Mueller <ulm@gentoo.org> ecls-9.12.3.ebuild,
ecls-10.2.1.ebuild, ecls-10.4.1.ebuild:
diff --git a/dev-lisp/ecls/ecls-11.1.1.ebuild b/dev-lisp/ecls/ecls-11.1.1.ebuild
new file mode 100644
index 000000000000..fe78469addb8
--- /dev/null
+++ b/dev-lisp/ecls/ecls-11.1.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-11.1.1.ebuild,v 1.1 2011/01/17 15:53:31 grozin Exp $
+
+EAPI=3
+inherit eutils multilib
+
+MY_P=ecl-${PV}
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation."
+HOMEPAGE="http://common-lisp.net/project/ecl/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug gengc precisegc threads +unicode X"
+
+RDEPEND="dev-libs/gmp
+ virtual/libffi
+ >=dev-libs/boehm-gc-7.1[threads?]"
+DEPEND="${RDEPEND}
+ app-text/texi2html"
+PDEPEND="dev-lisp/gentoo-init"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ if use gengc || use precisegc; then
+ ewarn "USE flags gengc and precisegc are experimental"
+ ewarn "Don't use them if you want a stable ecl"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-headers-gentoo.patch
+}
+
+src_configure() {
+ econf \
+ --with-system-gmp \
+ --enable-boehm=system \
+ --enable-longdouble \
+ $(use_enable gengc) \
+ $(use_enable precisegc) \
+ $(use_with debug debug-cflags) \
+ $(use_enable threads) \
+ $(use_with threads __thread) \
+ $(use_enable unicode) \
+ $(use_with X x) \
+ $(use_with X clx)
+}
+
+src_compile() {
+ #parallel fails
+ emake -j1 || die "Compilation failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ANNOUNCEMENT Copyright
+ dodoc "${FILESDIR}"/README.Gentoo
+ pushd build/doc
+ newman ecl.man ecl.1
+ newman ecl-config.man ecl-config.1
+ popd
+}
diff --git a/dev-lisp/ecls/files/11.1.1-headers-gentoo.patch b/dev-lisp/ecls/files/11.1.1-headers-gentoo.patch
new file mode 100644
index 000000000000..635fc5d4afde
--- /dev/null
+++ b/dev-lisp/ecls/files/11.1.1-headers-gentoo.patch
@@ -0,0 +1,17 @@
+diff -Naur ecl-8.12.0.orig/src/h/object.h ecl-8.12.0/src/h/object.h
+--- ecl.orig/src/h/object.h 2008-12-17 16:41:53.000000000 +0100
++++ ecl/src/h/object.h 2008-12-17 19:35:05.000000000 +0100
+@@ -23,8 +23,13 @@
+ Integer and boolean types (see config.h)
+ */
+
++#ifndef TRUE
+ #define TRUE 1 /* boolean true value */
++#endif
++
++#ifndef FALSE
+ #define FALSE 0 /* boolean false value */
++#endif
+
+ #if !defined(__cplusplus) && !defined(bool)
+ typedef int bool;