summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-09-08 10:46:56 +0000
committerUlrich Müller <ulm@gentoo.org>2007-09-08 10:46:56 +0000
commitb98c54596e21380a8b93f04529173192fdf47d7d (patch)
treeabab21544e313999ac5ccbaa4df7aeb76bf860e3 /dev-lisp
parentStable for HPPA (bug #186928). (diff)
downloadgentoo-2-b98c54596e21380a8b93f04529173192fdf47d7d.tar.gz
gentoo-2-b98c54596e21380a8b93f04529173192fdf47d7d.tar.bz2
gentoo-2-b98c54596e21380a8b93f04529173192fdf47d7d.zip
Fix fastcgi build problem, bug #154889.
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog8
-rw-r--r--dev-lisp/clisp/clisp-2.41.ebuild3
-rw-r--r--dev-lisp/clisp/files/2.41-fastcgi-build.patch12
3 files changed, 21 insertions, 2 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index 5cadfa1183d7..b1878d0dd6bc 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.61 2007/09/04 19:43:41 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.62 2007/09/08 10:46:55 ulm Exp $
+
+ 08 Sep 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/2.41-fastcgi-build.patch, clisp-2.41.ebuild:
+ Fix fastcgi build problem. Bug #154889, reported by Gleb Litvjak
+ <blaster999@gmail.com>. Patch backported from upstream CVS by Dave Wallace
+ <dw1@hundo.net>.
04 Sep 2007; Christian Faulhammer <opfer@gentoo.org> clisp-2.41.ebuild:
stable x86, bug 173050
diff --git a/dev-lisp/clisp/clisp-2.41.ebuild b/dev-lisp/clisp/clisp-2.41.ebuild
index 9b7025438fbc..7c0b88f27e89 100644
--- a/dev-lisp/clisp/clisp-2.41.ebuild
+++ b/dev-lisp/clisp/clisp-2.41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.41.ebuild,v 1.7 2007/09/04 19:43:41 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.41.ebuild,v 1.8 2007/09/08 10:46:55 ulm Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -42,6 +42,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch ${FILESDIR}/2.41-fastcgi-Makefile-gentoo.patch
+ epatch ${FILESDIR}/2.41-fastcgi-build.patch
epatch ${FILESDIR}/2.41-linux-headers.patch
}
diff --git a/dev-lisp/clisp/files/2.41-fastcgi-build.patch b/dev-lisp/clisp/files/2.41-fastcgi-build.patch
new file mode 100644
index 000000000000..05206f1acf9a
--- /dev/null
+++ b/dev-lisp/clisp/files/2.41-fastcgi-build.patch
@@ -0,0 +1,12 @@
+--- clisp-2.41.orig/modules/fastcgi/fastcgi.lisp 2006-10-13 05:02:24.000000000 +0200
++++ clisp-2.41/modules/fastcgi/fastcgi.lisp 2007-09-08 11:58:49.000000000 +0200
+@@ -147,6 +147,9 @@
+
+ ; -------------- "C" functions
+ ;(c-lines "#include \"fastcgi.h\"~%"); completely wrapped
++(eval-when (compile)
++ ;;NB this global affects further compilations in this session
++ (setq ffi:*output-c-functions* t))
+
+ ; Our wrappers
+ (def-call-out fcgi_getenv (:arguments (var c-string)) (:return-type c-string))