summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-02-21 16:18:05 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-02-21 16:18:05 +0000
commit6ca774a87144f2f644582eb4a166177d74386f0b (patch)
treee6bce1665b2025e2dc3586d99b8093a84ce8e6b5 /dev-lisp
parentAdded use of msn, yahoo, and oscar USE flags (Manifest recommit) (diff)
downloadgentoo-2-6ca774a87144f2f644582eb4a166177d74386f0b.tar.gz
gentoo-2-6ca774a87144f2f644582eb4a166177d74386f0b.tar.bz2
gentoo-2-6ca774a87144f2f644582eb4a166177d74386f0b.zip
moved slot 0.1 -> 0.
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/gauche-gl/ChangeLog9
-rw-r--r--dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild6
-rw-r--r--dev-lisp/gauche-gl/gauche-gl-0.3.1.ebuild68
-rw-r--r--dev-lisp/gauche-gl/metadata.xml12
4 files changed, 64 insertions, 31 deletions
diff --git a/dev-lisp/gauche-gl/ChangeLog b/dev-lisp/gauche-gl/ChangeLog
index a13755a97850..4b30e79278bc 100644
--- a/dev-lisp/gauche-gl/ChangeLog
+++ b/dev-lisp/gauche-gl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/gauche-gl
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche-gl/ChangeLog,v 1.3 2003/12/31 04:38:57 george Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche-gl/ChangeLog,v 1.4 2004/02/21 16:18:04 hattya Exp $
+
+ 22 Feb 2004; Akinori Hattori <hattya@gentoo.org> gauche-gl-0.3.1.ebuild,
+ metadata.xml:
+ moved slot 0.1 -> 0.
+ I've taken over from karltk.
*gauche-gl-0.3.1 (30 Dec 2003)
diff --git a/dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild b/dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild
index e6ca665be841..1a9293c9a14d 100644
--- a/dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild
+++ b/dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild,v 1.3 2003/09/06 22:35:54 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild,v 1.4 2004/02/21 16:18:04 hattya Exp $
DESCRIPTION="OpenGL 1.1 bindings for Gauche"
HOMEPAGE="http://gauche.sf.net"
SRC_URI="mirror://sourceforge/gauche/Gauche-gl-${PV}.tgz"
LICENSE="BSD"
-SLOT="0.1"
+SLOT="0"
KEYWORDS="x86"
DEPEND="virtual/glibc
virtual/opengl
diff --git a/dev-lisp/gauche-gl/gauche-gl-0.3.1.ebuild b/dev-lisp/gauche-gl/gauche-gl-0.3.1.ebuild
index 9ffdad4e1b80..71cb3f1be829 100644
--- a/dev-lisp/gauche-gl/gauche-gl-0.3.1.ebuild
+++ b/dev-lisp/gauche-gl/gauche-gl-0.3.1.ebuild
@@ -1,39 +1,55 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche-gl/gauche-gl-0.3.1.ebuild,v 1.1 2003/12/31 04:38:57 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche-gl/gauche-gl-0.3.1.ebuild,v 1.2 2004/02/21 16:18:05 hattya Exp $
-inherit base
+inherit eutils flag-o-matic
-DESCRIPTION="OpenGL 1.1 bindings for Gauche"
-HOMEPAGE="http://gauche.sf.net"
-SRC_URI="mirror://sourceforge/gauche/Gauche-gl-${PV}.tgz"
+IUSE=""
+MY_P="${P/g/G}"
+
+DESCRIPTION="OpenGL binding for Gauche"
+HOMEPAGE="http://gauche.sf.net/"
+SRC_URI="mirror://sourceforge/gauche/${MY_P}.tgz"
+
+RESTRICT="nomirror"
LICENSE="BSD"
-SLOT="0.1"
KEYWORDS="~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/opengl
+ >=media-libs/glut-3.7
+ >=dev-lisp/gauche-0.7.3"
+
+src_compile() {
+
+ local myflags
+
+ filter-flags -fforce-addr
-DEPEND="virtual/glibc
- virtual/opengl
- >=dev-lisp/gauche-0.7.3
- >=media-libs/glut-3.7"
+ myflags=${CFLAGS}
+ unset CFLAGS CXXFLAGS
-My_PN=${PN/g/G}
-S=${WORKDIR}/${My_PN}-${PV}
-PATCHES1="${FILESDIR}/nvidia-headers-gentoo.diff
- ${FILESDIR}/destdir-gentoo.diff"
+ econf || die
+ emake OPTFLAGS="${myflags}" || die
-src_install () {
- dodir `gauche-config --syslibdir`
- dodir `gauche-config --sysarchdir`
- dodir `gauche-config --sysincdir`
+}
+
+src_install() {
+
+ dodir $(gauche-config --syslibdir)
+ dodir $(gauche-config --sysincdir)
+ dodir $(gauche-config --sysarchdir)
make DESTDIR=${D} install || die
- dodoc COPYING README ChangeLog INSTALL* VERSION
- local expls=/usr/share/${PN}/examples
- dodir ${expls}/glbook
- insinto ${expls}
- doins examples/mandelbrot.scm
- insinto ${expls}/glbook
- doins examples/glbook/*
+ dodoc README ChangeLog INSTALL* COPYING
+
+ docinto examples
+ dodoc examples/*.scm
+
+ docinto examples/glbook
+ dodoc examples/glbook/*
+
}
diff --git a/dev-lisp/gauche-gl/metadata.xml b/dev-lisp/gauche-gl/metadata.xml
new file mode 100644
index 000000000000..e09f2734d6c0
--- /dev/null
+++ b/dev-lisp/gauche-gl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+
+ <longdescription>
+ OpenGL binding of Gauche
+ </longdescription>
+</pkgmetadata>