summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-11-30 16:32:40 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-11-30 16:32:40 +0000
commit5fac6f56b943135fab117e9965809328fb2951ca (patch)
treec27ddf4861ca69aacf4a753f2aebaff0a16652cf /dev-lisp
parentupdate lirc-0.7.0 to use linux-mod (Manifest recommit) (diff)
downloadgentoo-2-5fac6f56b943135fab117e9965809328fb2951ca.tar.gz
gentoo-2-5fac6f56b943135fab117e9965809328fb2951ca.tar.bz2
gentoo-2-5fac6f56b943135fab117e9965809328fb2951ca.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog10
-rw-r--r--dev-lisp/ecls/ecls-0.9d.ebuild3
-rw-r--r--dev-lisp/ecls/files/0.9d-headers-gentoo.patch37
-rw-r--r--dev-lisp/ecls/files/0.9d-texinfo-gentoo.patch116
4 files changed, 97 insertions, 69 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index 8638ccda5963..5ae3c374d314 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lisp/ecls
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.11 2004/11/04 20:21:55 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.12 2004/11/30 16:32:40 mkennedy Exp $
+
+ 30 Nov 2004; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/0.9d-headers-gentoo.patch, files/0.9d-texinfo-gentoo.patch,
+ ecls-0.9d.ebuild:
+ Elide texinfo documentation build since it cannot be built for now; Guard
+ against ech.h being recursively included; Conditionally define TRUE and
+ FALSE in object.h to play nicely with other libraries which do the same (eg.
+ glib).
04 Nov 2004; Matthew Kenendy <mkennedy@gentoo.org> ecls-0.9d.ebuild:
--with-cmu-format should have been --with-cmuformat
diff --git a/dev-lisp/ecls/ecls-0.9d.ebuild b/dev-lisp/ecls/ecls-0.9d.ebuild
index 3c585e66ffaa..dafb4fc9bf58 100644
--- a/dev-lisp/ecls/ecls-0.9d.ebuild
+++ b/dev-lisp/ecls/ecls-0.9d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9d.ebuild,v 1.2 2004/11/04 20:21:55 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9d.ebuild,v 1.3 2004/11/30 16:32:40 mkennedy Exp $
inherit eutils
@@ -23,6 +23,7 @@ S=${WORKDIR}/ecl-${PV}
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}-texinfo-gentoo.patch || die
+ epatch ${FILESDIR}/${PV}-headers-gentoo.patch || die
}
src_compile() {
diff --git a/dev-lisp/ecls/files/0.9d-headers-gentoo.patch b/dev-lisp/ecls/files/0.9d-headers-gentoo.patch
new file mode 100644
index 000000000000..e8f2c299da0e
--- /dev/null
+++ b/dev-lisp/ecls/files/0.9d-headers-gentoo.patch
@@ -0,0 +1,37 @@
+Only in ecl-0.9d: build
+diff --exclude 'Makefile*' --exclude '*~' -ur ecl-0.9d.orig/src/h/ecl.h ecl-0.9d/src/h/ecl.h
+--- ecl-0.9d.orig/src/h/ecl.h 2004-11-29 18:46:38.000000000 -0600
++++ ecl-0.9d/src/h/ecl.h 2004-11-29 21:13:29.099069235 -0600
+@@ -13,6 +13,9 @@
+ See file '../Copyright' for full details.
+ */
+
++#ifndef __ECL_H__
++#define __ECL_H__
++
+ #ifndef _MSC_VER
+ #include <sys/param.h> /* includes <sys/signal.h> and <sys/types.h> */
+ #else
+@@ -54,3 +57,5 @@
+ #ifdef LOCATIVE
+ #include <unify.h>
+ #endif
++
++#endif
+diff --exclude 'Makefile*' --exclude '*~' -ur ecl-0.9d.orig/src/h/object.h ecl-0.9d/src/h/object.h
+--- ecl-0.9d.orig/src/h/object.h 2004-11-29 18:46:38.000000000 -0600
++++ ecl-0.9d/src/h/object.h 2004-11-29 21:13:07.333474284 -0600
+@@ -22,8 +22,13 @@
+ Integer and boolean types (see config.h)
+ */
+
++#ifndef TRUE
+ #define TRUE 1 /* boolean true value */
++#endif
++
++#ifndef FALSE
+ #define FALSE 0 /* boolean false value */
++#endif
+
+ #define CHAR_CODE_LIMIT 256 /* ASCII character code limit */
+
diff --git a/dev-lisp/ecls/files/0.9d-texinfo-gentoo.patch b/dev-lisp/ecls/files/0.9d-texinfo-gentoo.patch
index 565f4a3735cf..d8111bf42862 100644
--- a/dev-lisp/ecls/files/0.9d-texinfo-gentoo.patch
+++ b/dev-lisp/ecls/files/0.9d-texinfo-gentoo.patch
@@ -1,73 +1,55 @@
-diff -ur ecl-0.9d.orig/src/doc/user.txi ecl-0.9d/src/doc/user.txi
---- ecl-0.9d.orig/src/doc/user.txi 2004-11-02 05:26:16.000000000 -0600
-+++ ecl-0.9d/src/doc/user.txi 2004-11-02 20:38:49.642445608 -0600
-@@ -3394,11 +3394,11 @@
- @deffnx {Method} {(setf documentation)} {new-value (list list) @optional{} doc-type}
- @end deffn
+Only in ecl-0.9d: Makefile
+diff --exclude '*~' -ur ecl-0.9d.orig/Makefile.in ecl-0.9d/Makefile.in
+--- ecl-0.9d.orig/Makefile.in 2004-11-29 18:46:39.000000000 -0600
++++ ecl-0.9d/Makefile.in 2004-11-29 20:53:09.479364087 -0600
+@@ -80,13 +80,6 @@
+ uninstall:
+ cd build; $(MAKE) uninstall
--@defun {ensure-generic-function} {function-name @keys{} lambda-list @keys :argument-precedence-order :declare :documentation :generic-function-class|ekeys{:method-combination :method-class :environment}}
--@example
--function-name ::= symbol | (setf symbol)
--@end example
--@end defun
-+@c @defun {ensure-generic-function} {function-name @keys{} lambda-list @keys :argument-precedence-order :declare :documentation :generic-function-class|ekeys{:method-combination :method-class :environment}}
-+@c @example
-+@c function-name ::= symbol | (setf symbol)
-+@c @end example
-+@c @end defun
+-# ==================== Documentation ====================
+-
+-info:
+- (cd ${srcdir}/doc; $(MAKE) info)
+-dvi:
+- (cd ${srcdir}/doc; $(MAKE) dvi)
+-
+ # ==================== Cleaning up and miscellanea ====================
- @defun {find-class} {symbol @optional{} errorp environment}
+ # `clean'
+Only in ecl-0.9d: build
+diff --exclude '*~' -ur ecl-0.9d.orig/src/Makefile.in ecl-0.9d/src/Makefile.in
+--- ecl-0.9d.orig/src/Makefile.in 2004-11-29 18:46:39.000000000 -0600
++++ ecl-0.9d/src/Makefile.in 2004-11-29 20:48:57.000000000 -0600
+@@ -40,7 +40,7 @@
+ LSP_LIBRARIES = @LSP_LIBRARIES@
+ TARGETS = @TARGETS@
-@@ -3417,29 +3417,29 @@
+-all: $(TARGETS) ecl-config doc
++all: $(TARGETS) ecl-config
+ .PHONY: all
- The generic function function-keywords is used to return the keyword parameter specifiers for a given method.
+ %Makefile: $(srcdir)/%Makefile.in config.status
+@@ -94,7 +94,6 @@
+ head -8 config.status | tail -6 >> $@
+ install: BUILD-STAMP install-base
+ cd c; $(MAKE) prefix=$(prefix) install
+- cd doc; $(MAKE) prefix=$(prefix) install
+ install-base:
+ $(mkinstalldirs) $(bindir) $(libdir)/h
+ for i in $(TARGETS); do \
+@@ -108,15 +107,10 @@
+ flatinstall: BUILD-STAMP
+ $(MAKE) bindir=$(prefix) libdir=$(prefix) install-base
+ cd c; $(MAKE) prefix=$(prefix) flatinstall
+- cd doc; $(MAKE) prefix=$(prefix) flatinstall
--@defmac {generic-function} {lambda-list \mchoice{option | @{method-description@}*}}
-+@c @defmac {generic-function} {lambda-list \mchoice{option | @{method-description@}*}}
+ uninstall:
+ for i in $(TARGETS) ecl-config; do rm -rf $(bindir)/$$i; done
+ rm -rf $(libdir)
+- cd doc; $(MAKE) uninstall
+-
+-doc: $(TARGETS)
+- cd doc; $(MAKE)
--@example
--option ::= (:argument-precedence-order @{parameter-name@}+)
-- | (declare @{declaration@}+)
-- | (:documentation string)
-- | (:method-combination symbol @{arg@}*)
-- | (:generic-function-class class-name)
-- | (:method-class class-name)
--method-description ::= (:method @{method-qualifier@}*
-- specialized-lambda-list
-- @{declaration | @var{documentation}@}*
-- @{form@}*)
--@end example
--The @code{generic-function} macro creates an anonymous generic function. The
--generic function is created with the set of methods specified by its method
--descriptions. The @var{option}, @var{method-qualifier}, and
--@var{specialized-lambda-list} arguments are the same as for @code{defgeneric}.
--The generic function object is returned as the result. If no method
--descriptions are specified, an anonymous generic function with no methods is
--created. See @macref{defgeneric}, @macref{generic-flet},
--@macref{generic-labels}, @macref{defmethod}.
--@end defmac
-+@c @example
-+@c option ::= (:argument-precedence-order @{parameter-name@}+)
-+@c | (declare @{declaration@}+)
-+@c | (:documentation string)
-+@c | (:method-combination symbol @{arg@}*)
-+@c | (:generic-function-class class-name)
-+@c | (:method-class class-name)
-+@c method-description ::= (:method @{method-qualifier@}*
-+@c specialized-lambda-list
-+@c @{declaration | @var{documentation}@}*
-+@c @{form@}*)
-+@c @end example
-+@c The @code{generic-function} macro creates an anonymous generic function. The
-+@c generic function is created with the set of methods specified by its method
-+@c descriptions. The @var{option}, @var{method-qualifier}, and
-+@c @var{specialized-lambda-list} arguments are the same as for @code{defgeneric}.
-+@c The generic function object is returned as the result. If no method
-+@c descriptions are specified, an anonymous generic function with no methods is
-+@c created. See @macref{defgeneric}, @macref{generic-flet},
-+@c @macref{generic-labels}, @macref{defmethod}.
-+@c @end defmac
-
- @deffn {Generic} {initialize-instance} instance @rest{} initargs
- @deffnx {Method} {initialize-instance} {(instance standard-object) @rest{} initargs}
-Only in ecl-0.9d/src/doc: user.txi~
+ clean: clean_lisp
+ for i in ${SUBDIR}; do (cd $$i; $(MAKE) clean); done