summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-07-09 16:33:30 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-07-09 16:33:30 +0000
commit5e92d18ef4641c8fea5fe1dac821f8ff5b6a0625 (patch)
tree8ba773122ab061425f5b7f14440871a72e0ece32 /dev-lisp
parentAdded ~x86-fbsd keyword. (diff)
downloadgentoo-2-5e92d18ef4641c8fea5fe1dac821f8ff5b6a0625.tar.gz
gentoo-2-5e92d18ef4641c8fea5fe1dac821f8ff5b6a0625.tar.bz2
gentoo-2-5e92d18ef4641c8fea5fe1dac821f8ff5b6a0625.zip
New upstream version.
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog8
-rw-r--r--dev-lisp/ecls/ecls-0.9i.ebuild66
-rw-r--r--dev-lisp/ecls/files/0.9i-headers-gentoo.patch36
-rw-r--r--dev-lisp/ecls/files/README.Gentoo17
-rw-r--r--dev-lisp/ecls/files/digest-ecls-0.9h2
-rw-r--r--dev-lisp/ecls/files/digest-ecls-0.9i3
6 files changed, 115 insertions, 17 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index a06e22b75f7e..615bf2133c93 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/ecls
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.23 2006/02/15 07:39:37 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.24 2006/07/09 16:33:30 mkennedy Exp $
+
+*ecls-0.9i (09 Jul 2006)
+
+ 09 Jul 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/0.9i-headers-gentoo.patch, files/README.Gentoo, +ecls-0.9i.ebuild:
+ New upstream version.
15 Feb 2006; Matthew Kennedy <mkennedy@gentoo.org>
files/0.9h-sockets-c++-gentoo.patch:
diff --git a/dev-lisp/ecls/ecls-0.9i.ebuild b/dev-lisp/ecls/ecls-0.9i.ebuild
new file mode 100644
index 000000000000..2b3f791cd6b4
--- /dev/null
+++ b/dev-lisp/ecls/ecls-0.9i.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9i.ebuild,v 1.1 2006/07/09 16:33:30 mkennedy Exp $
+
+inherit eutils
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation."
+SRC_URI="mirror://sourceforge/ecls/ecl-${PV}.tgz"
+HOMEPAGE="http://ecls.sourceforge.net/"
+SLOT="0"
+LICENSE="BSD LGPL-2"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+
+DEPEND="=dev-libs/gmp-4*
+ app-text/texi2html"
+
+# ECL fails to build with a system-installed Boehm GC (which apparently is a
+# rare configuration since most distributions neglect to install the useful
+# private headers). Until this is properly isolated, we use the Boehm GC
+# included with ECL.
+
+# dev-libs/boehm-gc
+
+IUSE="X c++"
+
+PROVIDE="virtual/commonlisp"
+
+S=${WORKDIR}/ecl-${PV:0:4}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-headers-gentoo.patch || die
+ # waiting on upstream to fix this http://sourceforge.net/tracker/?func=detail&aid=1519256&group_id=30035&atid=398053
+# epatch ${FILESDIR}/${PV}-sockets-c++-gentoo.patch || die
+}
+
+src_compile() {
+ local myconf="--with-system-gmp
+ --enable-boehm=included
+ --with-tcp
+ --with-ffi
+ --with-clos-streams
+ --with-cmuformat
+ --with-asdf
+ `use_with c++ cxx`
+ `use_with X x`
+ `use_with X clx`"
+ einfo "Configuring with: $myconf"
+ econf ${myconf} || die
+ make || die
+}
+
+src_install () {
+ make bindir=${D}/usr/bin \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ libdir=${D}/usr/lib/ecl \
+ includedir=${D}/usr/include \
+ docdir=${D}/usr/share/doc/${PF} install || true
+ dohtml doc/*.html
+ dodoc ANNOUNCEMENT Copyright LGPL
+
+ insinto /usr/share/doc/${PF}/
+ doins ${FILESDIR}/README.Gentoo
+}
diff --git a/dev-lisp/ecls/files/0.9i-headers-gentoo.patch b/dev-lisp/ecls/files/0.9i-headers-gentoo.patch
new file mode 100644
index 000000000000..e95adfa18360
--- /dev/null
+++ b/dev-lisp/ecls/files/0.9i-headers-gentoo.patch
@@ -0,0 +1,36 @@
+diff -ur ecl-0.9i.orig/src/h/ecl.h ecl-0.9i/src/h/ecl.h
+--- ecl-0.9i.orig/src/h/ecl.h 2005-08-12 11:26:42.000000000 -0500
++++ ecl-0.9i/src/h/ecl.h 2005-08-13 13:10:59.000000000 -0500
+@@ -13,6 +13,9 @@
+ See file '../Copyright' for full details.
+ */
+
++#ifndef __ECL_H__
++#define __ECL_H__
++
+ #ifndef _MSC_VER
+ #include <sys/param.h> /* includes <sys/signal.h> and <sys/types.h> */
+ #else
+@@ -69,3 +72,5 @@
+ #endif
+
+ typedef void (*ecl_init_function_t)(cl_object block);
++
++#endif
+diff -ur ecl-0.9i.orig/src/h/object.h ecl-0.9i/src/h/object.h
+--- ecl-0.9i.orig/src/h/object.h 2005-08-12 11:26:42.000000000 -0500
++++ ecl-0.9i/src/h/object.h 2005-08-13 13:18:03.000000000 -0500
+@@ -22,8 +22,13 @@
+ Integer and boolean types (see config.h)
+ */
+
++#ifndef TRUE
+ #define TRUE 1 /* boolean true value */
++#endif
++
++#ifndef FALSE
+ #define FALSE 0 /* boolean false value */
++#endif
+
+ #define CHAR_CODE_LIMIT 256 /* ASCII character code limit */
+
diff --git a/dev-lisp/ecls/files/README.Gentoo b/dev-lisp/ecls/files/README.Gentoo
index 40221f9f95ba..caa334f7c661 100644
--- a/dev-lisp/ecls/files/README.Gentoo
+++ b/dev-lisp/ecls/files/README.Gentoo
@@ -1,4 +1,4 @@
--*- outline -*- $Id: README.Gentoo,v 1.1 2005/06/07 01:44:37 mkennedy Exp $
+-*- outline -*- $Id: README.Gentoo,v 1.2 2006/07/09 16:33:30 mkennedy Exp $
Gentoo GNU/Linux specific notes for ECL
---------------------------------------
@@ -10,21 +10,6 @@ This is the README.Gentoo file from /usr/share/doc/@PF@/ directory.
elsewhere. This makes it easier to use ECL with other software which defines
those C preprocesser symbols (eg. glib-2.0).
- * Support for a kind of Common Lisp Controller is available since
- dev-lisp/ecls-0.9f_p1 but not enabled by default. The controller included in
- ECL simply puts /usr/share/common-lisp/systems/ into ASDF:*CENTRAL-REGISTRY*
- and extends ASDF:OUTPUT-FILES so that FASLs are placed into
- /var/cache/common-lisp-controller/<username>/ecl/.
-
- To use this controller, either copy /usr/share/doc/@PF@/clc-lite.lisp to
- your ~/.eclrc or source it from there.
-
- * ECL versus dev-lisp/cl-*: ECL 0.9f_p1 and later will compile a lot of the
- dev-lisp/cl-* ports. Quite a few ports will fail however. Should you come
- across a failure, consider isolating it in an ECL without the clc-lite.lisp
- code loaded. Submit your results preferably to the Gentoo Bugzilla or to
- upstream if you're absolutely sure it isn't Gentoo related.
-
If you encounter any problems or have suggestions, use http://bugs.gentoo.org.
Please don't bother the upstream authors unless you are absolutely certain it is
not Gentoo-related.
diff --git a/dev-lisp/ecls/files/digest-ecls-0.9h b/dev-lisp/ecls/files/digest-ecls-0.9h
index 8af0a8549c2d..1235d6eed1ca 100644
--- a/dev-lisp/ecls/files/digest-ecls-0.9h
+++ b/dev-lisp/ecls/files/digest-ecls-0.9h
@@ -1 +1,3 @@
MD5 d02ae5ce7fa48fe534666ce853aaa27e ecl-0.9h.tgz 4324629
+RMD160 e3d3318b9fca4230702032c43e13ee95865b2672 ecl-0.9h.tgz 4324629
+SHA256 22b04b20655444373e58bfd85ceee332890f3501df130ee9dc15940d11ceb42e ecl-0.9h.tgz 4324629
diff --git a/dev-lisp/ecls/files/digest-ecls-0.9i b/dev-lisp/ecls/files/digest-ecls-0.9i
new file mode 100644
index 000000000000..1ca47c23c133
--- /dev/null
+++ b/dev-lisp/ecls/files/digest-ecls-0.9i
@@ -0,0 +1,3 @@
+MD5 ea47c0a9f47c510ff4654b44b004537a ecl-0.9i.tgz 4308479
+RMD160 98d0d4bad39ece9427d356e28a561fd2e2ba7662 ecl-0.9i.tgz 4308479
+SHA256 158f0d89df3a8abb309deb389682e4fd4fd74dbb196614061df1b24015332a81 ecl-0.9i.tgz 4308479