summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-07-29 09:48:23 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-07-29 09:48:23 +0000
commit5547a822b55b7e6f833e7b380bf17408fbed116f (patch)
treeb62923993d6dc2b3c2e2c7f8108b8d21e86478bb /dev-lisp
parentsubmission #4998 - a python dtabase interface for firebird (diff)
downloadgentoo-2-5547a822b55b7e6f833e7b380bf17408fbed116f.tar.gz
gentoo-2-5547a822b55b7e6f833e7b380bf17408fbed116f.tar.bz2
gentoo-2-5547a822b55b7e6f833e7b380bf17408fbed116f.zip
support gcc-3.x, repoman-ness
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog10
-rw-r--r--dev-lisp/clisp/clisp-2.28.ebuild3
-rw-r--r--dev-lisp/clisp/clisp-2.29.ebuild42
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.291
4 files changed, 54 insertions, 2 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index 1247ae7a8bd1..fec548450c18 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.1 2002/06/03 23:44:26 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.2 2002/07/29 09:48:21 mkennedy Exp $
+
+*clisp-2.29 (29 Jul 2002)
+
+ 29 Jul 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ clisp-2.29.ebuild, files/digest-clisp-2.29 :
+
+ New upstream minor version to support gcc-3.x. Repoman compliance
+ added.
*clisp-2.28 (03 Jun 2002)
diff --git a/dev-lisp/clisp/clisp-2.28.ebuild b/dev-lisp/clisp/clisp-2.28.ebuild
index 48fbd1be9ec8..79bfc53be891 100644
--- a/dev-lisp/clisp/clisp-2.28.ebuild
+++ b/dev-lisp/clisp/clisp-2.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.28.ebuild,v 1.1 2002/06/03 23:44:26 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.28.ebuild,v 1.2 2002/07/29 09:48:23 mkennedy Exp $
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
@@ -10,6 +10,7 @@ DEPEND="X? ( x11-base/xfree )"
RDEPEND="$DEPEND"
LICENSE="GPL-2"
SLOT="2"
+KEYWORDS="x86"
src_compile() {
local myconf="--with-dynamic-ffi --with-dynamic-modules --with-export-syscalls --with-module=wildcard --with-module=regexp --with-module=bindings/linuxlibc6"
diff --git a/dev-lisp/clisp/clisp-2.29.ebuild b/dev-lisp/clisp/clisp-2.29.ebuild
new file mode 100644
index 000000000000..c614f9784ac4
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.29.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.29.ebuild,v 1.1 2002/07/29 09:48:23 mkennedy Exp $
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="http://cvs2.cons.org/ftp-area/clisp/source/latest/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+DEPEND="X? ( x11-base/xfree )"
+RDEPEND="$DEPEND"
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf="--with-dynamic-ffi --with-dynamic-modules --with-export-syscalls --with-module=wildcard --with-module=regexp --with-module=bindings/linuxlibc6"
+ if [ -n "`use X`" ] ; then
+ myconf="${myconf} --with-module=clx/new-clx"
+ fi
+
+ # compilation of modules fails if we don't do this (mkennedy: yep
+ # -- confirmed on gcc3.2 too)
+
+ unset CHOST
+ unset CFLAGS
+ unset CXXFLAGS
+
+ ./configure --prefix=/usr ${myconf} || die "./configure failed"
+ cd src
+ ./makemake ${myconf} > Makefile
+ make config.lisp
+ emake || die
+}
+
+src_install () {
+ cd src
+ make DESTDIR=${D} prefix=/usr install-bin || die
+ install -Dm 644 clisp.1 ${D}/usr/share/man/man1/clisp.1
+ install -Dm 644 clreadline.3 ${D}/usr/share/man/man3/clreadline.3
+ dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT ANNOUNCE clisp.dvi clisp.html clreadline.dvi clreadline.html
+}
+
diff --git a/dev-lisp/clisp/files/digest-clisp-2.29 b/dev-lisp/clisp/files/digest-clisp-2.29
new file mode 100644
index 000000000000..39b0d278d6f3
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.29
@@ -0,0 +1 @@
+MD5 53f7cfba5c5f3f7d536541e1df210b74 clisp-2.29.tar.gz 10979127