summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-21 00:02:50 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-21 00:02:50 +0000
commit3c92db331cd59e5ab59c366dcac15c8d6f60f4b8 (patch)
tree3d358aa0b28e24daf0a6a92a51773a0ea164594a /dev-lisp
parent(Portage version: 2.0.51.19) (Manifest recommit) (diff)
downloadgentoo-2-3c92db331cd59e5ab59c366dcac15c8d6f60f4b8.tar.gz
gentoo-2-3c92db331cd59e5ab59c366dcac15c8d6f60f4b8.tar.bz2
gentoo-2-3c92db331cd59e5ab59c366dcac15c8d6f60f4b8.zip
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-html-diff/ChangeLog10
-rw-r--r--dev-lisp/cl-html-diff/Manifest3
-rw-r--r--dev-lisp/cl-html-diff/cl-html-diff-0.1.ebuild25
-rw-r--r--dev-lisp/cl-html-diff/files/digest-cl-html-diff-0.11
-rw-r--r--dev-lisp/cl-html-diff/metadata.xml5
5 files changed, 44 insertions, 0 deletions
diff --git a/dev-lisp/cl-html-diff/ChangeLog b/dev-lisp/cl-html-diff/ChangeLog
new file mode 100644
index 000000000000..e58d2798a07f
--- /dev/null
+++ b/dev-lisp/cl-html-diff/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-html-diff
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-html-diff/ChangeLog,v 1.1 2005/03/21 00:02:50 mkennedy Exp $
+
+*cl-html-diff-0.1 (21 Mar 2005)
+
+ 21 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-html-diff-0.1.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-html-diff/Manifest b/dev-lisp/cl-html-diff/Manifest
new file mode 100644
index 000000000000..c7e1b4b7f321
--- /dev/null
+++ b/dev-lisp/cl-html-diff/Manifest
@@ -0,0 +1,3 @@
+MD5 2fe2bbe26319f02f177e3f5b7c2598af cl-html-diff-0.1.ebuild 688
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 320deb49bcf32b1fcdf1fd142a8197ad files/digest-cl-html-diff-0.1 66
diff --git a/dev-lisp/cl-html-diff/cl-html-diff-0.1.ebuild b/dev-lisp/cl-html-diff/cl-html-diff-0.1.ebuild
new file mode 100644
index 000000000000..88d06af4a160
--- /dev/null
+++ b/dev-lisp/cl-html-diff/cl-html-diff-0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-html-diff/cl-html-diff-0.1.ebuild,v 1.1 2005/03/21 00:02:50 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="CL-HTML-DIFF is a Common Lisp library for generating a human-readable diff of two HTML documents, using HTML."
+HOMEPAGE="http://www.cliki.net/CL-HTML-DIFF"
+SRC_URI="http://lemonodor.com/code/${PN}_${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-difflib"
+
+CLPACKAGE=cl-html-diff
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_install() {
+ common-lisp-install *.asd *.lisp
+ common-lisp-system-symlink
+ dodoc LICENSE.txt
+}
diff --git a/dev-lisp/cl-html-diff/files/digest-cl-html-diff-0.1 b/dev-lisp/cl-html-diff/files/digest-cl-html-diff-0.1
new file mode 100644
index 000000000000..7b51a1d059d9
--- /dev/null
+++ b/dev-lisp/cl-html-diff/files/digest-cl-html-diff-0.1
@@ -0,0 +1 @@
+MD5 13a3d9aa3545ba5e75dbe029860cb6de cl-html-diff_0.1.tar.gz 2824
diff --git a/dev-lisp/cl-html-diff/metadata.xml b/dev-lisp/cl-html-diff/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-html-diff/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>