summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-06-13 23:57:25 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-06-13 23:57:25 +0000
commit2b24ff3254cc37c0bd2a6ac4cece87e9ae0fea4e (patch)
tree43d4a211afe810021017efab1be5c29bb1139fa3 /dev-lisp
parentRespect LDFLAGS while linking the library. (diff)
downloadgentoo-2-2b24ff3254cc37c0bd2a6ac4cece87e9ae0fea4e.tar.gz
gentoo-2-2b24ff3254cc37c0bd2a6ac4cece87e9ae0fea4e.tar.bz2
gentoo-2-2b24ff3254cc37c0bd2a6ac4cece87e9ae0fea4e.zip
stable x86, bug 180118; double negation changed to normal test for source USE flag
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/ChangeLog6
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.4.ebuild18
2 files changed, 14 insertions, 10 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index 4c25aa730cf9..8fb95340ae80 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.109 2007/05/28 14:36:21 joslwah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.110 2007/06/13 23:57:25 opfer Exp $
+
+ 13 Jun 2007; Christian Faulhammer <opfer@gentoo.org> sbcl-1.0.4.ebuild:
+ stable x86, bug 180118; double negation changed to normal test for source
+ USE flag
*sbcl-1.0.6 (28 May 2007)
diff --git a/dev-lisp/sbcl/sbcl-1.0.4.ebuild b/dev-lisp/sbcl/sbcl-1.0.4.ebuild
index 9e540b886c44..6ab07dec2468 100644
--- a/dev-lisp/sbcl/sbcl-1.0.4.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.4.ebuild,v 1.5 2007/04/11 14:24:36 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.4.ebuild,v 1.6 2007/06/13 23:57:25 opfer Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -23,7 +23,7 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~ppc sparc ~x86"
+KEYWORDS="~amd64 ~ppc sparc x86"
IUSE="ldb source threads unicode doc"
@@ -87,9 +87,9 @@ src_unpack() {
cat >${S}/customize-target-features.lisp <<'EOF'
(lambda (list)
(flet ((enable (x)
- (pushnew x list))
- (disable (x)
- (setf list (remove x list))))
+ (pushnew x list))
+ (disable (x)
+ (setf list (remove x list))))
EOF
if use x86 || use amd64; then
use threads && echo '(enable :sb-thread)' \
@@ -109,7 +109,7 @@ EOF
&& echo '(disable :sb-unicode)' \
>>${S}/customize-target-features.lisp
cat >>${S}/customize-target-features.lisp <<'EOF'
- )
+ )
list)
EOF
cat ${S}/customize-target-features.lisp
@@ -145,8 +145,8 @@ src_install() {
;;; work in SLIME, for example.
(setf (logical-pathname-translations "SYS")
- '(("SYS:SRC;**;*.*.*" #p"/usr/$(get_libdir)/sbcl/src/**/*.*")
- ("SYS:CONTRIB;**;*.*.*" #p"/usr/$(get_libdir)/sbcl/**/*.*")))
+ '(("SYS:SRC;**;*.*.*" #p"/usr/$(get_libdir)/sbcl/src/**/*.*")
+ ("SYS:CONTRIB;**;*.*.*" #p"/usr/$(get_libdir)/sbcl/**/*.*")))
EOF
dodir /usr/share/man
dodir /usr/share/doc/${PF}
@@ -159,7 +159,7 @@ EOF
doinfo ${S}/doc/manual/*.info*
fi
- if ! use nosource; then
+ if use source; then
# install the SBCL source
cp -pPR ${S}/src ${D}/usr/$(get_libdir)/sbcl
find ${D}/usr/$(get_libdir)/sbcl/src -type f -name \*.fasl -print0 | xargs -0 rm -f