summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-01-11 09:42:32 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-01-11 09:42:32 +0000
commit13712a8fb4681d9ee5308a8578db2e8d5f31de00 (patch)
treef170d90e76575346f07961107743c8f07e07f9e9 /dev-lisp
parent*** empty log message *** (diff)
downloadgentoo-2-13712a8fb4681d9ee5308a8578db2e8d5f31de00.tar.gz
gentoo-2-13712a8fb4681d9ee5308a8578db2e8d5f31de00.tar.bz2
gentoo-2-13712a8fb4681d9ee5308a8578db2e8d5f31de00.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-fare-matcher/ChangeLog10
-rw-r--r--dev-lisp/cl-fare-matcher/Manifest6
-rw-r--r--dev-lisp/cl-fare-matcher/cl-fare-matcher-1.1.ebuild50
-rw-r--r--dev-lisp/cl-fare-matcher/files/clisp-utf8-gentoo.patch13
-rw-r--r--dev-lisp/cl-fare-matcher/files/digest-cl-fare-matcher-1.11
-rw-r--r--dev-lisp/cl-fare-matcher/metadata.xml12
6 files changed, 89 insertions, 3 deletions
diff --git a/dev-lisp/cl-fare-matcher/ChangeLog b/dev-lisp/cl-fare-matcher/ChangeLog
new file mode 100644
index 000000000000..f2bd73f48b9c
--- /dev/null
+++ b/dev-lisp/cl-fare-matcher/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-fare-matcher
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-fare-matcher/ChangeLog,v 1.1 2004/01/11 09:42:22 mkennedy Exp $
+
+*cl-fare-matcher-1.1 (11 Jan 2004)
+
+ 11 Jan 2004; <mkennedy@gentoo.org> cl-fare-matcher-1.1.ebuild, metadata.xml,
+ files/clisp-utf8-gentoo.patch:
+ initial ebuild. ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-fare-matcher/Manifest b/dev-lisp/cl-fare-matcher/Manifest
index fad707c5d4f6..a50e3442a90b 100644
--- a/dev-lisp/cl-fare-matcher/Manifest
+++ b/dev-lisp/cl-fare-matcher/Manifest
@@ -1,5 +1,5 @@
MD5 f1a4087a6699fbee0e1a4dd995f36f9a metadata.xml 545
-MD5 817be92f610c94f41c47d9bbbad00a10 cl-fare-matcher-1.1.ebuild 893
-MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml~ 164
-MD5 d8948add19d3ad02d9b32dfb81f8cba8 cl-fare-matcher-1.1.ebuild~ 1119
+MD5 98593c1f331f465eea814aa40e7a7f85 cl-fare-matcher-1.1.ebuild 1280
+MD5 415179d76f9f8dd2b5277a1e88a3e5b7 ChangeLog 460
MD5 4e38a78dbf2494d6b54dd83d964304b5 files/digest-cl-fare-matcher-1.1 71
+MD5 58343c4e451be25b9a6610466862a60b files/clisp-utf8-gentoo.patch 560
diff --git a/dev-lisp/cl-fare-matcher/cl-fare-matcher-1.1.ebuild b/dev-lisp/cl-fare-matcher/cl-fare-matcher-1.1.ebuild
new file mode 100644
index 000000000000..34532c5a658a
--- /dev/null
+++ b/dev-lisp/cl-fare-matcher/cl-fare-matcher-1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-fare-matcher/cl-fare-matcher-1.1.ebuild,v 1.1 2004/01/11 09:42:22 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A library of macros and functions by Fare Rideau."
+HOMEPAGE="http://mapcar.org/~mrd/utilities/matcher.html
+ http://www.cliki.net/fare-matcher
+ http://www.cliki.net/fare-matcher-docs"
+SRC_URI="http://mapcar.org/~mrd/utilities/fare-matcher-ext-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+S=${WORKDIR}/matcher
+
+CLPACKAGE=fare-matcher
+
+src_unpack() {
+ unpack ${A}
+ # maybe we should consider having clisp.sh pass -E utf8 to clisp
+ epatch ${FILESDIR}/clisp-utf8-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install *.asd *.lisp
+ common-lisp-system-symlink
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postinst() {
+ while read line; do einfo ${line}; done <<EOF
+
+The comments within the source for fare-matcher provide documentation.
+You can find summarized documentation at the CLiki.
+
+ http://www.cliki.net/fare-matcher-docs
+
+EOF
+} \ No newline at end of file
diff --git a/dev-lisp/cl-fare-matcher/files/clisp-utf8-gentoo.patch b/dev-lisp/cl-fare-matcher/files/clisp-utf8-gentoo.patch
new file mode 100644
index 000000000000..2e722fa85928
--- /dev/null
+++ b/dev-lisp/cl-fare-matcher/files/clisp-utf8-gentoo.patch
@@ -0,0 +1,13 @@
+diff -ur matcher.orig/fare-matcher.lisp matcher/fare-matcher.lisp
+--- matcher.orig/fare-matcher.lisp 2003-10-29 05:45:27.000000000 -0600
++++ matcher/fare-matcher.lisp 2004-01-11 02:53:03.580057632 -0600
+@@ -5,7 +5,7 @@
+ ;;; Redistribution under modern BSD license.
+ ;;; http://www.no-carrier.org/fare-relicensed/
+
+-;;; Copyright (c) 2002 Faré Rideau <fare@tunes.org>
++;;; Copyright (c) 2002 Fare Rideau <fare@tunes.org>
+ ;;; All rights reserved.
+ ;;;
+ ;;; Redistribution and use in source and binary forms, with or without
+Only in matcher: fare-matcher.lisp~
diff --git a/dev-lisp/cl-fare-matcher/files/digest-cl-fare-matcher-1.1 b/dev-lisp/cl-fare-matcher/files/digest-cl-fare-matcher-1.1
new file mode 100644
index 000000000000..643e8815b1cf
--- /dev/null
+++ b/dev-lisp/cl-fare-matcher/files/digest-cl-fare-matcher-1.1
@@ -0,0 +1 @@
+MD5 d8197aa8c953e3b94475abe1d4a1a801 fare-matcher-ext-1.1.tar.gz 12531
diff --git a/dev-lisp/cl-fare-matcher/metadata.xml b/dev-lisp/cl-fare-matcher/metadata.xml
new file mode 100644
index 000000000000..852c9992b616
--- /dev/null
+++ b/dev-lisp/cl-fare-matcher/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+A library of macros and functions by Fare Rideau. It extends CL with
+pattern matching much like ML, but in a way well integrated with CL,
+and with the possibility of extending the core matcher with arbitrary
+primitives. This port is that of Matthew Danish's fare-matcher which
+has some extensions and clean-ups, packaged with an ASDF system.
+</longdescription>
+</pkgmetadata>