summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-09-03 21:42:59 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-09-03 21:42:59 +0000
commit12168223fc2677c210a4de5142e7fe2ae923b235 (patch)
tree44ca5862e7a3eefd63ebf6c72206f70ffa3eb42a /dev-lisp
parentStable for HPPA (bug #234088). (diff)
downloadgentoo-2-12168223fc2677c210a4de5142e7fe2ae923b235.tar.gz
gentoo-2-12168223fc2677c210a4de5142e7fe2ae923b235.tar.bz2
gentoo-2-12168223fc2677c210a4de5142e7fe2ae923b235.zip
replace virtual/tetex with virtual/latex-base and virtual/texi2dvi; quote a lot of variables
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/gcl/ChangeLog7
-rw-r--r--dev-lisp/gcl/gcl-2.6.7-r1.ebuild30
-rw-r--r--dev-lisp/gcl/gcl-2.6.7-r2.ebuild26
-rw-r--r--dev-lisp/gcl/gcl-2.6.7-r3.ebuild26
-rw-r--r--dev-lisp/gcl/gcl-2.6.7.ebuild30
5 files changed, 62 insertions, 57 deletions
diff --git a/dev-lisp/gcl/ChangeLog b/dev-lisp/gcl/ChangeLog
index 414b4864d9a3..4dbc6281c538 100644
--- a/dev-lisp/gcl/ChangeLog
+++ b/dev-lisp/gcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/gcl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/ChangeLog,v 1.52 2008/07/28 19:08:07 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/ChangeLog,v 1.53 2008/09/03 21:42:59 opfer Exp $
+
+ 03 Sep 2008; Christian Faulhammer <opfer@gentoo.org> gcl-2.6.7.ebuild,
+ gcl-2.6.7-r1.ebuild, gcl-2.6.7-r2.ebuild, gcl-2.6.7-r3.ebuild:
+ replace virtual/tetex with virtual/latex-base and virtual/texi2dvi; quote a
+ lot of variables
28 Jul 2008; Panagiotis Christopoulos <pchrist@gentoo.org> metadata.xml:
Update metadata.xml to include USE flag descriptions. Entries taken from
diff --git a/dev-lisp/gcl/gcl-2.6.7-r1.ebuild b/dev-lisp/gcl/gcl-2.6.7-r1.ebuild
index 803954cf6fc4..90868ca41f46 100644
--- a/dev-lisp/gcl/gcl-2.6.7-r1.ebuild
+++ b/dev-lisp/gcl/gcl-2.6.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7-r1.ebuild,v 1.6 2008/04/20 22:00:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7-r1.ebuild,v 1.7 2008/09/03 21:42:59 opfer Exp $
inherit elisp-common flag-o-matic autotools
@@ -20,18 +20,18 @@ RDEPEND="emacs? ( virtual/emacs )
X? ( x11-libs/libXt x11-libs/libXext x11-libs/libXmu x11-libs/libXaw )"
DEPEND="$RDEPEND
- doc? ( virtual/tetex )
+ doc? ( virtual/texi2dvi )
>=app-text/texi2html-1.64
>=sys-devel/autoconf-2.52"
src_unpack() {
unpack ${A}
- sed -e "s/gcl-doc/${PF}/g" ${S}/info/makefile > ${T}/makefile
- mv ${T}/makefile ${S}/info/makefile
- epatch ${FILESDIR}/${PV}-fix-configure.in-gentoo.patch || die
+ sed -e "s/gcl-doc/${PF}/g" "${S}"/info/makefile > "${T}"/makefile
+ mv "${T}"/makefile "${S}"/info/makefile
+ epatch "${FILESDIR}"/${PV}-fix-configure.in-gentoo.patch
eautoconf || die
- epatch ${FILESDIR}/flex-configure-LANG.patch # see Bug #122583
+ epatch "${FILESDIR}"/flex-configure-LANG.patch # see Bug #122583
}
src_compile() {
@@ -130,18 +130,18 @@ ${myconfig}"
src_install() {
export SANDBOX_ON=0
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
- rm -rf ${D}/usr/lib/${P}/info
- mv ${D}/default.el elisp/
+ rm -rf "${D}"/usr/lib/${P}/info
+ mv "${D}"/default.el elisp/
if use emacs; then
- mv elisp/add-default.el ${T}/50gcl-gentoo.el
- elisp-site-file-install ${T}/50gcl-gentoo.el
+ mv elisp/add-default.el "${T}"/50gcl-gentoo.el
+ elisp-site-file-install "${T}"/50gcl-gentoo.el
elisp-install ${PN} elisp/*
fperms 0644 /usr/share/emacs/site-lisp/gcl/*
else
- rm -rf ${D}/usr/share/emacs
+ rm -rf "${D}"/usr/share/emacs
fi
dosed /usr/bin/gcl
@@ -157,13 +157,13 @@ src_install() {
dodoc readme* RELEASE* ChangeLog* doc/*
- for i in ${D}/usr/share/doc/gcl-{tk,si}; do
- mv $i ${D}/usr/share/doc/${PF}
+ for i in "${D}"/usr/share/doc/gcl-{tk,si}; do
+ mv $i "${D}"/usr/share/doc/${PF}
done
doman gcl.1
- find ${D}/usr/lib/gcl-${PV}/ -type f \( -perm 640 -o -perm 750 \) -exec chmod 0644 '{}' \;
+ find "${D}"/usr/lib/gcl-${PV}/ -type f \( -perm 640 -o -perm 750 \) -exec chmod 0644 '{}' \;
}
pkg_postinst() {
diff --git a/dev-lisp/gcl/gcl-2.6.7-r2.ebuild b/dev-lisp/gcl/gcl-2.6.7-r2.ebuild
index 2eda09bc36eb..6d813b953853 100644
--- a/dev-lisp/gcl/gcl-2.6.7-r2.ebuild
+++ b/dev-lisp/gcl/gcl-2.6.7-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7-r2.ebuild,v 1.8 2007/08/31 10:16:53 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7-r2.ebuild,v 1.9 2008/09/03 21:42:59 opfer Exp $
inherit elisp-common flag-o-matic
@@ -22,9 +22,9 @@ RDEPEND="emacs? ( virtual/emacs )
>=dev-libs/gmp-4.1
tk? ( dev-lang/tk )
X? ( x11-libs/libXt x11-libs/libXext x11-libs/libXmu x11-libs/libXaw )
- virtual/tetex" # pdflatex (see Bug # 157903)
+ virtual/latex-base" # pdflatex (see Bug # 157903)
DEPEND="${RDEPEND}
- doc? ( virtual/tetex )
+ doc? ( virtual/texi2dvi )
>=app-text/texi2html-1.64
>=sys-devel/autoconf-2.52"
@@ -33,7 +33,7 @@ src_unpack() {
cd "${S}"
epatch ../gcl_${PV}-${DEB_PV}.diff
epatch "${FILESDIR}"/flex-configure-LANG.patch
- sed -ie "s/gcl-doc/${PF}/g" ${S}/info/makefile
+ sed -ie "s/gcl-doc/${PF}/g" "${S}"/info/makefile
}
src_compile() {
@@ -68,16 +68,16 @@ src_install() {
export SANDBOX_ON=0
make DESTDIR="${D}" install || die "make install failed"
- rm -rf ${D}/usr/lib/${P}/info
- mv ${D}/default.el elisp/
+ rm -rf "${D}"/usr/lib/${P}/info
+ mv "${D}"/default.el elisp/
if use emacs; then
- mv elisp/add-default.el ${T}/50gcl-gentoo.el
- elisp-site-file-install ${T}/50gcl-gentoo.el
+ mv elisp/add-default.el "${T}"/50gcl-gentoo.el
+ elisp-site-file-install "${T}"/50gcl-gentoo.el
elisp-install ${PN} elisp/*
fperms 0644 /usr/share/emacs/site-lisp/gcl/*
else
- rm -rf ${D}/usr/share/emacs
+ rm -rf "${D}"/usr/share/emacs
fi
dosed /usr/bin/gcl
@@ -93,14 +93,14 @@ src_install() {
dodoc readme* RELEASE* ChangeLog* doc/*
- for i in ${D}/usr/share/doc/gcl-{tk,si}; do
- mv $i ${D}/usr/share/doc/${PF}
+ for i in "${D}"/usr/share/doc/gcl-{tk,si}; do
+ mv $i "${D}"/usr/share/doc/${PF}
done
doman gcl.1
doinfo info/*.info*
- find ${D}/usr/lib/gcl-${PV}/ -type f \( -perm 640 -o -perm 750 \) -exec chmod 0644 '{}' \;
+ find "${D}"/usr/lib/gcl-${PV}/ -type f \( -perm 640 -o -perm 750 \) -exec chmod 0644 '{}' \;
}
pkg_postinst() {
diff --git a/dev-lisp/gcl/gcl-2.6.7-r3.ebuild b/dev-lisp/gcl/gcl-2.6.7-r3.ebuild
index fe35a99baa83..bd455138e246 100644
--- a/dev-lisp/gcl/gcl-2.6.7-r3.ebuild
+++ b/dev-lisp/gcl/gcl-2.6.7-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7-r3.ebuild,v 1.3 2007/12/22 13:12:38 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7-r3.ebuild,v 1.4 2008/09/03 21:42:59 opfer Exp $
#removing flag-o-matic results in make install failing due to a segfault
inherit elisp-common flag-o-matic
@@ -23,9 +23,9 @@ RDEPEND="emacs? ( virtual/emacs )
>=dev-libs/gmp-4.1
tk? ( dev-lang/tk )
X? ( x11-libs/libXt x11-libs/libXext x11-libs/libXmu x11-libs/libXaw )
- virtual/tetex" # pdflatex (see Bug # 157903)
+ virtual/latex-base" # pdflatex (see Bug # 157903)
DEPEND="${RDEPEND}
- doc? ( virtual/tetex )
+ doc? ( virtual/texi2dvi )
>=app-text/texi2html-1.64
>=sys-devel/autoconf-2.52"
@@ -34,7 +34,7 @@ src_unpack() {
cd "${S}"
epatch ../gcl_${PV}-${DEB_PV}.diff
epatch "${FILESDIR}"/flex-configure-LANG.patch
- sed -ie "s/gcl-doc/${PF}/g" ${S}/info/makefile
+ sed -ie "s/gcl-doc/${PF}/g" "${S}"/info/makefile
}
src_compile() {
@@ -70,16 +70,16 @@ src_install() {
export SANDBOX_ON=0
make DESTDIR="${D}" install || die "make install failed"
- rm -rf ${D}/usr/lib/${P}/info
- mv ${D}/default.el elisp/
+ rm -rf "${D}"/usr/lib/${P}/info
+ mv "${D}"/default.el elisp/
if use emacs; then
- mv elisp/add-default.el ${T}/50gcl-gentoo.el
- elisp-site-file-install ${T}/50gcl-gentoo.el
+ mv elisp/add-default.el "${T}"/50gcl-gentoo.el
+ elisp-site-file-install "${T}"/50gcl-gentoo.el
elisp-install ${PN} elisp/*
fperms 0644 /usr/share/emacs/site-lisp/gcl/*
else
- rm -rf ${D}/usr/share/emacs
+ rm -rf "${D}"/usr/share/emacs
fi
dosed /usr/bin/gcl
@@ -95,14 +95,14 @@ src_install() {
dodoc readme* RELEASE* ChangeLog* doc/*
- for i in ${D}/usr/share/doc/gcl-{tk,si}; do
- mv $i ${D}/usr/share/doc/${PF}
+ for i in "${D}"/usr/share/doc/gcl-{tk,si}; do
+ mv $i "${D}"/usr/share/doc/${PF}
done
doman gcl.1
doinfo info/*.info*
- find ${D}/usr/lib/gcl-${PV}/ -type f \( -perm 640 -o -perm 750 \) -exec chmod 0644 '{}' \;
+ find "${D}"/usr/lib/gcl-${PV}/ -type f \( -perm 640 -o -perm 750 \) -exec chmod 0644 '{}' \;
}
pkg_postinst() {
diff --git a/dev-lisp/gcl/gcl-2.6.7.ebuild b/dev-lisp/gcl/gcl-2.6.7.ebuild
index 303b44e134f8..c59af8ff5e32 100644
--- a/dev-lisp/gcl/gcl-2.6.7.ebuild
+++ b/dev-lisp/gcl/gcl-2.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7.ebuild,v 1.11 2008/04/20 22:00:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.6.7.ebuild,v 1.12 2008/09/03 21:42:59 opfer Exp $
inherit elisp-common flag-o-matic autotools
@@ -20,16 +20,16 @@ RDEPEND="emacs? ( virtual/emacs )
tk? ( dev-lang/tk )"
DEPEND="$RDEPEND
- doc? ( virtual/tetex )
+ doc? ( virtual/texi2dvi )
>=app-text/texi2html-1.64
>=sys-devel/autoconf-2.52"
src_unpack() {
unpack ${A}
- sed -e "s/gcl-doc/${PF}/g" ${S}/info/makefile > ${T}/makefile
- mv ${T}/makefile ${S}/info/makefile
- epatch ${FILESDIR}/${PV}-fix-configure.in-gentoo.patch || die
- epatch ${FILESDIR}/${P}-fix-configure.in-bfd.patch || die
+ sed -e "s/gcl-doc/${PF}/g" "${S}"/info/makefile > "${T}"/makefile
+ mv "${T}"/makefile "${S}"/info/makefile
+ epatch "${FILESDIR}"/${PV}-fix-configure.in-gentoo.patch
+ epatch "${FILESDIR}"/${P}-fix-configure.in-bfd.patch
eautoconf || die
}
@@ -128,18 +128,18 @@ ${myconfig}"
src_install() {
export SANDBOX_ON=0
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
- rm -rf ${D}/usr/lib/${P}/info
- mv ${D}/default.el elisp/
+ rm -rf "${D}"/usr/lib/${P}/info
+ mv "${D}"/default.el elisp/
if use emacs; then
- mv elisp/add-default.el ${T}/50gcl-gentoo.el
- elisp-site-file-install ${T}/50gcl-gentoo.el
+ mv elisp/add-default.el "${T}"/50gcl-gentoo.el
+ elisp-site-file-install "${T}"/50gcl-gentoo.el
elisp-install ${PN} elisp/*
fperms 0644 /usr/share/emacs/site-lisp/gcl/*
else
- rm -rf ${D}/usr/share/emacs
+ rm -rf "${D}"/usr/share/emacs
fi
dosed /usr/bin/gcl
@@ -155,11 +155,11 @@ src_install() {
dodoc readme* RELEASE* ChangeLog* doc/*
- for i in ${D}/usr/share/doc/gcl-{tk,si}; do
- mv $i ${D}/usr/share/doc/${PF}
+ for i in "${D}"/usr/share/doc/gcl-{tk,si}; do
+ mv $i "${D}"/usr/share/doc/${PF}
done
- find ${D}/usr/lib/gcl-${PV}/ -type f \( -perm 640 -o -perm 750 \) -exec chmod 0644 '{}' \;
+ find "${D}"/usr/lib/gcl-${PV}/ -type f \( -perm 640 -o -perm 750 \) -exec chmod 0644 '{}' \;
}
pkg_postinst() {