summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-01-11 14:50:19 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-01-11 14:50:19 +0000
commit0f83559c327d132aa4698b31c46e06903abecc66 (patch)
tree9f1d0524bcfab30c22fa0897fc68f6f8ee39a0c1 /dev-lisp
parentUpdated epix to the new latex-base virtual. (diff)
downloadgentoo-2-0f83559c327d132aa4698b31c46e06903abecc66.tar.gz
gentoo-2-0f83559c327d132aa4698b31c46e06903abecc66.tar.bz2
gentoo-2-0f83559c327d132aa4698b31c46e06903abecc66.zip
bump, bug 204011
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog9
-rw-r--r--dev-lisp/ecls/ecls-0.9j_p1.ebuild52
-rw-r--r--dev-lisp/ecls/files/digest-ecls-0.9j_p13
3 files changed, 62 insertions, 2 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index 03ea9e5a32e5..1eca91b83f59 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/ecls
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.25 2007/02/22 01:37:34 peper Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.26 2008/01/11 14:50:18 hkbst Exp $
+
+*ecls-0.9j_p1 (11 Jan 2008)
+
+ 11 Jan 2008; Marijn Schouten <hkBst@gentoo.org> +ecls-0.9j_p1.ebuild:
+ bump, bug 204011
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-lisp/ecls/ecls-0.9j_p1.ebuild b/dev-lisp/ecls/ecls-0.9j_p1.ebuild
new file mode 100644
index 000000000000..a0a85163aace
--- /dev/null
+++ b/dev-lisp/ecls/ecls-0.9j_p1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9j_p1.ebuild,v 1.1 2008/01/11 14:50:18 hkbst Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation."
+SRC_URI="mirror://sourceforge/${PN}/ecl-${PV/_/-}.tgz"
+HOMEPAGE="http://ecls.sourceforge.net/"
+SLOT="0"
+LICENSE="BSD LGPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="=dev-libs/gmp-4*
+ app-text/texi2html
+ >=dev-libs/boehm-gc-6.8"
+
+IUSE="X threads unicode"
+
+PROVIDE="virtual/commonlisp"
+
+S="${WORKDIR}"/ecl-${PV:0:4}
+
+_src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PV}-headers-gentoo.patch
+}
+
+src_compile() {
+ econf \
+ --with-system-gmp \
+ --enable-boehm=system \
+ --enable-longdouble \
+ --enable-c99-complex \
+ $(use_with threads) \
+ $(use_with threads __thread) \
+ $(use_with unicode) \
+ $(use_with X x) \
+ $(use_with X clx) \
+ || die "econf failed"
+ #parallel fails
+ emake -j1 || die "make failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ dohtml doc/*.html
+ dodoc ANNOUNCEMENT Copyright
+
+# dodoc "${FILESDIR}"/README.Gentoo
+}
diff --git a/dev-lisp/ecls/files/digest-ecls-0.9j_p1 b/dev-lisp/ecls/files/digest-ecls-0.9j_p1
new file mode 100644
index 000000000000..cbf20ceb6279
--- /dev/null
+++ b/dev-lisp/ecls/files/digest-ecls-0.9j_p1
@@ -0,0 +1,3 @@
+MD5 2e20a0fcad15f323b233488bbaef636a ecl-0.9j-p1.tgz 4972867
+RMD160 5281a50c202f76023b415db2d5227e88fe24afb8 ecl-0.9j-p1.tgz 4972867
+SHA256 dcbc139a202f78e99b0694dcc9813de1e5e810248982570537bf7a1dba4a6444 ecl-0.9j-p1.tgz 4972867