summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-16 16:31:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-16 16:31:39 +0000
commit8723f4c86815d73868f982c19d9187dab9457fc3 (patch)
treeb6cbdfc0b05e153f983189b37a01826b4fc49956 /dev-lisp/sbcl
parentCorrect --as-needed filtering and list a bug number for it. (diff)
downloadgentoo-2-8723f4c86815d73868f982c19d9187dab9457fc3.tar.gz
gentoo-2-8723f4c86815d73868f982c19d9187dab9457fc3.tar.bz2
gentoo-2-8723f4c86815d73868f982c19d9187dab9457fc3.zip
Correct --as-needed filtering.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'dev-lisp/sbcl')
-rw-r--r--dev-lisp/sbcl/ChangeLog8
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.10.ebuild6
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.11-r1.ebuild6
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.12.ebuild6
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.13.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.14.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.15.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.18.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.19.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.9.ebuild6
10 files changed, 29 insertions, 23 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index c901006b02f5..269105f69b56 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.148 2008/08/03 14:44:24 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.149 2008/11/16 16:31:39 flameeyes Exp $
+
+ 16 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org> sbcl-1.0.9.ebuild,
+ sbcl-1.0.10.ebuild, sbcl-1.0.11-r1.ebuild, sbcl-1.0.12.ebuild,
+ sbcl-1.0.13.ebuild, sbcl-1.0.14.ebuild, sbcl-1.0.15.ebuild,
+ sbcl-1.0.18.ebuild, sbcl-1.0.19.ebuild:
+ Correct --as-needed filtering.
03 Aug 2008; Panagiotis Christopoulos <pchrist@gentoo.org>
sbcl-1.0.18.ebuild:
diff --git a/dev-lisp/sbcl/sbcl-1.0.10.ebuild b/dev-lisp/sbcl/sbcl-1.0.10.ebuild
index 7c69a5a11b4b..538067486ad1 100644
--- a/dev-lisp/sbcl/sbcl-1.0.10.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.10.ebuild,v 1.3 2007/12/19 02:54:06 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.10.ebuild,v 1.4 2008/11/16 16:31:39 flameeyes Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -109,7 +109,7 @@ src_unpack() {
src_compile() {
local bindir="${WORKDIR}/sbcl-binary"
- filter-ldflags -Wl,--as-needed --as-needed # see Bug #132992
+ append-ldflags -Wl,--no-as-needed # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.11-r1.ebuild b/dev-lisp/sbcl/sbcl-1.0.11-r1.ebuild
index b3724736a3d7..f19959ef2f89 100644
--- a/dev-lisp/sbcl/sbcl-1.0.11-r1.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.11-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.11-r1.ebuild,v 1.3 2007/12/19 02:54:06 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.11-r1.ebuild,v 1.4 2008/11/16 16:31:39 flameeyes Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -111,7 +111,7 @@ src_unpack() {
src_compile() {
local bindir="${WORKDIR}/sbcl-binary"
- filter-ldflags -Wl,--as-needed --as-needed # see Bug #132992
+ append-ldflags -Wl,--no-as-needed # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.12.ebuild b/dev-lisp/sbcl/sbcl-1.0.12.ebuild
index 2b1858d2e506..2cb64c558206 100644
--- a/dev-lisp/sbcl/sbcl-1.0.12.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.12.ebuild,v 1.2 2007/12/19 02:54:06 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.12.ebuild,v 1.3 2008/11/16 16:31:39 flameeyes Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -113,7 +113,7 @@ src_unpack() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- filter-ldflags -Wl,--as-needed --as-needed # see Bug #132992
+ append-ldflags -Wl,--no-as-needed # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.13.ebuild b/dev-lisp/sbcl/sbcl-1.0.13.ebuild
index f18bc7096e21..d2691d11ae22 100644
--- a/dev-lisp/sbcl/sbcl-1.0.13.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.13.ebuild,v 1.1 2008/01/01 23:58:31 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.13.ebuild,v 1.2 2008/11/16 16:31:39 flameeyes Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -113,7 +113,7 @@ src_unpack() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- filter-ldflags -Wl,--as-needed --as-needed # see Bug #132992
+ append-ldflags -Wl,--no-as-needed # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.14.ebuild b/dev-lisp/sbcl/sbcl-1.0.14.ebuild
index 67a3cdf66b02..cb78e6985e85 100644
--- a/dev-lisp/sbcl/sbcl-1.0.14.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.14.ebuild,v 1.4 2008/05/01 09:13:47 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.14.ebuild,v 1.5 2008/11/16 16:31:39 flameeyes Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -113,7 +113,7 @@ src_unpack() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- filter-ldflags -Wl,--as-needed --as-needed # see Bug #132992
+ append-ldflags -Wl,--no-as-needed # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.15.ebuild b/dev-lisp/sbcl/sbcl-1.0.15.ebuild
index da41e5cb8437..f44a1dfe02e1 100644
--- a/dev-lisp/sbcl/sbcl-1.0.15.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.15.ebuild,v 1.2 2008/05/12 15:24:12 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.15.ebuild,v 1.3 2008/11/16 16:31:39 flameeyes Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -114,7 +114,7 @@ src_unpack() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- filter-ldflags -Wl,--as-needed --as-needed # see Bug #132992
+ append-ldflags -Wl,--no-as-needed # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.18.ebuild b/dev-lisp/sbcl/sbcl-1.0.18.ebuild
index 93e10ecd3b55..f55ea990a2d0 100644
--- a/dev-lisp/sbcl/sbcl-1.0.18.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.18.ebuild,v 1.2 2008/08/03 14:44:24 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.18.ebuild,v 1.3 2008/11/16 16:31:39 flameeyes Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -121,7 +121,7 @@ src_unpack() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- filter-ldflags -Wl,--as-needed --as-needed # see Bug #132992
+ append-ldflags -Wl,--no-as-needed # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.19.ebuild b/dev-lisp/sbcl/sbcl-1.0.19.ebuild
index 1afb0808c047..d04a0d1233f5 100644
--- a/dev-lisp/sbcl/sbcl-1.0.19.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.19.ebuild,v 1.2 2008/08/03 14:41:12 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.19.ebuild,v 1.3 2008/11/16 16:31:39 flameeyes Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -121,7 +121,7 @@ src_unpack() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- filter-ldflags -Wl,--as-needed --as-needed # see Bug #132992
+ append-ldflags -Wl,--no-as-needed # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.9.ebuild b/dev-lisp/sbcl/sbcl-1.0.9.ebuild
index 77e364022be6..a87398629aef 100644
--- a/dev-lisp/sbcl/sbcl-1.0.9.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.9.ebuild,v 1.8 2007/12/19 02:54:06 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.9.ebuild,v 1.9 2008/11/16 16:31:39 flameeyes Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -123,7 +123,7 @@ src_unpack() {
src_compile() {
local bindir="${WORKDIR}/sbcl-binary"
- filter-ldflags -Wl,--as-needed --as-needed # see Bug #132992
+ append-ldflags -Wl,--no-as-needed # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis