summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-11 16:51:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-11 16:51:39 +0000
commitc1254f995a7d0a3974f973d7355f666d8ff0857a (patch)
tree421fddbcc14f0db09b6583aeb89409860a43d92c /dev-lisp/openmcl-build-tools
parent- marking 2.1.3 stable for all supporting arches (diff)
downloadgentoo-2-c1254f995a7d0a3974f973d7355f666d8ff0857a.tar.gz
gentoo-2-c1254f995a7d0a3974f973d7355f666d8ff0857a.tar.bz2
gentoo-2-c1254f995a7d0a3974f973d7355f666d8ff0857a.zip
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lisp/openmcl-build-tools')
-rw-r--r--dev-lisp/openmcl-build-tools/ChangeLog10
-rw-r--r--dev-lisp/openmcl-build-tools/Manifest2
-rw-r--r--dev-lisp/openmcl-build-tools/files/digest-openmcl-build-tools-200405051
-rw-r--r--dev-lisp/openmcl-build-tools/metadata.xml15
-rw-r--r--dev-lisp/openmcl-build-tools/openmcl-build-tools-20040505.ebuild31
5 files changed, 59 insertions, 0 deletions
diff --git a/dev-lisp/openmcl-build-tools/ChangeLog b/dev-lisp/openmcl-build-tools/ChangeLog
new file mode 100644
index 000000000000..b99e89a1618b
--- /dev/null
+++ b/dev-lisp/openmcl-build-tools/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/openmcl-build-tools
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/openmcl-build-tools/ChangeLog,v 1.1 2005/03/11 16:51:04 mkennedy Exp $
+
+*openmcl-build-tools-20040505 (11 Mar 2005)
+
+ 11 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +openmcl-build-tools-20040505.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/openmcl-build-tools/Manifest b/dev-lisp/openmcl-build-tools/Manifest
new file mode 100644
index 000000000000..4a4c7b5f6f0e
--- /dev/null
+++ b/dev-lisp/openmcl-build-tools/Manifest
@@ -0,0 +1,2 @@
+MD5 408063b3dcedb652a5bbd9529da7779d openmcl-build-tools-20040505.ebuild 602
+MD5 cdc510f48391503558fabc7dbe45228f files/digest-openmcl-build-tools-20040505 83
diff --git a/dev-lisp/openmcl-build-tools/files/digest-openmcl-build-tools-20040505 b/dev-lisp/openmcl-build-tools/files/digest-openmcl-build-tools-20040505
new file mode 100644
index 000000000000..7063b43ee2d5
--- /dev/null
+++ b/dev-lisp/openmcl-build-tools/files/digest-openmcl-build-tools-20040505
@@ -0,0 +1 @@
+MD5 59543d8cb8e7c56366e1108ab35acb87 openmcl-build-tools_20040505-2.tar.gz 2723206
diff --git a/dev-lisp/openmcl-build-tools/metadata.xml b/dev-lisp/openmcl-build-tools/metadata.xml
new file mode 100644
index 000000000000..2183ba25a528
--- /dev/null
+++ b/dev-lisp/openmcl-build-tools/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+OpenMCL is a Common Lisp implementation. It began as a subset of the commercial
+MCL (Macintosh Common Lisp), and has grown into a full-featured, stable
+implementation. All of OpenMCL is released under the GNU Lesser General Public
+License. Commercial MCL does have a nicely integrated IDE and user interface
+libraries, which were not open-sourced and are not available in OpenMCL.
+
+This port contains the heap image and other tools for building OpenMCL (OpenMCL
+needs an OpenMCL heap image to build itself).
+</longdescription>
+</pkgmetadata>
diff --git a/dev-lisp/openmcl-build-tools/openmcl-build-tools-20040505.ebuild b/dev-lisp/openmcl-build-tools/openmcl-build-tools-20040505.ebuild
new file mode 100644
index 000000000000..7634e1bd64d2
--- /dev/null
+++ b/dev-lisp/openmcl-build-tools/openmcl-build-tools-20040505.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/openmcl-build-tools/openmcl-build-tools-20040505.ebuild,v 1.1 2005/03/11 16:51:04 mkennedy Exp $
+
+inherit eutils common-lisp-common-2
+
+DEB_PV=2
+
+DESCRIPTION="OpenMCL is a Common Lisp implementation, derived from Digitool's MCL product"
+HOMEPAGE="http://packages.debian.org/unstable/devel/openmcl-build-tools"
+SRC_URI="http://ftp.debian.org/debian/pool/main/o/${PN}/${PN}_${PV}-${DEB_PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ tar xfz ${S}/openmcl-interfaces-${PV:2}.tar.gz -C ${S} || die
+}
+
+src_install() {
+ insinto /usr/lib/openmcl
+ doins PPCCL-orig
+ doins -r ccl/headers
+ do-debian-credits
+}