summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-09-01 20:02:41 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-09-01 20:02:41 +0000
commited3f12b5fd21251e5e405a038ee9d95866559084 (patch)
tree40f29063de837745886672bfe8e4bb8cac881cb7 /dev-lisp/lush
parentinitial import (diff)
downloadgentoo-2-ed3f12b5fd21251e5e405a038ee9d95866559084.tar.gz
gentoo-2-ed3f12b5fd21251e5e405a038ee9d95866559084.tar.bz2
gentoo-2-ed3f12b5fd21251e5e405a038ee9d95866559084.zip
initial import
Diffstat (limited to 'dev-lisp/lush')
-rw-r--r--dev-lisp/lush/ChangeLog8
-rw-r--r--dev-lisp/lush/Manifest5
-rw-r--r--dev-lisp/lush/files/digest-lush-0.981
-rw-r--r--dev-lisp/lush/lush-0.98.ebuild33
4 files changed, 44 insertions, 3 deletions
diff --git a/dev-lisp/lush/ChangeLog b/dev-lisp/lush/ChangeLog
new file mode 100644
index 000000000000..3fa9534b490a
--- /dev/null
+++ b/dev-lisp/lush/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-lisp/lush
+# Copyright 2000-2003 Gentoo Technologies, Inc. and Matthew Kennedy <mkennedy@gentoo.org>; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/lush/ChangeLog,v 1.1 2003/09/01 20:02:39 mkennedy Exp $
+
+*lush-0.98 (01 Sep 2003)
+
+ 01 Sep 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ Initial import.
diff --git a/dev-lisp/lush/Manifest b/dev-lisp/lush/Manifest
index cf4d4c7583a4..20bdfd216516 100644
--- a/dev-lisp/lush/Manifest
+++ b/dev-lisp/lush/Manifest
@@ -1,4 +1,3 @@
-MD5 679d7de3a746a941ea56927edb82c7b2 lush-0.98.ebuild 1213
-MD5 e0d039af8dccbe4a14bc23d1d7de3a13 lush-0.98.ebuild~ 6007
-MD5 125ee013081b112d56a1d15507d72ef2 ChangeLog 3674
+MD5 7941db22a9a22b44c5cf50e45e8f876e lush-0.98.ebuild 1206
+MD5 18b394648309024b85afb379cf4e3bf5 ChangeLog 351
MD5 9017b31febc2ec8b075f9d84e5303b89 files/digest-lush-0.98 62
diff --git a/dev-lisp/lush/files/digest-lush-0.98 b/dev-lisp/lush/files/digest-lush-0.98
new file mode 100644
index 000000000000..ad3e688eb0af
--- /dev/null
+++ b/dev-lisp/lush/files/digest-lush-0.98
@@ -0,0 +1 @@
+MD5 5cdd85617b081ac358f98b834c176ef9 lush-0.98.tar.gz 3694006
diff --git a/dev-lisp/lush/lush-0.98.ebuild b/dev-lisp/lush/lush-0.98.ebuild
new file mode 100644
index 000000000000..3851a9f8ef0c
--- /dev/null
+++ b/dev-lisp/lush/lush-0.98.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc. and Matthew Kennedy <mkennedy@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/lush/lush-0.98.ebuild,v 1.1 2003/09/01 20:02:39 mkennedy Exp $
+
+DESCRIPTION="Lush is the Lisp User Shell. Lush is designed to be used in situations where one would want to combine the flexibility of a high-level, loosely-typed interpreted language, with the efficiency of a strongly-typed, natively-compiled language, and with the easy integration of code written in C, C++, or other languages."
+HOMEPAGE="http://lush.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lush/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X emacs"
+
+DEPEND="X? ( virtual/x11 )"
+# emacs? ( virtual/emacs )"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ local myconf="--without-x"
+ use X && myconf="${myconf} --with-x"
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc 0-CVS-INFO COPYING COPYRIGHT README README.binutils README.cygwin README.mac
+}