summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-11-25 09:04:33 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-11-25 09:04:33 +0000
commit461b7f88fe2dec53ae45a885fd90857cfc1c36d6 (patch)
tree92e014bdb13d580ce35fd88b067094a3e49016d9 /dev-lisp/common-lisp-controller
parentadded prepgamesdirs (diff)
downloadgentoo-2-461b7f88fe2dec53ae45a885fd90857cfc1c36d6.tar.gz
gentoo-2-461b7f88fe2dec53ae45a885fd90857cfc1c36d6.tar.bz2
gentoo-2-461b7f88fe2dec53ae45a885fd90857cfc1c36d6.zip
some permissions fixups, added robust, coreutils compat. thanks to apprentice_emacs@eathlink.net for test assistance.
Diffstat (limited to 'dev-lisp/common-lisp-controller')
-rw-r--r--dev-lisp/common-lisp-controller/ChangeLog7
-rw-r--r--dev-lisp/common-lisp-controller/Manifest5
-rw-r--r--dev-lisp/common-lisp-controller/common-lisp-controller-3.76-r1.ebuild12
-rw-r--r--dev-lisp/common-lisp-controller/files/3.76-coreutils-gentoo.patch42
4 files changed, 58 insertions, 8 deletions
diff --git a/dev-lisp/common-lisp-controller/ChangeLog b/dev-lisp/common-lisp-controller/ChangeLog
index 939ce9ffa27d..4c0ffac5ae96 100644
--- a/dev-lisp/common-lisp-controller/ChangeLog
+++ b/dev-lisp/common-lisp-controller/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/common-lisp-controller
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/common-lisp-controller/ChangeLog,v 1.5 2003/11/25 07:18:12 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/common-lisp-controller/ChangeLog,v 1.6 2003/11/25 09:04:29 mkennedy Exp $
+
+ 25 Nov 2003; <mkennedy@gentoo.org> common-lisp-controller-3.76-r1.ebuild,
+ files/3.76-coreutils-gentoo.patch:
+ some permissions fixups, added robust, coreutils compat. thanks to
+ apprentice_emacs@eathlink.net for test assistance.
*common-lisp-controller-3.76-r1 (20 Nov 2003)
diff --git a/dev-lisp/common-lisp-controller/Manifest b/dev-lisp/common-lisp-controller/Manifest
index cf0acf3b8fb7..3c3970c5f3f8 100644
--- a/dev-lisp/common-lisp-controller/Manifest
+++ b/dev-lisp/common-lisp-controller/Manifest
@@ -1,7 +1,7 @@
-MD5 85eb2a491787ad9f5c50189f08232860 ChangeLog 1178
+MD5 c773e1a5d2966c8a3cc0cdff68e14960 ChangeLog 1414
MD5 cb62d3c8a7d70151afccaa57bc208877 common-lisp-controller-3.64.ebuild 3597
MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
-MD5 53e9a32ccc2b1641282be09d7aa094c1 common-lisp-controller-3.76-r1.ebuild 3178
+MD5 0181e194e59267731568cf8ae0b89c93 common-lisp-controller-3.76-r1.ebuild 3254
MD5 7f5ac148cc5356dc87dabe21c680283a common-lisp-controller-3.76.ebuild 2848
MD5 531ca5d802bb5b70c234532655bbfa91 files/digest-common-lisp-controller-3.64 80
MD5 e5d6d4f73e65082fae7961087dc7f681 files/digest-common-lisp-controller-3.76 80
@@ -11,3 +11,4 @@ MD5 7bd53a475f418012e5986df364fdd6f2 files/inetd.conf-snippet 75
MD5 ad8d66b4cc62aa6b09805068265e89d1 files/README.Gentoo 642
MD5 fd599fefe360bfff34b78fb6dbf69344 files/clc-gentoo-3.76.patch.gz 8398
MD5 e5d6d4f73e65082fae7961087dc7f681 files/digest-common-lisp-controller-3.76-r1 80
+MD5 a28b04411f6963aa9b5ea21b77a67600 files/3.76-coreutils-gentoo.patch 1345
diff --git a/dev-lisp/common-lisp-controller/common-lisp-controller-3.76-r1.ebuild b/dev-lisp/common-lisp-controller/common-lisp-controller-3.76-r1.ebuild
index a2327cfdcd5a..bc8047526b50 100644
--- a/dev-lisp/common-lisp-controller/common-lisp-controller-3.76-r1.ebuild
+++ b/dev-lisp/common-lisp-controller/common-lisp-controller-3.76-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/common-lisp-controller/common-lisp-controller-3.76-r1.ebuild,v 1.1 2003/11/25 07:18:12 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/common-lisp-controller/common-lisp-controller-3.76-r1.ebuild,v 1.2 2003/11/25 09:04:29 mkennedy Exp $
DESCRIPTION="Common Lisp Controller"
HOMEPAGE="http://packages.debian.org/unstable/devel/common-lisp-controller.html"
@@ -17,10 +17,10 @@ DEPEND="dev-lisp/cl-defsystem3
S=${WORKDIR}/${PN}
-# src_unpack() {
-# unpack ${A}
-# epatch ${FILESDIR}/clc-gentoo-${PV}.patch.gz || die
-# }
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-coreutils-gentoo.patch || die
+}
# src_compile() {
# make clc-build-daemon-standalone clc-send-command-standalone || die
@@ -74,6 +74,8 @@ EOF
}
pkg_postinst() {
+ userdel cl-builder &>/dev/null || true
+ groupdel cl-builder &>/dev/null || true
enewgroup cl-builder 407
enewuser cl-builder 407 /bin/sh /usr/lib/common-lisp cl-builder
chown root:root /usr/lib/common-lisp
diff --git a/dev-lisp/common-lisp-controller/files/3.76-coreutils-gentoo.patch b/dev-lisp/common-lisp-controller/files/3.76-coreutils-gentoo.patch
new file mode 100644
index 000000000000..46ebcfe4c28a
--- /dev/null
+++ b/dev-lisp/common-lisp-controller/files/3.76-coreutils-gentoo.patch
@@ -0,0 +1,42 @@
+diff -ur common-lisp-controller.orig/clc-autobuild-check common-lisp-controller/clc-autobuild-check
+--- common-lisp-controller.orig/clc-autobuild-check 2003-05-08 13:47:52.000000000 -0500
++++ common-lisp-controller/clc-autobuild-check 2003-11-25 02:44:06.600594488 -0600
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/sh
+ set -e
+ # Checks if a package should be autobuild for an implementation
+ # Written by Kevin Rosenberg <kmr@debian.org>
+@@ -12,11 +12,11 @@
+ cat >&2 <<END
+ Usage: $progname impl library [OPTIONS]
+
+-$progname checks if a library should be auto-built for a
++$progname checks if a library should be auto-built for a
+ particular implementation. It returns a status code of 0 for "yes"
+ and 1 for "no". Returns 2 for a usage error.
+
+-Options:
++Options:
+ -h Print this short help message
+ END
+ }
+@@ -31,7 +31,7 @@
+ return
+ fi
+ if [ -r $file ]; then
+- first_line="$(cat $file | head -1)"
++ first_line="$(cat $file | head -n 1)"
+ if [ "$first_line" ]; then
+ first_line="$(echo "$first_line" | tr "[A-Z]" "[a-z]")"
+ if [ "$(expr "$first_line" : ".*\(yes\).*")" ]; then
+@@ -48,7 +48,7 @@
+
+ clc_bin_dir=/usr/lib/common-lisp/bin
+
+-if [ $# -lt 2 ]; then
++if [ $# -lt 2 ]; then
+ echo "Error: too few arguments" >&2
+ usage
+ exit 2
+Only in common-lisp-controller: clc-autobuild-check.~1.4.~