summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-11-19 17:20:55 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-11-19 17:20:55 +0000
commitf1522a65771bfcfb11e35f5c539ef40735a66714 (patch)
treebb71204c351b2666714e3d25146b14f2d6a3eee2 /dev-lisp/cmucl
parentfix bug 155602 (diff)
downloadgentoo-2-f1522a65771bfcfb11e35f5c539ef40735a66714.tar.gz
gentoo-2-f1522a65771bfcfb11e35f5c539ef40735a66714.tar.bz2
gentoo-2-f1522a65771bfcfb11e35f5c539ef40735a66714.zip
pkg_prerm should have been pkg_postrm; Fixes a problem where files from the previous CMUCL are left over.
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'dev-lisp/cmucl')
-rw-r--r--dev-lisp/cmucl/ChangeLog9
-rw-r--r--dev-lisp/cmucl/cmucl-19d_pre1-r1.ebuild72
-rw-r--r--dev-lisp/cmucl/files/digest-cmucl-19d_pre1-r16
3 files changed, 86 insertions, 1 deletions
diff --git a/dev-lisp/cmucl/ChangeLog b/dev-lisp/cmucl/ChangeLog
index 8188859e19b7..7ce41615d4eb 100644
--- a/dev-lisp/cmucl/ChangeLog
+++ b/dev-lisp/cmucl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lisp/cmucl
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/ChangeLog,v 1.23 2006/11/09 02:28:47 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/ChangeLog,v 1.24 2006/11/19 17:20:55 mkennedy Exp $
+
+*cmucl-19d_pre1-r1 (19 Nov 2006)
+
+ 19 Nov 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +cmucl-19d_pre1-r1.ebuild:
+ pkg_prerm should have been pkg_postrm; Fixes a problem where files from the
+ previous CMUCL are left over.
*cmucl-19d_pre1 (09 Nov 2006)
diff --git a/dev-lisp/cmucl/cmucl-19d_pre1-r1.ebuild b/dev-lisp/cmucl/cmucl-19d_pre1-r1.ebuild
new file mode 100644
index 000000000000..10e201663acc
--- /dev/null
+++ b/dev-lisp/cmucl/cmucl-19d_pre1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-19d_pre1-r1.ebuild,v 1.1 2006/11/19 17:20:55 mkennedy Exp $
+
+inherit common-lisp-common-3 eutils toolchain-funcs
+
+MY_PVL=${PV/_/-}
+MY_PV=${PV:0:3}
+
+DESCRIPTION="CMU Common Lisp is an implementation of ANSI Common Lisp"
+HOMEPAGE="http://www.cons.org/cmucl/"
+SRC_URI="http://common-lisp.net/project/cmucl/downloads/release/${MY_PV}/pre-release/cmucl-src-${MY_PVL}.tar.bz2
+ http://common-lisp.net/project/cmucl/downloads/release/${MY_PV}/pre-release/cmucl-${MY_PVL}-x86-linux.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc lesstif source"
+
+DEPEND="lesstif? ( x11-libs/lesstif )
+ !lesstif? ( x11-libs/openmotif )
+ sys-devel/bc"
+
+PROVIDE="virtual/commonlisp"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${MY_PV}-gentoo.patch || die
+ find ${S} -type f \( -name \*.sh -o -name linux-nm \) \
+ -exec chmod +x '{}' \;
+ # non-x86 maintainers, add to the the following and verify
+ if use lesstif || test -d /usr/X11R6/include/lesstif; then
+ sed -i -e 's,-I/usr/X11R6/include,-I/usr/X11R6/include/lesstif,g' \
+ -e 's,-L/usr/X11R6/lib,-L/usr/X11R6/lib/lesstif -L/usr/X11R6/lib,g' \
+ src/motif/server/Config.x86
+ fi
+ sed -i -e "s,CC = .*,CC = $(tc-getCC),g" src/lisp/Config.linux_gencgc
+ sed -i -e 's,"time","",g' src/tools/build.sh
+ sed -i -e "s,@CFLAGS@,$CFLAGS,g" src/lisp/Config.linux_gencgc src/motif/server/Config.x86
+}
+
+src_compile() {
+ export SANDBOX_ON=0
+ src/tools/build.sh -C "" -o "bin/lisp -core lib/cmucl/lib/lisp.core -batch -noinit -nositeinit" || die
+}
+
+src_install() {
+ src/tools/make-dist.sh -g -G root -O root build-4 ${MY_PVL} x86 linux
+ dodir /usr/share/doc
+ for i in cmucl-${MY_PVL}-x86-linux.{,extra.}tar.gz; do
+ tar xzpf $i -C ${D}/usr
+ done
+ mv ${D}/usr/doc ${D}/usr/share/doc/${PF}
+ mv ${D}/usr/man ${D}/usr/share/
+ impl-save-timestamp-hack cmucl || die
+}
+
+pkg_postinst() {
+ standard-impl-postinst cmucl
+}
+
+pkg_postrm() {
+ standard-impl-postrm cmucl /usr/bin/lisp
+}
+
+# pkg_postrm() {
+# if [ ! -x /usr/bin/lisp ]; then
+# rm -rf /usr/lib/cmucl/ || die
+# fi
+# }
diff --git a/dev-lisp/cmucl/files/digest-cmucl-19d_pre1-r1 b/dev-lisp/cmucl/files/digest-cmucl-19d_pre1-r1
new file mode 100644
index 000000000000..5485748a52e8
--- /dev/null
+++ b/dev-lisp/cmucl/files/digest-cmucl-19d_pre1-r1
@@ -0,0 +1,6 @@
+MD5 06dba01693757fb57bcad374cf720b9e cmucl-19d-pre1-x86-linux.tar.bz2 7600456
+RMD160 59d8e1211fb2e37ecabfd6cda9a706b57913d9ec cmucl-19d-pre1-x86-linux.tar.bz2 7600456
+SHA256 959157ee365d499d065f08d9ab385d2fff6adda11ce78d79ede0247fb4ba6e6e cmucl-19d-pre1-x86-linux.tar.bz2 7600456
+MD5 f759dc6fc7dc04d0bc4037b57575f659 cmucl-src-19d-pre1.tar.bz2 3780423
+RMD160 19a536c4492d1ef6a59f09b6e9d9b90da6a88408 cmucl-src-19d-pre1.tar.bz2 3780423
+SHA256 117e8fd8c7c02a7bcdbc055a23431ffc895c9766c1459b5daaf91203cbc9ad05 cmucl-src-19d-pre1.tar.bz2 3780423