summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-05-27 00:47:18 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-05-27 00:47:18 +0000
commitcc234cf136dd6180e764a86f38a76b356deccd1c (patch)
tree7a2a1a7c2c7454d10c64cde37a82df8678cb7377 /dev-lisp/cmucl
parentfixed date (diff)
downloadgentoo-2-cc234cf136dd6180e764a86f38a76b356deccd1c.tar.gz
gentoo-2-cc234cf136dd6180e764a86f38a76b356deccd1c.tar.bz2
gentoo-2-cc234cf136dd6180e764a86f38a76b356deccd1c.zip
Add dodir to fix installing issue. wrt bug 321375 and some missing files
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-lisp/cmucl')
-rw-r--r--dev-lisp/cmucl/ChangeLog6
-rw-r--r--dev-lisp/cmucl/cmucl-20a.ebuild4
-rw-r--r--dev-lisp/cmucl/files/cmuclrc9
-rw-r--r--dev-lisp/cmucl/files/site-init.lisp.in60
4 files changed, 77 insertions, 2 deletions
diff --git a/dev-lisp/cmucl/ChangeLog b/dev-lisp/cmucl/ChangeLog
index 4a308ba4f071..6eb62ac8f2d5 100644
--- a/dev-lisp/cmucl/ChangeLog
+++ b/dev-lisp/cmucl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/cmucl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/ChangeLog,v 1.32 2010/05/12 04:14:47 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/ChangeLog,v 1.33 2010/05/27 00:47:18 chiiph Exp $
+
+ 27 May 2010; Tomas Touceda <chiiph@gentoo.org> cmucl-20a.ebuild,
+ +files/cmuclrc, +files/site-init.lisp.in:
+ Add dodir to fix installing issue. wrt bug 321375 and some missing files
*cmucl-20a (12 May 2010)
diff --git a/dev-lisp/cmucl/cmucl-20a.ebuild b/dev-lisp/cmucl/cmucl-20a.ebuild
index bccfc4455e7b..111e7833f8ac 100644
--- a/dev-lisp/cmucl/cmucl-20a.ebuild
+++ b/dev-lisp/cmucl/cmucl-20a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-20a.ebuild,v 1.1 2010/05/12 04:14:47 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-20a.ebuild,v 1.2 2010/05/27 00:47:18 chiiph Exp $
EAPI="3"
@@ -58,6 +58,8 @@ src_install() {
env MANDIR=share/man/man1 DOCDIR=share/doc/${PF} \
src/tools/make-dist.sh -S -g -G root -O root build-4 ${MY_PV} x86 linux || die "Cannot build installation archive"
+ dodir /usr || die "dodir failed"
+
tar xzpf cmucl-${MY_PV}-x86-linux.tar.gz -C "${D}"/usr || die "Cannot install main system"
if use X ; then
tar xzpf cmucl-${MY_PV}-x86-linux.extra.tar.gz -C "${D}"/usr || die "Cannot install extra files"
diff --git a/dev-lisp/cmucl/files/cmuclrc b/dev-lisp/cmucl/files/cmuclrc
new file mode 100644
index 000000000000..e663e92af87a
--- /dev/null
+++ b/dev-lisp/cmucl/files/cmuclrc
@@ -0,0 +1,9 @@
+;;; -*- Mode: Lisp; Syntax: ANSI-Common-Lisp; indent-tabs-mode: nil -*-
+;;;
+
+(in-package :common-lisp-user)
+
+(if (probe-file "/etc/gentoo-init.lisp")
+ (load "/etc/gentoo-init.lisp")
+ (format t "~%;;; Warning: There is no /etc/gentoo-init.lisp file ~
+\(which should be provided by dev-lisp/gentoo-init"))
diff --git a/dev-lisp/cmucl/files/site-init.lisp.in b/dev-lisp/cmucl/files/site-init.lisp.in
new file mode 100644
index 000000000000..7a1010102003
--- /dev/null
+++ b/dev-lisp/cmucl/files/site-init.lisp.in
@@ -0,0 +1,60 @@
+;;; -*- Mode: Lisp; Package: System -*-
+;;;
+;;; **********************************************************************
+;;; This code was written as part of the CMU Common Lisp project at
+;;; Carnegie Mellon University, and has been placed in the public domain.
+;;;
+
+;;; Heavy modifications by Peter Van Eynde
+
+;;; More modifications for Gentoo by Matthew Kennedy
+;;; <mkennedy@gentoo.org>
+
+(in-package "SYSTEM")
+
+(ext:without-package-locks
+ (defun lisp-implementation-version ()
+ (format nil "~X-~A" c:byte-fasl-file-version "@VERSION@")))
+
+(if (probe-file "/etc/cmuclrc")
+ (load "/etc/cmuclrc")
+ (format t "~%;;; Warning: There is no /etc/cmuclrc file (which should have been created during emerge"))
+
+;;; If you have sources installed on your system, un-comment the following form
+;;; and change it to point to the source location. This will allow the Hemlock
+;;; "Edit Definition" command and the debugger to find sources for functions in
+;;; the core.
+(when (probe-file #p"/usr/share/common-lisp/source/cmucl/")
+ (setf (ext:search-list "target:")
+ '(
+ "/usr/share/common-lisp/source/cmucl/" ; object dir
+ )))
+
+;;; (setf (ext:search-list "library:") '("/usr/lib/cmucl/lib/"))
+;;; for safety...
+
+;;; Put your site name here...
+(setq *short-site-name* "Unknown")
+(setq *long-site-name* "Site name not initialized")
+
+(in-package :common-lisp-user)
+
+;;; newbie functions, delete if you don't like them
+
+(defun help ()
+ (format t "~
+Welcome to the Gentoo GNU/Linux port of CMUCL.
+
+The CMUCL REPL does not have GNU Readline-like support, however
+you may wish to install rlwap (see: app-misc/rlwrap) to achieve
+the same effect.
+
+If you think you found a bug, please use http://bugs.gentoo.org/
+
+Read the documentation in /usr/share/doc/@PF@.
+
+\(quit) exit Lisp
+\(describe 'foo) gives information about foo
+\(inspect '*foo*) interactively inspects *foo*
+\(apropos \"foo\") briefly describe all symbols which match \"foo\"
+"))