summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-17 16:04:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-17 16:04:29 +0000
commit8169fbcdf47a90a729602a2e0b9472c0084d7cc3 (patch)
tree189f025e7c8f3558e9709c0d668eb540abe50796 /dev-lisp/clisp
parentStable on alpha, bug #222533 (diff)
downloadgentoo-2-8169fbcdf47a90a729602a2e0b9472c0084d7cc3.tar.gz
gentoo-2-8169fbcdf47a90a729602a2e0b9472c0084d7cc3.tar.bz2
gentoo-2-8169fbcdf47a90a729602a2e0b9472c0084d7cc3.zip
Dont strip module objects as stripping will also remove common symbols and then we would expect failures when building modules against it
(Portage version: 2.1.5)
Diffstat (limited to 'dev-lisp/clisp')
-rw-r--r--dev-lisp/clisp/ChangeLog8
-rw-r--r--dev-lisp/clisp/clisp-2.44.1-r1.ebuild105
2 files changed, 112 insertions, 1 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index dacf5849f568..e7b340ed379a 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.77 2008/05/13 11:36:55 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.78 2008/05/17 16:04:29 aballier Exp $
+
+*clisp-2.44.1-r1 (17 May 2008)
+
+ 17 May 2008; Alexis Ballier <aballier@gentoo.org> +clisp-2.44.1-r1.ebuild:
+ Dont strip module objects as stripping will also remove common symbols and
+ then we would expect failures when building modules against it
13 May 2008; Marijn Schouten <hkBst@gentoo.org> -clisp-2.38.ebuild,
-clisp-2.38-r1.ebuild, -clisp-2.38-r2.ebuild, -clisp-2.39.ebuild,
diff --git a/dev-lisp/clisp/clisp-2.44.1-r1.ebuild b/dev-lisp/clisp/clisp-2.44.1-r1.ebuild
new file mode 100644
index 000000000000..49661858cbe1
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.44.1-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.44.1-r1.ebuild,v 1.1 2008/05/17 16:04:29 aballier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clisp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE="hyperspec X new-clx fastcgi gdbm gtk pcre postgres readline svm zlib"
+
+RDEPEND="dev-lisp/gentoo-init
+ virtual/libiconv
+ >=dev-libs/libsigsegv-2.4
+ >=dev-libs/ffcall-1.10
+ fastcgi? ( dev-libs/fcgi )
+ gdbm? ( sys-libs/gdbm )
+ gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
+ postgres? ( >=dev-db/postgresql-8.0 )
+ readline? ( sys-libs/readline )
+ pcre? ( dev-libs/libpcre )
+ svm? ( sci-libs/libsvm )
+ zlib? ( sys-libs/zlib )
+ X? ( new-clx? ( x11-libs/libXpm ) )
+ hyperspec? ( dev-lisp/hyperspec )"
+# * GNU gettext
+# + Not needed on systems with glibc 2.2 or newer, but recommended on all
+# other systems: needed if you want clisp with native language support.
+# sys-devel/gettext
+
+DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
+
+PROVIDE="virtual/commonlisp"
+
+enable_modules() {
+ [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
+ for m in "$@" ; do
+ einfo "enabling module $m"
+ myconf="${myconf} --with-module=${m}"
+ done
+}
+
+BUILDDIR="builddir"
+
+src_compile() {
+ # built-in features
+ local myconf="--with-ffcall"
+ use readline || myconf="${myconf} --with-noreadline"
+
+ # default modules
+ enable_modules wildcard rawsock i18n
+ # optional modules
+ use elibc_glibc && enable_modules bindings/glibc
+ if use X; then
+ if use new-clx; then
+ enable_modules clx/new-clx
+ else
+ enable_modules clx/mit-clx
+ fi
+ fi
+ if use postgres; then
+ enable_modules postgresql
+ CPPFLAGS="-I $(pg_config --includedir)"
+ fi
+ use fastcgi && enable_modules fastcgi
+ use gdbm && enable_modules gdbm
+ use gtk && enable_modules gtk2
+ use pcre && enable_modules pcre
+ use svm && enable_modules libsvm
+ use zlib && enable_modules zlib
+
+ # configure chokes on --infodir option
+ ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
+ ${myconf} ${BUILDDIR} || die "./configure failed"
+ cd ${BUILDDIR}
+ sed -i 's,"vi","nano",g' config.lisp
+ if use hyperspec; then
+ CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
+ else
+ CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
+ fi
+ sed -i "s,http://www.lisp.org/HyperSpec/,${CLHSROOT},g" config.lisp
+ IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
+ sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" config.lisp
+ # parallel build fails
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ pushd ${BUILDDIR}
+ make DESTDIR="${D}" prefix=/usr install-bin || die
+ doman clisp.1
+ dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
+ chmod a+x "${D}"/usr/$(get_libdir)/clisp-${PV}/clisp-link
+ # stripping them removes common symbols (defined but unitialised variables)
+ # which are then needed to build modules...
+ export STRIP_MASK="*/usr/$(get_libdir)/clisp-${PV}/*/*"
+ popd
+ dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
+ dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
+}