summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-04-03 17:29:51 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-04-03 17:29:51 +0000
commitc477583bcb38530bf02d29cf782404fcdefebecd (patch)
tree306ee5c9b0ee34b6e7928928d26066650cd859e8 /dev-lisp/clisp/files
parentppc stable, bug #128610 (diff)
downloadgentoo-2-c477583bcb38530bf02d29cf782404fcdefebecd.tar.gz
gentoo-2-c477583bcb38530bf02d29cf782404fcdefebecd.tar.bz2
gentoo-2-c477583bcb38530bf02d29cf782404fcdefebecd.zip
Missing x11-misc/imake dependencies; Resolves Bug #128288; Removed old ebuilds.
(Portage version: 2.1_pre7-r1)
Diffstat (limited to 'dev-lisp/clisp/files')
-rw-r--r--dev-lisp/clisp/files/2.33.2/README.Gentoo11
-rw-r--r--dev-lisp/clisp/files/2.33.2/clisp.sh118
-rw-r--r--dev-lisp/clisp/files/2.33.2/compilefix.patch17
-rw-r--r--dev-lisp/clisp/files/2.33.2/fastcgi-Makefile.in-gentoo.patch17
-rw-r--r--dev-lisp/clisp/files/2.33.2/glibc-linux.lisp-sigpause-gentoo.patch15
-rw-r--r--dev-lisp/clisp/files/2.33.2/install-clc.lisp15
-rw-r--r--dev-lisp/clisp/files/2.34/README.Gentoo11
-rw-r--r--dev-lisp/clisp/files/2.34/clisp.sh118
-rw-r--r--dev-lisp/clisp/files/2.34/fastcgi-Makefile.in-gentoo.patch17
-rw-r--r--dev-lisp/clisp/files/2.34/glibc-linux.lisp-sigpause-gentoo.patch15
-rw-r--r--dev-lisp/clisp/files/2.34/install-clc.lisp15
-rw-r--r--dev-lisp/clisp/files/2.35/README.Gentoo11
-rw-r--r--dev-lisp/clisp/files/2.35/clisp.sh118
-rw-r--r--dev-lisp/clisp/files/2.35/install-clc.lisp15
-rw-r--r--dev-lisp/clisp/files/2.36/README.Gentoo11
-rw-r--r--dev-lisp/clisp/files/2.36/clisp.sh118
-rw-r--r--dev-lisp/clisp/files/2.36/install-clc.lisp15
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.33.2-r21
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.34-r11
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.351
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.361
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.38-r13
22 files changed, 3 insertions, 661 deletions
diff --git a/dev-lisp/clisp/files/2.33.2/README.Gentoo b/dev-lisp/clisp/files/2.33.2/README.Gentoo
deleted file mode 100644
index 6bec925fb0d3..000000000000
--- a/dev-lisp/clisp/files/2.33.2/README.Gentoo
+++ /dev/null
@@ -1,11 +0,0 @@
- -*-outline-*-
-
-* Gentoo Specific Notes
-
-The CLISP port for Gentoo uses Common Lisp Controller related code
-(install-clc.lisp and clisp.sh) from Debian. This code contains the following
-copyright:
-
- ;;;; Copyright (c) 2004 Kevin M. Rosenberg
- ;;;; GNU GPL v2 license
-
diff --git a/dev-lisp/clisp/files/2.33.2/clisp.sh b/dev-lisp/clisp/files/2.33.2/clisp.sh
deleted file mode 100644
index f5ed6a1d8fce..000000000000
--- a/dev-lisp/clisp/files/2.33.2/clisp.sh
+++ /dev/null
@@ -1,118 +0,0 @@
-#!/bin/sh
-# Copyright (c) 2002 Kevin M. Rosenberg
-# GNU GPL v2 license
-
-if [ ! -f /usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp ] ; then
- echo "*** Can't find common-lisp-controller.lisp ***" >&2
- echo "Please report this as a bug" &>2
- exit 1
-fi
-
-clisp_dir=/usr/lib/clisp
-clc_lib_dir=/usr/lib/common-lisp/clisp
-
-builder=/usr/bin/clisp
-old_mem=$clisp_dir/full/lispinit.mem
-new_mem=$clisp_dir/full/lispinit-new.mem
-clean_mem=$clisp_dir/full/lispinit-clean.mem
-
-lisp_error()
-{
- echo "Error running $builder" >&2
- exit 1
-}
-
-mem_error()
-{
- echo "Error moving new lisp image $new_mem" >&2
- exit 1
-}
-
-
-case $1 in
- rebuild)
- echo $0 Rebuilding packages...
- shift
- while [ -x $builder ] && [ ! -z "$1" ] ; do
- echo ...rebuilding $1
- $builder -norc -q -M $old_mem -x "
-(let ((*compile-print* nil)
- (*compile-progress* nil)
- (*compile-verbose* nil)
- (*require-verbose* nil)
- (*load-verbose* nil)
- (mk::*load-source-if-no-binary* nil)
- (mk::*bother-user-if-no-binary* nil)
- (mk::*compile-during-load* t))
- (handler-case
- (progn
- (c-l-c:compile-library (quote $1))
- (ext:exit 0)
- )
- (error (e)
- (ignore-errors (format t \"~&Build error: ~A~%\" e))
- (finish-output)
- (ext:exit 1))))" || exit 1
- shift
- done
- ;;
- remove)
- echo $0 Removing packages...
- shift
- while [ ! -z "$1" ] ; do
- echo ...removing package $1
- rm -rf "${clc_lib_dir}/$1"
- shift
- done
- rmdir $clc_lib_dir 2> /dev/null
- ;;
- install-clc)
- echo Installing clc...
- if [ ! -f $clean_mem ]; then
- cp $old_mem $clean_mem
- fi
- if [ -x $clisp_dir/$lisp_builder ]; then
- $builder -norc -q -M $clean_mem \
- -x "
-(handler-case
- (progn
- (when (find-package :c-l-c) ; have to remove
- (delete-package :c-l-c)) ; for clisp workaround
- (load \"$clisp_dir/install-clc.lisp\")
- (saveinitmem \"${new_mem}\")
- (ext:exit 0))
- (error (e)
- (ignore-errors (format t \"~&install-clc error: ~A~%\" e))
- (finish-output)
- (ext:exit 1)))" || lisp_error
- mv $new_mem $old_mem || mem_error
- fi
- ;;
- remove-clc)
- if [ -f $clean_mem ]; then
- cp $clean_mem $old_mem
- else
- echo "Warning: Can't find original image file $clean_mem. Aborting." >& 2
- fi
- ;;
- make-user-image)
- if [ ! -f $2 ] ; then
- echo "Trying to make-user image, but can not find file $2" >&2
- exit 1
- fi
- $builder -norc -q -M $old_mem \
- -x "(progn
- (load \"$2\")
- (saveinitmem \"${new_mem}\"))
- (ext:exit 0)" || lisp_error
- mv $new_mem $old_mem || mem_error
- ;;
- *)
- echo "`basename $0`: Unknown command $1" >&2
- echo "Known commands are:" >&2
- echo "install-clc, remove-clc, rebuild, remove, and make-user-image" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/dev-lisp/clisp/files/2.33.2/compilefix.patch b/dev-lisp/clisp/files/2.33.2/compilefix.patch
deleted file mode 100644
index 507c72c22747..000000000000
--- a/dev-lisp/clisp/files/2.33.2/compilefix.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- clisp-2.33.2/src/genclisph.d.orig 2004-05-27 09:43:38.000000000 -0500
-+++ clisp-2.33.2/src/genclisph.d 2005-05-09 14:24:44.000000000 -0500
-@@ -891,13 +891,13 @@
- printf("#define sstring_length(ptr) sarray_length(ptr)\n");
- printf("#define Sstring_length(obj) sstring_length(TheSstring(obj))\n");
- printf("extern bool string_equal (object string1, object string2);\n");
-- /*
- #ifdef TYPECODES
- printf("#define Array_type_simple_bit_vector(atype) (%d+((atype)<<%d)",Array_type_sbvector,TB0);
- if (TB0+1 != TB1) printf("+((atype)&%d)",bit(TB0+1)-bit(TB1));
- if (TB1+1 != TB2) printf("+((atype)&%d)",bit(TB1+1)-bit(TB2));
- printf(")\n");
- #endif
-+ /*
- sprintf(buf,"struct { XRECORD_HEADER gcv_object_t pack_external_symbols%s; gcv_object_t pack_internal_symbols%s; gcv_object_t pack_shadowing_symbols%s; gcv_object_t pack_use_list%s; gcv_object_t pack_used_by_list%s; gcv_object_t pack_name%s; gcv_object_t pack_nicknames%s; } *",attribute_aligned_object,attribute_aligned_object,attribute_aligned_object,attribute_aligned_object,attribute_aligned_object,attribute_aligned_object,attribute_aligned_object);
- emit_typedef(buf,"Package");
- */
diff --git a/dev-lisp/clisp/files/2.33.2/fastcgi-Makefile.in-gentoo.patch b/dev-lisp/clisp/files/2.33.2/fastcgi-Makefile.in-gentoo.patch
deleted file mode 100644
index 5be16b23c032..000000000000
--- a/dev-lisp/clisp/files/2.33.2/fastcgi-Makefile.in-gentoo.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -ur clisp-2.33.2.original/modules/fastcgi/Makefile.in clisp-2.33.2/modules/fastcgi/Makefile.in
---- clisp-2.33.2.original/modules/fastcgi/Makefile.in 2004-03-03 08:41:54.000000000 -0600
-+++ clisp-2.33.2/modules/fastcgi/Makefile.in 2004-03-20 00:02:37.235191912 -0600
-@@ -22,10 +22,10 @@
- $(CLISP) -c fastcgi.lisp
-
- fastcgi.o: fastcgi.c
-- $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES) -I.. -c fastcgi.c
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -I.. -c fastcgi.c
-
- fastcgi_wrappers.o: fastcgi_wrappers.c
-- $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES) -I.. -c fastcgi_wrappers.c
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -I.. -c fastcgi_wrappers.c
-
- # Make a module
- clisp-module : all
-
diff --git a/dev-lisp/clisp/files/2.33.2/glibc-linux.lisp-sigpause-gentoo.patch b/dev-lisp/clisp/files/2.33.2/glibc-linux.lisp-sigpause-gentoo.patch
deleted file mode 100644
index f1d810f58411..000000000000
--- a/dev-lisp/clisp/files/2.33.2/glibc-linux.lisp-sigpause-gentoo.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -U4 --recursive clisp-2.33.2-orig/modules/bindings/glibc/linux.lisp clisp-2.33.2/modules/bindings/glibc/linux.lisp
---- clisp-2.33.2-orig/modules/bindings/glibc/linux.lisp 2004-07-27 11:51:00.403973848 -0400
-+++ clisp-2.33.2/modules/bindings/glibc/linux.lisp 2004-07-27 11:51:39.937963768 -0400
-@@ -34,8 +34,11 @@
- (def-c-type ulonglong uint64)
- (define-modify-macro orf () logior)
- (define-modify-macro andf () logand)
-
-+; Needed to choose sigpause version
-+(c-lines "#define __FAVOR_BSD~%~%")
-+
- ; ============================= <stddef.h> ====================================
-
- (c-lines "#include <stddef.h>~%")
-
diff --git a/dev-lisp/clisp/files/2.33.2/install-clc.lisp b/dev-lisp/clisp/files/2.33.2/install-clc.lisp
deleted file mode 100644
index 06cb217d32cf..000000000000
--- a/dev-lisp/clisp/files/2.33.2/install-clc.lisp
+++ /dev/null
@@ -1,15 +0,0 @@
-;;;; -*- Mode: Lisp; Package: CL-USER -*-
-;;;; Copyright (c) 2004 Kevin M. Rosenberg
-;;;; GNU GPL v2 license
-
-(in-package #:cl-user)
-
-(handler-case
- (load "/usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp")
- (error (e)
- (format t "Error during loading of common-lisp-controller.lisp: ~A~%" e)))
-
-(handler-case
- (common-lisp-controller:init-common-lisp-controller-v4 "clisp")
- (error (e)
- (format t "Error during init-common-lisp-controller-v4: ~A~%" e)))
diff --git a/dev-lisp/clisp/files/2.34/README.Gentoo b/dev-lisp/clisp/files/2.34/README.Gentoo
deleted file mode 100644
index 6bec925fb0d3..000000000000
--- a/dev-lisp/clisp/files/2.34/README.Gentoo
+++ /dev/null
@@ -1,11 +0,0 @@
- -*-outline-*-
-
-* Gentoo Specific Notes
-
-The CLISP port for Gentoo uses Common Lisp Controller related code
-(install-clc.lisp and clisp.sh) from Debian. This code contains the following
-copyright:
-
- ;;;; Copyright (c) 2004 Kevin M. Rosenberg
- ;;;; GNU GPL v2 license
-
diff --git a/dev-lisp/clisp/files/2.34/clisp.sh b/dev-lisp/clisp/files/2.34/clisp.sh
deleted file mode 100644
index f5ed6a1d8fce..000000000000
--- a/dev-lisp/clisp/files/2.34/clisp.sh
+++ /dev/null
@@ -1,118 +0,0 @@
-#!/bin/sh
-# Copyright (c) 2002 Kevin M. Rosenberg
-# GNU GPL v2 license
-
-if [ ! -f /usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp ] ; then
- echo "*** Can't find common-lisp-controller.lisp ***" >&2
- echo "Please report this as a bug" &>2
- exit 1
-fi
-
-clisp_dir=/usr/lib/clisp
-clc_lib_dir=/usr/lib/common-lisp/clisp
-
-builder=/usr/bin/clisp
-old_mem=$clisp_dir/full/lispinit.mem
-new_mem=$clisp_dir/full/lispinit-new.mem
-clean_mem=$clisp_dir/full/lispinit-clean.mem
-
-lisp_error()
-{
- echo "Error running $builder" >&2
- exit 1
-}
-
-mem_error()
-{
- echo "Error moving new lisp image $new_mem" >&2
- exit 1
-}
-
-
-case $1 in
- rebuild)
- echo $0 Rebuilding packages...
- shift
- while [ -x $builder ] && [ ! -z "$1" ] ; do
- echo ...rebuilding $1
- $builder -norc -q -M $old_mem -x "
-(let ((*compile-print* nil)
- (*compile-progress* nil)
- (*compile-verbose* nil)
- (*require-verbose* nil)
- (*load-verbose* nil)
- (mk::*load-source-if-no-binary* nil)
- (mk::*bother-user-if-no-binary* nil)
- (mk::*compile-during-load* t))
- (handler-case
- (progn
- (c-l-c:compile-library (quote $1))
- (ext:exit 0)
- )
- (error (e)
- (ignore-errors (format t \"~&Build error: ~A~%\" e))
- (finish-output)
- (ext:exit 1))))" || exit 1
- shift
- done
- ;;
- remove)
- echo $0 Removing packages...
- shift
- while [ ! -z "$1" ] ; do
- echo ...removing package $1
- rm -rf "${clc_lib_dir}/$1"
- shift
- done
- rmdir $clc_lib_dir 2> /dev/null
- ;;
- install-clc)
- echo Installing clc...
- if [ ! -f $clean_mem ]; then
- cp $old_mem $clean_mem
- fi
- if [ -x $clisp_dir/$lisp_builder ]; then
- $builder -norc -q -M $clean_mem \
- -x "
-(handler-case
- (progn
- (when (find-package :c-l-c) ; have to remove
- (delete-package :c-l-c)) ; for clisp workaround
- (load \"$clisp_dir/install-clc.lisp\")
- (saveinitmem \"${new_mem}\")
- (ext:exit 0))
- (error (e)
- (ignore-errors (format t \"~&install-clc error: ~A~%\" e))
- (finish-output)
- (ext:exit 1)))" || lisp_error
- mv $new_mem $old_mem || mem_error
- fi
- ;;
- remove-clc)
- if [ -f $clean_mem ]; then
- cp $clean_mem $old_mem
- else
- echo "Warning: Can't find original image file $clean_mem. Aborting." >& 2
- fi
- ;;
- make-user-image)
- if [ ! -f $2 ] ; then
- echo "Trying to make-user image, but can not find file $2" >&2
- exit 1
- fi
- $builder -norc -q -M $old_mem \
- -x "(progn
- (load \"$2\")
- (saveinitmem \"${new_mem}\"))
- (ext:exit 0)" || lisp_error
- mv $new_mem $old_mem || mem_error
- ;;
- *)
- echo "`basename $0`: Unknown command $1" >&2
- echo "Known commands are:" >&2
- echo "install-clc, remove-clc, rebuild, remove, and make-user-image" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/dev-lisp/clisp/files/2.34/fastcgi-Makefile.in-gentoo.patch b/dev-lisp/clisp/files/2.34/fastcgi-Makefile.in-gentoo.patch
deleted file mode 100644
index 902e1ac267c7..000000000000
--- a/dev-lisp/clisp/files/2.34/fastcgi-Makefile.in-gentoo.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -ur clisp-2.34.original/modules/fastcgi/Makefile.in clisp-2.34/modules/fastcgi/Makefile.in
---- clisp-2.34.original/modules/fastcgi/Makefile.in 2004-03-03 08:41:54.000000000 -0600
-+++ clisp-2.34/modules/fastcgi/Makefile.in 2004-03-20 00:02:37.235191912 -0600
-@@ -22,10 +22,10 @@
- $(CLISP) -c fastcgi.lisp
-
- fastcgi.o: fastcgi.c
-- $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES) -I.. -c fastcgi.c
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -I.. -c fastcgi.c
-
- fastcgi_wrappers.o: fastcgi_wrappers.c
-- $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES) -I.. -c fastcgi_wrappers.c
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -I.. -c fastcgi_wrappers.c
-
- # Make a module
- clisp-module : all
-
diff --git a/dev-lisp/clisp/files/2.34/glibc-linux.lisp-sigpause-gentoo.patch b/dev-lisp/clisp/files/2.34/glibc-linux.lisp-sigpause-gentoo.patch
deleted file mode 100644
index e7f6dd69a786..000000000000
--- a/dev-lisp/clisp/files/2.34/glibc-linux.lisp-sigpause-gentoo.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -U4 --recursive clisp-2.34-orig/modules/bindings/glibc/linux.lisp clisp-2.34/modules/bindings/glibc/linux.lisp
---- clisp-2.34-orig/modules/bindings/glibc/linux.lisp 2004-07-27 11:51:00.403973848 -0400
-+++ clisp-2.34/modules/bindings/glibc/linux.lisp 2004-07-27 11:51:39.937963768 -0400
-@@ -34,8 +34,11 @@
- (def-c-type ulonglong uint64)
- (define-modify-macro orf () logior)
- (define-modify-macro andf () logand)
-
-+; Needed to choose sigpause version
-+(c-lines "#define __FAVOR_BSD~%~%")
-+
- ; ============================= <stddef.h> ====================================
-
- (c-lines "#include <stddef.h>~%")
-
diff --git a/dev-lisp/clisp/files/2.34/install-clc.lisp b/dev-lisp/clisp/files/2.34/install-clc.lisp
deleted file mode 100644
index 06cb217d32cf..000000000000
--- a/dev-lisp/clisp/files/2.34/install-clc.lisp
+++ /dev/null
@@ -1,15 +0,0 @@
-;;;; -*- Mode: Lisp; Package: CL-USER -*-
-;;;; Copyright (c) 2004 Kevin M. Rosenberg
-;;;; GNU GPL v2 license
-
-(in-package #:cl-user)
-
-(handler-case
- (load "/usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp")
- (error (e)
- (format t "Error during loading of common-lisp-controller.lisp: ~A~%" e)))
-
-(handler-case
- (common-lisp-controller:init-common-lisp-controller-v4 "clisp")
- (error (e)
- (format t "Error during init-common-lisp-controller-v4: ~A~%" e)))
diff --git a/dev-lisp/clisp/files/2.35/README.Gentoo b/dev-lisp/clisp/files/2.35/README.Gentoo
deleted file mode 100644
index 6bec925fb0d3..000000000000
--- a/dev-lisp/clisp/files/2.35/README.Gentoo
+++ /dev/null
@@ -1,11 +0,0 @@
- -*-outline-*-
-
-* Gentoo Specific Notes
-
-The CLISP port for Gentoo uses Common Lisp Controller related code
-(install-clc.lisp and clisp.sh) from Debian. This code contains the following
-copyright:
-
- ;;;; Copyright (c) 2004 Kevin M. Rosenberg
- ;;;; GNU GPL v2 license
-
diff --git a/dev-lisp/clisp/files/2.35/clisp.sh b/dev-lisp/clisp/files/2.35/clisp.sh
deleted file mode 100644
index f5ed6a1d8fce..000000000000
--- a/dev-lisp/clisp/files/2.35/clisp.sh
+++ /dev/null
@@ -1,118 +0,0 @@
-#!/bin/sh
-# Copyright (c) 2002 Kevin M. Rosenberg
-# GNU GPL v2 license
-
-if [ ! -f /usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp ] ; then
- echo "*** Can't find common-lisp-controller.lisp ***" >&2
- echo "Please report this as a bug" &>2
- exit 1
-fi
-
-clisp_dir=/usr/lib/clisp
-clc_lib_dir=/usr/lib/common-lisp/clisp
-
-builder=/usr/bin/clisp
-old_mem=$clisp_dir/full/lispinit.mem
-new_mem=$clisp_dir/full/lispinit-new.mem
-clean_mem=$clisp_dir/full/lispinit-clean.mem
-
-lisp_error()
-{
- echo "Error running $builder" >&2
- exit 1
-}
-
-mem_error()
-{
- echo "Error moving new lisp image $new_mem" >&2
- exit 1
-}
-
-
-case $1 in
- rebuild)
- echo $0 Rebuilding packages...
- shift
- while [ -x $builder ] && [ ! -z "$1" ] ; do
- echo ...rebuilding $1
- $builder -norc -q -M $old_mem -x "
-(let ((*compile-print* nil)
- (*compile-progress* nil)
- (*compile-verbose* nil)
- (*require-verbose* nil)
- (*load-verbose* nil)
- (mk::*load-source-if-no-binary* nil)
- (mk::*bother-user-if-no-binary* nil)
- (mk::*compile-during-load* t))
- (handler-case
- (progn
- (c-l-c:compile-library (quote $1))
- (ext:exit 0)
- )
- (error (e)
- (ignore-errors (format t \"~&Build error: ~A~%\" e))
- (finish-output)
- (ext:exit 1))))" || exit 1
- shift
- done
- ;;
- remove)
- echo $0 Removing packages...
- shift
- while [ ! -z "$1" ] ; do
- echo ...removing package $1
- rm -rf "${clc_lib_dir}/$1"
- shift
- done
- rmdir $clc_lib_dir 2> /dev/null
- ;;
- install-clc)
- echo Installing clc...
- if [ ! -f $clean_mem ]; then
- cp $old_mem $clean_mem
- fi
- if [ -x $clisp_dir/$lisp_builder ]; then
- $builder -norc -q -M $clean_mem \
- -x "
-(handler-case
- (progn
- (when (find-package :c-l-c) ; have to remove
- (delete-package :c-l-c)) ; for clisp workaround
- (load \"$clisp_dir/install-clc.lisp\")
- (saveinitmem \"${new_mem}\")
- (ext:exit 0))
- (error (e)
- (ignore-errors (format t \"~&install-clc error: ~A~%\" e))
- (finish-output)
- (ext:exit 1)))" || lisp_error
- mv $new_mem $old_mem || mem_error
- fi
- ;;
- remove-clc)
- if [ -f $clean_mem ]; then
- cp $clean_mem $old_mem
- else
- echo "Warning: Can't find original image file $clean_mem. Aborting." >& 2
- fi
- ;;
- make-user-image)
- if [ ! -f $2 ] ; then
- echo "Trying to make-user image, but can not find file $2" >&2
- exit 1
- fi
- $builder -norc -q -M $old_mem \
- -x "(progn
- (load \"$2\")
- (saveinitmem \"${new_mem}\"))
- (ext:exit 0)" || lisp_error
- mv $new_mem $old_mem || mem_error
- ;;
- *)
- echo "`basename $0`: Unknown command $1" >&2
- echo "Known commands are:" >&2
- echo "install-clc, remove-clc, rebuild, remove, and make-user-image" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/dev-lisp/clisp/files/2.35/install-clc.lisp b/dev-lisp/clisp/files/2.35/install-clc.lisp
deleted file mode 100644
index 06cb217d32cf..000000000000
--- a/dev-lisp/clisp/files/2.35/install-clc.lisp
+++ /dev/null
@@ -1,15 +0,0 @@
-;;;; -*- Mode: Lisp; Package: CL-USER -*-
-;;;; Copyright (c) 2004 Kevin M. Rosenberg
-;;;; GNU GPL v2 license
-
-(in-package #:cl-user)
-
-(handler-case
- (load "/usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp")
- (error (e)
- (format t "Error during loading of common-lisp-controller.lisp: ~A~%" e)))
-
-(handler-case
- (common-lisp-controller:init-common-lisp-controller-v4 "clisp")
- (error (e)
- (format t "Error during init-common-lisp-controller-v4: ~A~%" e)))
diff --git a/dev-lisp/clisp/files/2.36/README.Gentoo b/dev-lisp/clisp/files/2.36/README.Gentoo
deleted file mode 100644
index 6bec925fb0d3..000000000000
--- a/dev-lisp/clisp/files/2.36/README.Gentoo
+++ /dev/null
@@ -1,11 +0,0 @@
- -*-outline-*-
-
-* Gentoo Specific Notes
-
-The CLISP port for Gentoo uses Common Lisp Controller related code
-(install-clc.lisp and clisp.sh) from Debian. This code contains the following
-copyright:
-
- ;;;; Copyright (c) 2004 Kevin M. Rosenberg
- ;;;; GNU GPL v2 license
-
diff --git a/dev-lisp/clisp/files/2.36/clisp.sh b/dev-lisp/clisp/files/2.36/clisp.sh
deleted file mode 100644
index f5ed6a1d8fce..000000000000
--- a/dev-lisp/clisp/files/2.36/clisp.sh
+++ /dev/null
@@ -1,118 +0,0 @@
-#!/bin/sh
-# Copyright (c) 2002 Kevin M. Rosenberg
-# GNU GPL v2 license
-
-if [ ! -f /usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp ] ; then
- echo "*** Can't find common-lisp-controller.lisp ***" >&2
- echo "Please report this as a bug" &>2
- exit 1
-fi
-
-clisp_dir=/usr/lib/clisp
-clc_lib_dir=/usr/lib/common-lisp/clisp
-
-builder=/usr/bin/clisp
-old_mem=$clisp_dir/full/lispinit.mem
-new_mem=$clisp_dir/full/lispinit-new.mem
-clean_mem=$clisp_dir/full/lispinit-clean.mem
-
-lisp_error()
-{
- echo "Error running $builder" >&2
- exit 1
-}
-
-mem_error()
-{
- echo "Error moving new lisp image $new_mem" >&2
- exit 1
-}
-
-
-case $1 in
- rebuild)
- echo $0 Rebuilding packages...
- shift
- while [ -x $builder ] && [ ! -z "$1" ] ; do
- echo ...rebuilding $1
- $builder -norc -q -M $old_mem -x "
-(let ((*compile-print* nil)
- (*compile-progress* nil)
- (*compile-verbose* nil)
- (*require-verbose* nil)
- (*load-verbose* nil)
- (mk::*load-source-if-no-binary* nil)
- (mk::*bother-user-if-no-binary* nil)
- (mk::*compile-during-load* t))
- (handler-case
- (progn
- (c-l-c:compile-library (quote $1))
- (ext:exit 0)
- )
- (error (e)
- (ignore-errors (format t \"~&Build error: ~A~%\" e))
- (finish-output)
- (ext:exit 1))))" || exit 1
- shift
- done
- ;;
- remove)
- echo $0 Removing packages...
- shift
- while [ ! -z "$1" ] ; do
- echo ...removing package $1
- rm -rf "${clc_lib_dir}/$1"
- shift
- done
- rmdir $clc_lib_dir 2> /dev/null
- ;;
- install-clc)
- echo Installing clc...
- if [ ! -f $clean_mem ]; then
- cp $old_mem $clean_mem
- fi
- if [ -x $clisp_dir/$lisp_builder ]; then
- $builder -norc -q -M $clean_mem \
- -x "
-(handler-case
- (progn
- (when (find-package :c-l-c) ; have to remove
- (delete-package :c-l-c)) ; for clisp workaround
- (load \"$clisp_dir/install-clc.lisp\")
- (saveinitmem \"${new_mem}\")
- (ext:exit 0))
- (error (e)
- (ignore-errors (format t \"~&install-clc error: ~A~%\" e))
- (finish-output)
- (ext:exit 1)))" || lisp_error
- mv $new_mem $old_mem || mem_error
- fi
- ;;
- remove-clc)
- if [ -f $clean_mem ]; then
- cp $clean_mem $old_mem
- else
- echo "Warning: Can't find original image file $clean_mem. Aborting." >& 2
- fi
- ;;
- make-user-image)
- if [ ! -f $2 ] ; then
- echo "Trying to make-user image, but can not find file $2" >&2
- exit 1
- fi
- $builder -norc -q -M $old_mem \
- -x "(progn
- (load \"$2\")
- (saveinitmem \"${new_mem}\"))
- (ext:exit 0)" || lisp_error
- mv $new_mem $old_mem || mem_error
- ;;
- *)
- echo "`basename $0`: Unknown command $1" >&2
- echo "Known commands are:" >&2
- echo "install-clc, remove-clc, rebuild, remove, and make-user-image" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/dev-lisp/clisp/files/2.36/install-clc.lisp b/dev-lisp/clisp/files/2.36/install-clc.lisp
deleted file mode 100644
index 06cb217d32cf..000000000000
--- a/dev-lisp/clisp/files/2.36/install-clc.lisp
+++ /dev/null
@@ -1,15 +0,0 @@
-;;;; -*- Mode: Lisp; Package: CL-USER -*-
-;;;; Copyright (c) 2004 Kevin M. Rosenberg
-;;;; GNU GPL v2 license
-
-(in-package #:cl-user)
-
-(handler-case
- (load "/usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp")
- (error (e)
- (format t "Error during loading of common-lisp-controller.lisp: ~A~%" e)))
-
-(handler-case
- (common-lisp-controller:init-common-lisp-controller-v4 "clisp")
- (error (e)
- (format t "Error during init-common-lisp-controller-v4: ~A~%" e)))
diff --git a/dev-lisp/clisp/files/digest-clisp-2.33.2-r2 b/dev-lisp/clisp/files/digest-clisp-2.33.2-r2
deleted file mode 100644
index d1380368af9a..000000000000
--- a/dev-lisp/clisp/files/digest-clisp-2.33.2-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ee4ea316db1e843dcb16094bf500012f clisp-2.33.2.tar.bz2 6091273
diff --git a/dev-lisp/clisp/files/digest-clisp-2.34-r1 b/dev-lisp/clisp/files/digest-clisp-2.34-r1
deleted file mode 100644
index cd5424c2e086..000000000000
--- a/dev-lisp/clisp/files/digest-clisp-2.34-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 68b20ad2d13bdc544e57000e38c856de clisp-2.34.tar.bz2 8000158
diff --git a/dev-lisp/clisp/files/digest-clisp-2.35 b/dev-lisp/clisp/files/digest-clisp-2.35
deleted file mode 100644
index fb1aef6b4353..000000000000
--- a/dev-lisp/clisp/files/digest-clisp-2.35
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a8e3136c4ecfb5deb65fe53e22ca2c07 clisp-2.35.tar.bz2 7902817
diff --git a/dev-lisp/clisp/files/digest-clisp-2.36 b/dev-lisp/clisp/files/digest-clisp-2.36
deleted file mode 100644
index 72e2ea68c72d..000000000000
--- a/dev-lisp/clisp/files/digest-clisp-2.36
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b6b5f6b7e6d0ce9f42bc07d59fbddc09 clisp-2.36.tar.bz2 8008221
diff --git a/dev-lisp/clisp/files/digest-clisp-2.38-r1 b/dev-lisp/clisp/files/digest-clisp-2.38-r1
new file mode 100644
index 000000000000..797910b544ad
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.38-r1
@@ -0,0 +1,3 @@
+MD5 960e1f6e232415c59b6978f92e62f30b clisp-2.38.tar.bz2 8078151
+RMD160 9070e1d7cd4db66de62f077b68a7fef7413da622 clisp-2.38.tar.bz2 8078151
+SHA256 98ddb7faa384b9b62621ac9af8b4416cbe1b6df420306fceea9e1e01a880e051 clisp-2.38.tar.bz2 8078151