summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-10-01 07:07:09 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-10-01 07:07:09 +0000
commit23573003f13c55fe127b4cc331251d589bdade37 (patch)
tree34f62dcac15d9404878c11a3649d69a8211fd401 /dev-lisp/cl-with
parentversion bump (diff)
downloadgentoo-2-23573003f13c55fe127b4cc331251d589bdade37.tar.gz
gentoo-2-23573003f13c55fe127b4cc331251d589bdade37.tar.bz2
gentoo-2-23573003f13c55fe127b4cc331251d589bdade37.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-lisp/cl-with')
-rw-r--r--dev-lisp/cl-with/ChangeLog11
-rw-r--r--dev-lisp/cl-with/Manifest6
-rw-r--r--dev-lisp/cl-with/cl-with-20020712.ebuild30
-rw-r--r--dev-lisp/cl-with/files/20020712-gentoo.patch23
-rw-r--r--dev-lisp/cl-with/files/digest-cl-with-200207121
-rw-r--r--dev-lisp/cl-with/files/with.asd12
-rw-r--r--dev-lisp/cl-with/metadata.xml5
7 files changed, 88 insertions, 0 deletions
diff --git a/dev-lisp/cl-with/ChangeLog b/dev-lisp/cl-with/ChangeLog
new file mode 100644
index 000000000000..b46cf70c680a
--- /dev/null
+++ b/dev-lisp/cl-with/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-lisp/cl-with
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-with/ChangeLog,v 1.1 2005/10/01 07:07:09 mkennedy Exp $
+
+*cl-with-20020712 (01 Oct 2005)
+
+ 01 Oct 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/20020712-gentoo.patch, +files/with.asd, +metadata.xml,
+ +cl-with-20020712.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
+
diff --git a/dev-lisp/cl-with/Manifest b/dev-lisp/cl-with/Manifest
new file mode 100644
index 000000000000..e39c2c1483ef
--- /dev/null
+++ b/dev-lisp/cl-with/Manifest
@@ -0,0 +1,6 @@
+MD5 7afd96a6199dae723a2a916d0a33bbe3 ChangeLog 374
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 04303c0db0432c055dacbb787c7e8fe3 cl-with-20020712.ebuild 704
+MD5 ccc12fa5ca6b0d3216f9781ff56c749a files/with.asd 240
+MD5 2f1ffabbcf47cfff7431333eaabf196e files/digest-cl-with-20020712 64
+MD5 d2b60c46eb4ada016acc95251aca2b96 files/20020712-gentoo.patch 795
diff --git a/dev-lisp/cl-with/cl-with-20020712.ebuild b/dev-lisp/cl-with/cl-with-20020712.ebuild
new file mode 100644
index 000000000000..10a6dd5ee81f
--- /dev/null
+++ b/dev-lisp/cl-with/cl-with-20020712.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-with/cl-with-20020712.ebuild,v 1.1 2005/10/01 07:07:09 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="With -- The Bastard Son of Loop"
+HOMEPAGE="http://www.geocities.com/mparker762/with.html"
+SRC_URI="mirror://gentoo/with-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-plus"
+
+S=${WORKDIR}/
+
+CLPACKAGE=with
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install *.lisp ${FILESDIR}/with.asd
+ common-lisp-system-symlink
+ dodoc license.txt
+}
diff --git a/dev-lisp/cl-with/files/20020712-gentoo.patch b/dev-lisp/cl-with/files/20020712-gentoo.patch
new file mode 100644
index 000000000000..eed9b6a78f47
--- /dev/null
+++ b/dev-lisp/cl-with/files/20020712-gentoo.patch
@@ -0,0 +1,23 @@
+Only in with: with.fasl
+diff -u with.orig/with.lisp with/with.lisp
+--- with.orig/with.lisp 2002-02-19 05:48:00.000000000 -0600
++++ with/with.lisp 2005-10-01 01:58:49.000000000 -0500
+@@ -187,7 +187,7 @@
+ collect x
+ do (pop lst))))
+ (values decltok decls lst)))
+- (t (error "~S is not a WITH declaration keyword"))))
++ (t (error "~S is not a WITH declaration keyword" decltok))))
+
+ (defun decl-terminating-kw-p (x)
+ (or (null x)
+@@ -215,7 +215,7 @@
+ (or (symbol-name-equal x "DO")
+ (symbol-name-equal x "IN")))
+
+-(defconstant +default-eq-toks+ '(= := <-))
++(cl+:defconst +default-eq-toks+ '(= := <-))
+ (defun kw-in-set-p (x &optional (valid-eq-toks +default-eq-toks+))
+ (member x valid-eq-toks :test #'symbol-name-equal))
+
+Only in with: with.lisp~
diff --git a/dev-lisp/cl-with/files/digest-cl-with-20020712 b/dev-lisp/cl-with/files/digest-cl-with-20020712
new file mode 100644
index 000000000000..e1b792e7ee45
--- /dev/null
+++ b/dev-lisp/cl-with/files/digest-cl-with-20020712
@@ -0,0 +1 @@
+MD5 ab9fbcb2e43242e92dc36f7d3c3f97a4 with-20020712.tar.gz 10240
diff --git a/dev-lisp/cl-with/files/with.asd b/dev-lisp/cl-with/files/with.asd
new file mode 100644
index 000000000000..45f81abc7b1a
--- /dev/null
+++ b/dev-lisp/cl-with/files/with.asd
@@ -0,0 +1,12 @@
+
+(defpackage #:with-system
+ (:use #:common-lisp
+ #:asdf))
+
+(in-package #:with-system)
+
+(defsystem #:with
+ :name "WITH"
+ :components ((:file "with-package")
+ (:file "with" :depends-on ("with-package")))
+ :depends-on (#:cl-plus))
diff --git a/dev-lisp/cl-with/metadata.xml b/dev-lisp/cl-with/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-with/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>