summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-06 10:59:40 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-06 10:59:40 +0000
commit6d9a3062be2734d9988f6aec2f2793b9b7dbde58 (patch)
treea6409a6a2ce86fb157b8b059c8298d8c7914c629 /dev-lisp/cl-unit/cl-unit-1.3.1.ebuild
parentnew upstream minor (diff)
downloadgentoo-2-6d9a3062be2734d9988f6aec2f2793b9b7dbde58.tar.gz
gentoo-2-6d9a3062be2734d9988f6aec2f2793b9b7dbde58.tar.bz2
gentoo-2-6d9a3062be2734d9988f6aec2f2793b9b7dbde58.zip
new upstream minor
Diffstat (limited to 'dev-lisp/cl-unit/cl-unit-1.3.1.ebuild')
-rw-r--r--dev-lisp/cl-unit/cl-unit-1.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lisp/cl-unit/cl-unit-1.3.1.ebuild b/dev-lisp/cl-unit/cl-unit-1.3.1.ebuild
new file mode 100644
index 000000000000..6f02eaf3b9a3
--- /dev/null
+++ b/dev-lisp/cl-unit/cl-unit-1.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-unit/cl-unit-1.3.1.ebuild,v 1.1 2003/10/06 10:59:38 mkennedy Exp $
+
+inherit common-lisp
+
+DEB_PV=1
+
+DESCRIPTION="A regression suite library for Common Lisp"
+HOMEPAGE="http://www.ancar.org/CLUnit/docs/CLUnit.html
+ http://packages.debian.org/unstable/devel/cl-unit.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-unit/${PN}_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-unit/cl-unit_${PV}-${DEB_PV}.diff.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=clunit
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch cl-unit_${PV}-${DEB_PV}.diff
+}
+
+src_install() {
+ common-lisp-install *.lisp ${FILESDIR}/clunit.asd
+ common-lisp-system-symlink
+ dodoc license readme
+ dohtml docs/*
+}