summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-09-24 08:34:38 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-09-24 08:34:38 +0000
commit62b698438548654b10024a8347ac4572a7fdb769 (patch)
tree4d652d90a18257baece38bb0a1eb607349102b6d /dev-lisp/cl-tbnl
parentStable on ppc64 (diff)
downloadgentoo-2-62b698438548654b10024a8347ac4572a7fdb769.tar.gz
gentoo-2-62b698438548654b10024a8347ac4572a7fdb769.tar.bz2
gentoo-2-62b698438548654b10024a8347ac4572a7fdb769.zip
New upstream version; Install test and contrib source.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-lisp/cl-tbnl')
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest14
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.8.0.ebuild39
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.01
4 files changed, 49 insertions, 12 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index 514e1d71bf5c..3166ecf2390a 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.13 2005/09/19 18:14:20 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.14 2005/09/24 08:34:38 mkennedy Exp $
+
+*cl-tbnl-0.8.0 (24 Sep 2005)
+
+ 24 Sep 2005; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.8.0.ebuild:
+ New upstream version; Install test and contrib source.
*cl-tbnl-0.7.0 (19 Sep 2005)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index f58e05671e13..1c80d02493d6 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 98d574aa4f2eebc6fe3b0e9eb07defc4 ChangeLog 2390
+MD5 c8bbcae6a680449ef858fdc8e8021b4e ChangeLog 2554
+MD5 4f6251dc7ab74bb48380e23399900ae6 cl-tbnl-0.8.0.ebuild 1011
MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
MD5 13a57ef6d8c46a29ceee1842cf0ac9f1 cl-tbnl-0.6.1.ebuild 981
MD5 aa1483295e02fc06e7c0e75fb9bd1fbc cl-tbnl-0.7.0.ebuild 981
+MD5 678e6c03cfaf2e63508ef3d589bf50ee files/digest-cl-tbnl-0.8.0 66
MD5 ddac1fb53cca7685915b56e8d9a7f2ff files/digest-cl-tbnl-0.6.1 66
MD5 a4d159c9065a78c213f1774bffa9bbf7 files/digest-cl-tbnl-0.7.0 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDLwA7yiNZaEAZA+ARAkVjAKCDQenVeWZ47h5mCSTQgwgKbkJEJQCfYzws
-T6t9ZsyOBjk+2IK17r4fl6Y=
-=R75i
------END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.8.0.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.8.0.ebuild
new file mode 100644
index 000000000000..ac6a6d3c3a01
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.8.0.ebuild,v 1.1 2005/09/24 08:34:38 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE="standalone"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+# RDEPEND="${DEPEND}
+# apache2? ( www-apache/mod_lisp2 ) !apache2? ( www-apache/mod_lisp )"
+
+RDEPEND="${DEPEND}
+ !standalone? ( www-apache/mod_lisp )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/
+ doins -r test contrib
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.0 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.0
new file mode 100644
index 000000000000..ead4362f8c4b
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.0
@@ -0,0 +1 @@
+MD5 e78ae39e689592e945e84e9de2debdb4 tbnl_0.8.0.orig.tar.gz 86193