summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-10-11 15:19:49 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-10-11 15:19:49 +0000
commitd4d80a5b3e60b149db99b83c9b1f28c2600bd1d2 (patch)
tree435efdab2347db7a00c2e4949f8e7a0fa801c5a2 /dev-lisp/cl-store
parentNew release. (diff)
downloadgentoo-2-d4d80a5b3e60b149db99b83c9b1f28c2600bd1d2.tar.gz
gentoo-2-d4d80a5b3e60b149db99b83c9b1f28c2600bd1d2.tar.bz2
gentoo-2-d4d80a5b3e60b149db99b83c9b1f28c2600bd1d2.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.0.53_rc4)
Diffstat (limited to 'dev-lisp/cl-store')
-rw-r--r--dev-lisp/cl-store/ChangeLog10
-rw-r--r--dev-lisp/cl-store/Manifest4
-rw-r--r--dev-lisp/cl-store/cl-store-0.6.ebuild39
-rw-r--r--dev-lisp/cl-store/files/0.6-custom.lisp-sbcl.patch21
-rw-r--r--dev-lisp/cl-store/files/digest-cl-store-0.61
-rw-r--r--dev-lisp/cl-store/metadata.xml5
6 files changed, 80 insertions, 0 deletions
diff --git a/dev-lisp/cl-store/ChangeLog b/dev-lisp/cl-store/ChangeLog
new file mode 100644
index 000000000000..e20dd15696ee
--- /dev/null
+++ b/dev-lisp/cl-store/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-store
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-store/ChangeLog,v 1.1 2005/10/11 15:19:49 mkennedy Exp $
+
+*cl-store-0.6 (11 Oct 2005)
+
+ 11 Oct 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/0.6-custom.lisp-sbcl.patch, +metadata.xml, +cl-store-0.6.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
+
diff --git a/dev-lisp/cl-store/Manifest b/dev-lisp/cl-store/Manifest
new file mode 100644
index 000000000000..05349f14af72
--- /dev/null
+++ b/dev-lisp/cl-store/Manifest
@@ -0,0 +1,4 @@
+MD5 6bcfa1b3a5a68cf6ec0d02b5207e0443 cl-store-0.6.ebuild 1076
+MD5 6fd9c721e013f77b673891f8c00d87d4 files/0.6-custom.lisp-sbcl.patch 830
+MD5 62ff491c1f72d0213204c8b70617cf59 files/digest-cl-store-0.6 60
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
diff --git a/dev-lisp/cl-store/cl-store-0.6.ebuild b/dev-lisp/cl-store/cl-store-0.6.ebuild
new file mode 100644
index 000000000000..131d4902daac
--- /dev/null
+++ b/dev-lisp/cl-store/cl-store-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-store/cl-store-0.6.ebuild,v 1.1 2005/10/11 15:19:49 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="CL-STORE is a Common Lisp library for serializing and deserializing Common Lisp objects."
+HOMEPAGE="http://common-lisp.net/project/cl-store/
+ http://www.cliki.net/cl-store"
+SRC_URI="http://common-lisp.net/project/cl-store/files/cl-store_${PV}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="sys-apps/texinfo"
+
+CLPACKAGE=cl-store
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-custom.lisp-sbcl.patch # Fix for SBCL >= 0.9.5
+}
+
+src_compile() {
+ makeinfo doc/cl-store.texi -o cl-store.info
+}
+
+src_install() {
+ ( shopt -s nullglob; for i in . clisp cmucl ecl lispworks sbcl; do
+ insinto $CLSOURCEROOT/$CLPACKAGE/$i
+ doins $i/*.{lisp,asd}
+ done )
+ common-lisp-system-symlink
+ dodoc LICENCE README ChangeLog
+ doinfo *.info*
+}
diff --git a/dev-lisp/cl-store/files/0.6-custom.lisp-sbcl.patch b/dev-lisp/cl-store/files/0.6-custom.lisp-sbcl.patch
new file mode 100644
index 000000000000..e850abba1455
--- /dev/null
+++ b/dev-lisp/cl-store/files/0.6-custom.lisp-sbcl.patch
@@ -0,0 +1,21 @@
+===================================================================
+RCS file: /project/cl-store/cvsroot/cl-store/sbcl/custom.lisp,v
+retrieving revision 1.8
+retrieving revision 1.10
+diff -u -r1.8 -r1.10
+--- cl-store/sbcl/custom.lisp 2005/05/05 12:58:57 1.8
++++ cl-store/sbcl/custom.lisp 2005/10/04 08:14:02 1.10
+@@ -52,9 +52,10 @@
+ (slot-value dd 'sb-kernel::name))
+
+ (defvar *sbcl-struct-inherits*
+- (list (get-layout (find-class t))
+- (get-layout (find-class 'sb-kernel:instance))
+- (get-layout (find-class 'cl:structure-object))))
++ `(,(get-layout (find-class t))
++ ,@(when-let (class (find-class 'sb-kernel:instance nil))
++ (list (get-layout class)))
++ ,(get-layout (find-class 'cl:structure-object))))
+
+ (defstruct (struct-def (:conc-name sdef-))
+ (supers (required-arg :supers) :type list)
diff --git a/dev-lisp/cl-store/files/digest-cl-store-0.6 b/dev-lisp/cl-store/files/digest-cl-store-0.6
new file mode 100644
index 000000000000..38e48df64843
--- /dev/null
+++ b/dev-lisp/cl-store/files/digest-cl-store-0.6
@@ -0,0 +1 @@
+MD5 d143af0f1be7573e2ea49deb155fe7b7 cl-store_0.6.tgz 43882
diff --git a/dev-lisp/cl-store/metadata.xml b/dev-lisp/cl-store/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-store/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>