summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-07-30 01:57:43 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-07-30 01:57:43 +0000
commit744fd33fe30118a714cf8d4ff5d1c49a478ab183 (patch)
tree944f09655811e9b4312c67f8200a905d1a83d33a /dev-lisp/cl-smtp/cl-smtp-20060404.1.ebuild
parentVersion bump (diff)
downloadgentoo-2-744fd33fe30118a714cf8d4ff5d1c49a478ab183.tar.gz
gentoo-2-744fd33fe30118a714cf8d4ff5d1c49a478ab183.tar.bz2
gentoo-2-744fd33fe30118a714cf8d4ff5d1c49a478ab183.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.1.1_pre3-r4)
Diffstat (limited to 'dev-lisp/cl-smtp/cl-smtp-20060404.1.ebuild')
-rw-r--r--dev-lisp/cl-smtp/cl-smtp-20060404.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-lisp/cl-smtp/cl-smtp-20060404.1.ebuild b/dev-lisp/cl-smtp/cl-smtp-20060404.1.ebuild
new file mode 100644
index 000000000000..55c37a02b278
--- /dev/null
+++ b/dev-lisp/cl-smtp/cl-smtp-20060404.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-smtp/cl-smtp-20060404.1.ebuild,v 1.1 2006/07/30 01:57:43 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A Common Lisp client library for the SMTP network protocol."
+HOMEPAGE="http://www.cliki.net/CL-SMTP"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lisp/cl-base64"
+
+CLPACKAGE=cl-smtp
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ dodoc CHANGELOG INSTALL *LICENSE README
+}