summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-06-20 16:25:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-06-20 16:25:21 +0000
commitb2dcb8bd722130a9a3503e30d4a7e2513fb12053 (patch)
tree974f3d61e8cdb626c87c6e2e8da2d69fc54205bf /dev-lisp/cl-salza/cl-salza-0.7.2.ebuild
parent(Portage version: 2.0.51.19) (Manifest recommit) (diff)
downloadgentoo-2-b2dcb8bd722130a9a3503e30d4a7e2513fb12053.tar.gz
gentoo-2-b2dcb8bd722130a9a3503e30d4a7e2513fb12053.tar.bz2
gentoo-2-b2dcb8bd722130a9a3503e30d4a7e2513fb12053.zip
update, cleanup
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-lisp/cl-salza/cl-salza-0.7.2.ebuild')
-rw-r--r--dev-lisp/cl-salza/cl-salza-0.7.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-lisp/cl-salza/cl-salza-0.7.2.ebuild b/dev-lisp/cl-salza/cl-salza-0.7.2.ebuild
new file mode 100644
index 000000000000..19e618bfbc8d
--- /dev/null
+++ b/dev-lisp/cl-salza/cl-salza-0.7.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-salza/cl-salza-0.7.2.ebuild,v 1.1 2005/06/20 16:25:21 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION='Salza is a Common Lisp Library that provides an FFI-less interface to the ZLIB and DEFLATE compressed data formats.'
+HOMEPAGE="http://www.cliki.net/Salza"
+SRC_URI="http://www.xach.com/lisp/salza/salza-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=salza
+
+S=${WORKDIR}/salza-${PV}
+
+src_install() {
+ common-lisp-install *.asd *.lisp
+ common-lisp-system-symlink
+ dodoc README ChangeLog LICENSE
+ docinto examples
+ dodoc examples/*
+}