summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-18 10:13:23 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-18 10:13:23 +0000
commit95251320fd0fce2e95e203d7ba842e880a8e9fb2 (patch)
treed4db40b819e482fe44c00f1a442d405df73294e6 /dev-lisp/cl-rsm-fuzzy/cl-rsm-fuzzy-1.2.ebuild
parentinitial import (diff)
downloadgentoo-2-95251320fd0fce2e95e203d7ba842e880a8e9fb2.tar.gz
gentoo-2-95251320fd0fce2e95e203d7ba842e880a8e9fb2.tar.bz2
gentoo-2-95251320fd0fce2e95e203d7ba842e880a8e9fb2.zip
initial import
Diffstat (limited to 'dev-lisp/cl-rsm-fuzzy/cl-rsm-fuzzy-1.2.ebuild')
-rw-r--r--dev-lisp/cl-rsm-fuzzy/cl-rsm-fuzzy-1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lisp/cl-rsm-fuzzy/cl-rsm-fuzzy-1.2.ebuild b/dev-lisp/cl-rsm-fuzzy/cl-rsm-fuzzy-1.2.ebuild
new file mode 100644
index 000000000000..f9a53ed1a44a
--- /dev/null
+++ b/dev-lisp/cl-rsm-fuzzy/cl-rsm-fuzzy-1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-fuzzy/cl-rsm-fuzzy-1.2.ebuild,v 1.1 2003/10/18 10:13:19 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="McIntire's Common Lisp Fuzzy Logic Library"
+HOMEPAGE="http://packages.debian.org/unstable/devel/cl-rsm-fuzzy.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-rsm-fuzzy/cl-rsm-fuzzy_1.2.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp "
+
+CLPACKAGE=rsm-fuzzy
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc copying copyright
+ dohtml *.html *.jpg
+ do-debian-credits
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}